aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2004-11-27 05:31:19 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2004-11-27 05:31:19 +0000
commit65b5a7c979fc28cf287b099f739651573deb1f42 (patch)
treed5344c8de31a3e51b872d1e0e12818d54e3352b0 /devel
parentba9248d7d982b7ac7716cba68927dbc02b05b2e4 (diff)
New port: devel/pear-HTML_TreeMenu Provides an API to create a HTML
tree PHP Based API creates a tree structure using a couple of small PHP classes. This can then be converted to javascript using the printMenu() method. The tree is dynamic in IE 4 or higher, NN6/Mozilla and Opera 7, and maintains state (the collapsed/expanded status of the branches) by using cookies. Other browsers display the tree fully expanded. Each node can have an optional link and icon. New API in 1.1 with many changes (see CVS for changelog) and new features, of which most came from Chip Chapin (http://www.chipchapin.com). PR: ports/74376 Submitted by: Antônio Carlos Venâncio Júnior <antonio@php.net>
Notes
Notes: svn path=/head/; revision=122552
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/pear-HTML_TreeMenu/Makefile40
-rw-r--r--devel/pear-HTML_TreeMenu/distinfo2
-rw-r--r--devel/pear-HTML_TreeMenu/pkg-descr11
4 files changed, 54 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index f858dee513fb..019064984645 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1083,6 +1083,7 @@
SUBDIR += pear-HTML_Table
SUBDIR += pear-HTML_Template_IT
SUBDIR += pear-HTML_Template_PHPLIB
+ SUBDIR += pear-HTML_TreeMenu
SUBDIR += pear-I18N
SUBDIR += pear-OLE
SUBDIR += pear-PEAR
diff --git a/devel/pear-HTML_TreeMenu/Makefile b/devel/pear-HTML_TreeMenu/Makefile
new file mode 100644
index 000000000000..5f499477fc02
--- /dev/null
+++ b/devel/pear-HTML_TreeMenu/Makefile
@@ -0,0 +1,40 @@
+# Ports collection makefile for: pear-HTML_TreeMenu
+# Date created: 25 September 2004
+# Whom: Antonio Carlos Venancio Junior (<antonio@inf.ufsc.br>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTML_TreeMenu
+PORTVERSION= 1.1.9
+CATEGORIES= devel www pear
+
+MAINTAINER= antonio@php.net
+COMMENT= Provides an API to create a HTML tree
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+CATEGORY= HTML
+FILES= TreeMenu.php
+DATA= TreeMenu.js images/branch.gif images/branchbottom.gif \
+ images/branchtop.gif images/folder.gif images/folder-expanded.gif \
+ images/line.gif images/linebottom.gif images/minus.gif \
+ images/minusbottom.gif images/minustop.gif images/plus.gif \
+ images/plusbottom.gif images/plustop.gif imagesAlt/branch.gif \
+ imagesAlt/branchbottom.gif imagesAlt/branchtop.gif imagesAlt/folder.gif \
+ imagesAlt/folder-expanded.gif imagesAlt/line.gif \
+ imagesAlt/linebottom.gif imagesAlt/minus.gif imagesAlt/minusbottom.gif \
+ imagesAlt/minustop.gif imagesAlt/plus.gif imagesAlt/plusbottom.gif \
+ imagesAlt/plustop.gif imagesAlt2/branch.gif imagesAlt2/branchbottom.gif \
+ imagesAlt2/branchtop.gif imagesAlt2/folder.gif \
+ imagesAlt2/folder-expanded.gif imagesAlt2/line.gif \
+ imagesAlt2/linebottom.gif imagesAlt2/minus.gif \
+ imagesAlt2/minusbottom.gif imagesAlt2/minustop.gif \
+ imagesAlt2/plus.gif imagesAlt2/plusbottom.gif imagesAlt2/plustop.gif
+DOCS= HTML_TreeMenu.doc HTML_TreeMenu.pdf example.php map_fs.php
+_DATADIR= .
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include <bsd.port.post.mk>
diff --git a/devel/pear-HTML_TreeMenu/distinfo b/devel/pear-HTML_TreeMenu/distinfo
new file mode 100644
index 000000000000..7e9f7c8da954
--- /dev/null
+++ b/devel/pear-HTML_TreeMenu/distinfo
@@ -0,0 +1,2 @@
+MD5 (PEAR/HTML_TreeMenu-1.1.9.tgz) = 88007ab29ac389ecc607c872de3ce684
+SIZE (PEAR/HTML_TreeMenu-1.1.9.tgz) = 49213
diff --git a/devel/pear-HTML_TreeMenu/pkg-descr b/devel/pear-HTML_TreeMenu/pkg-descr
new file mode 100644
index 000000000000..20613c603708
--- /dev/null
+++ b/devel/pear-HTML_TreeMenu/pkg-descr
@@ -0,0 +1,11 @@
+PHP Based API creates a tree structure using a couple of
+small PHP classes. This can then be converted to javascript
+using the printMenu() method. The tree is dynamic in
+IE 4 or higher, NN6/Mozilla and Opera 7, and maintains state
+(the collapsed/expanded status of the branches) by using cookies.
+Other browsers display the tree fully expanded. Each node can
+have an optional link and icon. New API in 1.1 with many changes
+(see CVS for changelog) and new features, of which most came
+from Chip Chapin (http://www.chipchapin.com).
+
+WWW: http://pear.php.net/package/HTML_TreeMenu/