aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-11-24 15:18:57 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-11-24 15:18:57 +0000
commit80f46c8915709c5e20ce53690b848e1cbd38908a (patch)
treebc4bb8fea86ebe4a239c41e329650ffe4ef2608a /devel
parentf11642b77c11aad12554dfcdf2e8da6dbc1f0349 (diff)
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/upp/Makefile6
-rw-r--r--devel/upp/distinfo4
-rw-r--r--devel/upp/files/patch-uppsrc_CtrlLib_TrayIconX11.cpp11
3 files changed, 5 insertions, 16 deletions
diff --git a/devel/upp/Makefile b/devel/upp/Makefile
index 0338b9098b55..db193d0bdd7a 100644
--- a/devel/upp/Makefile
+++ b/devel/upp/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= upp
-PORTVERSION= 3211
-PORTREVISION= 1
+PORTVERSION= 4179
CATEGORIES= devel x11-toolkits
MASTER_SITES= SF
DISTNAME= ${PORTNAME}-x11-src-${PORTVERSION}
@@ -15,6 +14,8 @@ DISTNAME= ${PORTNAME}-x11-src-${PORTVERSION}
MAINTAINER= m.sund@arcor.de
COMMENT= Ultimate++, a BSD-licensed, cross-platform, C/C++ RAD suite
+LICENSE= BSD
+
LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2 \
expat.6:${PORTSDIR}/textproc/expat2 \
notify.4:${PORTSDIR}/devel/libnotify
@@ -25,7 +26,6 @@ USE_GMAKE= yes
WRKSRC= ${WRKDIR}/${DISTNAME}
BUILD_WRKSRC= ${WRKSRC}/uppsrc
-LICENSE= BSD
MAKE_JOBS_SAFE= yes
MACRO_FLAGS= -DflagGUI -DflagGCC -DflagSHARED -DflagPOSIX -DflagBSD -DflagFREEBSD
diff --git a/devel/upp/distinfo b/devel/upp/distinfo
index 14989b1893b0..82b02f123de7 100644
--- a/devel/upp/distinfo
+++ b/devel/upp/distinfo
@@ -1,2 +1,2 @@
-SHA256 (upp-x11-src-3211.tar.gz) = 1791e8f6b7e2b72e0f5508145780f2c2e4b484d5ec5def87cb7639d2498c97d9
-SIZE (upp-x11-src-3211.tar.gz) = 31356144
+SHA256 (upp-x11-src-4179.tar.gz) = 74557a998b51fc8ea73ef03a3a2483861674f0a15b2bfb985a3772695ae405c7
+SIZE (upp-x11-src-4179.tar.gz) = 38392395
diff --git a/devel/upp/files/patch-uppsrc_CtrlLib_TrayIconX11.cpp b/devel/upp/files/patch-uppsrc_CtrlLib_TrayIconX11.cpp
deleted file mode 100644
index f1909b176c30..000000000000
--- a/devel/upp/files/patch-uppsrc_CtrlLib_TrayIconX11.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- uppsrc/CtrlLib/TrayIconX11.cpp.orig 2011-08-12 16:13:23.000000000 +0200
-+++ uppsrc/CtrlLib/TrayIconX11.cpp 2011-08-12 16:14:01.000000000 +0200
-@@ -106,7 +106,7 @@ void TrayIcon::Message(int type, const c
- NotifyNotification *notification = notify_notification_new (title, text
- , type == 1 ? "gtk-dialog-info"
- : type == 2 ? "gtk-dialog-warning"
-- : "gtk-dialog-error", NULL);
-+ : "gtk-dialog-error");
- notify_notification_set_timeout(notification, timeout * 1000);
- notify_notification_show (notification, &error);
- #endif