aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2009-04-11 13:23:05 +0000
committerStanislav Sedov <stas@FreeBSD.org>2009-04-11 13:23:05 +0000
commitc6762e80516b169cd71a8d7e68d0ed5b308f7e55 (patch)
treef23cbb8b9252353d844bff7e183b8b588e997854 /devel
parent3b03d918066c823f39536b8d108d1145c833a3dd (diff)
downloadports-c6762e80516b169cd71a8d7e68d0ed5b308f7e55.tar.gz
ports-c6762e80516b169cd71a8d7e68d0ed5b308f7e55.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/cil/files/patch-Makefile.in25
-rw-r--r--devel/deputy/files/patch-cil-Makefile.in27
-rw-r--r--devel/omake/Makefile9
-rw-r--r--devel/omake/distinfo6
-rw-r--r--devel/omake/files/patch-src_exec_omake_exec.ml11
-rw-r--r--devel/omake/pkg-plist2
6 files changed, 70 insertions, 10 deletions
diff --git a/devel/cil/files/patch-Makefile.in b/devel/cil/files/patch-Makefile.in
new file mode 100644
index 000000000000..42d13b825bba
--- /dev/null
+++ b/devel/cil/files/patch-Makefile.in
@@ -0,0 +1,25 @@
+--- Makefile.in.orig 2009-04-10 02:07:19.000000000 +0400
++++ Makefile.in 2009-04-10 02:07:54.000000000 +0400
+@@ -213,7 +213,7 @@
+ # build two libraries
+ .PHONY: cillib libcil
+ ifeq ($(NATIVECAML),1)
+-cillib: $(OBJDIR)/cil.$(CMXA) $(OBJDIR)/libcil.a
++cillib: $(OBJDIR)/cil.$(CMXA) $(OBJDIR)/libcil.o
+ else
+ cillib: $(OBJDIR)/cil.$(CMXA)
+ endif
+@@ -271,11 +271,11 @@
+ # be called from C code; this is like the target above, except
+ # it is callable from C instead of from Ocaml
+ ifeq ($(NATIVECAML),1)
+-$(OBJDIR)/libcil.a: $(OCAML_CIL_LIB_CMODULES:%=$(OBJDIR)/lib%.a) \
++$(OBJDIR)/libcil.o: $(OCAML_CIL_LIB_CMODULES:%=$(OBJDIR)/lib%.a) \
+ $(OCAML_CIL_LIB_MODULES:%=$(OBJDIR)/%.$(CMO))
+ ocamlopt -output-obj -o $@ $(CILLY_LIBS:%=%.cmxa) $^
+ else
+-$(OBJDIR)/libcil.a:
++$(OBJDIR)/libcil.o:
+ @echo "Can only build $@ when NATIVECAML is 1."
+ exit 2
+ endif
diff --git a/devel/deputy/files/patch-cil-Makefile.in b/devel/deputy/files/patch-cil-Makefile.in
index 3133b4902f04..5ade88951148 100644
--- a/devel/deputy/files/patch-cil-Makefile.in
+++ b/devel/deputy/files/patch-cil-Makefile.in
@@ -1,5 +1,14 @@
---- cil/Makefile.in.orig Fri Mar 16 17:10:11 2007
-+++ cil/Makefile.in Fri Mar 16 17:10:16 2007
+--- cil/Makefile.in.orig 2007-02-02 15:22:17.000000000 +0300
++++ cil/Makefile.in 2009-04-11 00:18:21.000000000 +0400
+@@ -210,7 +210,7 @@
+ # build two libraries
+ .PHONY: cillib libcil
+ ifeq ($(NATIVECAML),1)
+-cillib: $(OBJDIR)/cil.$(CMXA) $(OBJDIR)/libcil.a
++cillib: $(OBJDIR)/cil.$(CMXA) $(OBJDIR)/libcil.o
+ else
+ cillib: $(OBJDIR)/cil.$(CMXA)
+ endif
@@ -236,7 +236,7 @@
endif
# Now the extra features, with the first letter capitalized
@@ -9,3 +18,17 @@
$(foreach f,@EXTRAFEATURES@, \
"\n "`echo $f | cut -c 1 | tr "[a-z]" "[A-Z]"``echo $f | cut -c 2-`".feature;") >> $@
echo "]" >>$@
+@@ -267,11 +267,11 @@
+ # be called from C code; this is like the target above, except
+ # it is callable from C instead of from Ocaml
+ ifeq ($(NATIVECAML),1)
+-$(OBJDIR)/libcil.a: $(OCAML_CIL_LIB_CMODULES:%=$(OBJDIR)/lib%.a) \
++$(OBJDIR)/libcil.o: $(OCAML_CIL_LIB_CMODULES:%=$(OBJDIR)/lib%.a) \
+ $(OCAML_CIL_LIB_MODULES:%=$(OBJDIR)/%.$(CMO))
+ ocamlopt -output-obj -o $@ $(CILLY_LIBS:%=%.cmxa) $^
+ else
+-$(OBJDIR)/libcil.a:
++$(OBJDIR)/libcil.o:
+ @echo "Can only build $@ when NATIVECAML is 1."
+ exit 2
+ endif
diff --git a/devel/omake/Makefile b/devel/omake/Makefile
index 0477d5df817b..da1f7329d5e3 100644
--- a/devel/omake/Makefile
+++ b/devel/omake/Makefile
@@ -7,12 +7,11 @@
#
PORTNAME= omake
-PORTVERSION= 0.9.8.1
-PORTREVISION= 1
+PORTVERSION= 0.9.8.5
+PORTREVISION= 0
CATEGORIES= devel
-MASTER_SITES= http://omake.metaprl.org/downloads/ \
- http://sunner.elcomnet.ru/~stas/
-DISTNAME= omake-0.9.8.1-1
+MASTER_SITES= http://omake.metaprl.org/downloads/
+DISTNAME= omake-0.9.8.5-3
MAINTAINER= stas@FreeBSD.org
COMMENT= A flexible build system
diff --git a/devel/omake/distinfo b/devel/omake/distinfo
index adbe66520f35..2660a07b9049 100644
--- a/devel/omake/distinfo
+++ b/devel/omake/distinfo
@@ -1,3 +1,3 @@
-MD5 (omake-0.9.8.1-1.tar.gz) = 1d0fb573fab8f4de38993f81f3d383cd
-SHA256 (omake-0.9.8.1-1.tar.gz) = 3265293803e75dcea72c62ebb18022b16e1984d59f1ab6cc4397b17b976f7500
-SIZE (omake-0.9.8.1-1.tar.gz) = 2919405
+MD5 (omake-0.9.8.5-3.tar.gz) = d114b3c4201808aacd73ec1a98965c47
+SHA256 (omake-0.9.8.5-3.tar.gz) = 5b675e09f49ff8249a775798f25ab127515cf2fed39527b202784757a35eddad
+SIZE (omake-0.9.8.5-3.tar.gz) = 3321245
diff --git a/devel/omake/files/patch-src_exec_omake_exec.ml b/devel/omake/files/patch-src_exec_omake_exec.ml
new file mode 100644
index 000000000000..249096522da8
--- /dev/null
+++ b/devel/omake/files/patch-src_exec_omake_exec.ml
@@ -0,0 +1,11 @@
+--- src/exec/omake_exec.ml.orig 2009-04-11 14:50:31.000000000 +0400
++++ src/exec/omake_exec.ml 2009-04-11 14:50:36.000000000 +0400
+@@ -46,8 +46,6 @@
+ open Omake_options
+ open Omake_command_type
+
+-external sync : unit -> unit = "caml_sync"
+-
+ module Exec =
+ struct
+ (*
diff --git a/devel/omake/pkg-plist b/devel/omake/pkg-plist
index 856161ca6037..30751b70dda3 100644
--- a/devel/omake/pkg-plist
+++ b/devel/omake/pkg-plist
@@ -14,6 +14,7 @@ lib/omake/build/svn_realclean.om
lib/omake/configure/Configure.om
lib/omake/configure/X.om
lib/omake/configure/fam.om
+lib/omake/configure/fs_case_sensitive.om
lib/omake/configure/ncurses.om
lib/omake/configure/readline.om
lib/omake/configure/snprintf.om
@@ -46,6 +47,7 @@ lib/omake/parse/C/Parse.om
%%PORTDOCS%%%%DOCSDIR%%/omake-fun-index.html
%%PORTDOCS%%%%DOCSDIR%%/omake-grammar.html
%%PORTDOCS%%%%DOCSDIR%%/omake-language-examples.html
+%%PORTDOCS%%%%DOCSDIR%%/omake-language-naming.html
%%PORTDOCS%%%%DOCSDIR%%/omake-language.html
%%PORTDOCS%%%%DOCSDIR%%/omake-obj-index.html
%%PORTDOCS%%%%DOCSDIR%%/omake-option-index.html