aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2004-03-23 14:48:00 +0000
committerMathieu Arnold <mat@FreeBSD.org>2004-03-23 14:48:00 +0000
commitf439e6d08f24534472bf637532d3fb48cf95c066 (patch)
treef4a4dad5d29defcdc0d9098adf43c6fd9462142c /devel
parent2fc319beb5bb3862a1cd838aac0a2ec6ac6456a3 (diff)
downloadports-f439e6d08f24534472bf637532d3fb48cf95c066.tar.gz
ports-f439e6d08f24534472bf637532d3fb48cf95c066.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Data-Dumper/Makefile29
-rw-r--r--devel/p5-Data-Dumper/distinfo2
-rw-r--r--devel/p5-Data-Dumper/pkg-descr12
-rw-r--r--devel/p5-Data-Dumper/pkg-plist7
5 files changed, 51 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 9168cf27179a..e5f779bd5e0a 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -624,6 +624,7 @@
SUBDIR += p5-Data-Compare
SUBDIR += p5-Data-Dump
SUBDIR += p5-Data-DumpXML
+ SUBDIR += p5-Data-Dumper
SUBDIR += p5-Data-Flow
SUBDIR += p5-Data-HexDump
SUBDIR += p5-Data-Hexdumper
diff --git a/devel/p5-Data-Dumper/Makefile b/devel/p5-Data-Dumper/Makefile
new file mode 100644
index 000000000000..82956a8b5198
--- /dev/null
+++ b/devel/p5-Data-Dumper/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: p5-Data-Dumper
+# Date created: 23 March 2003
+# Whom: mat
+#
+# $FreeBSD$
+#
+
+PORTNAME= Data-Dumper
+PORTVERSION= 2.121
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Data
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= mat@FreeBSD.org
+COMMENT= Stringified perl data structures, suitable for both printing and eval
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} >= 500801
+IGNORE="Alread included in perl ${PERL_VER}"
+.endif
+.if ${PERL_LEVEL} < 500601
+IGNORE="Need at least perl 5.6.1 to build"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Data-Dumper/distinfo b/devel/p5-Data-Dumper/distinfo
new file mode 100644
index 000000000000..94b6c0d74fdc
--- /dev/null
+++ b/devel/p5-Data-Dumper/distinfo
@@ -0,0 +1,2 @@
+MD5 (Data-Dumper-2.121.tar.gz) = 10d6ff7a85fa3e5f91fcb2e6593cfd1b
+SIZE (Data-Dumper-2.121.tar.gz) = 31931
diff --git a/devel/p5-Data-Dumper/pkg-descr b/devel/p5-Data-Dumper/pkg-descr
new file mode 100644
index 000000000000..515090969838
--- /dev/null
+++ b/devel/p5-Data-Dumper/pkg-descr
@@ -0,0 +1,12 @@
+Converts a data structure into a sequence of perl statements sufficient for
+recreating the original via eval. This module is very similar in concept to
+Data::Dumper and Data::Dump, with the major differences being that this module
+is designed to output to a stream instead of constructing its output in memory,
+and that the traversal over the data structure is effectively breadth first
+versus the depth first traversal done by the others.
+
+In fact the data structure is scanned twice, first in breadth first mode to
+perform structural analysis, and then in depth first mode to actually produce
+the output, but obeying the depth relationships of the first pass.
+
+WWW: http://search.cpan.org/dist/Data-Dump-Streamer/
diff --git a/devel/p5-Data-Dumper/pkg-plist b/devel/p5-Data-Dumper/pkg-plist
new file mode 100644
index 000000000000..686a0bbcacb5
--- /dev/null
+++ b/devel/p5-Data-Dumper/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/Data/Dumper.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Dumper/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Dumper/Dumper.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Dumper/Dumper.so
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Dumper
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/Data 2>/dev/null || true