aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2009-04-10 09:03:33 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2009-04-10 09:03:33 +0000
commit8e333b4fbc76f5b9493ddaaddc03503a6fbf5b73 (patch)
treee9a23fe0fcd285dcd3736feebc8ce87d911dad60 /devel
parent1613478376c26a639c4789d57c5859d794e5ef25 (diff)
downloadports-8e333b4fbc76f5b9493ddaaddc03503a6fbf5b73.tar.gz
ports-8e333b4fbc76f5b9493ddaaddc03503a6fbf5b73.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-TAP-Formatter-JUnit/Makefile35
-rw-r--r--devel/p5-TAP-Formatter-JUnit/distinfo3
-rw-r--r--devel/p5-TAP-Formatter-JUnit/pkg-descr3
-rw-r--r--devel/p5-TAP-Formatter-JUnit/pkg-plist5
5 files changed, 47 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index ae0c956964ac..2a5701d3d9fa 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1816,6 +1816,7 @@
SUBDIR += p5-Sys-SigAction
SUBDIR += p5-Sys-Syscall
SUBDIR += p5-System2
+ SUBDIR += p5-TAP-Formatter-JUnit
SUBDIR += p5-TAP-Harness-JUnit
SUBDIR += p5-Taint-Runtime
SUBDIR += p5-Task-Weaken
diff --git a/devel/p5-TAP-Formatter-JUnit/Makefile b/devel/p5-TAP-Formatter-JUnit/Makefile
new file mode 100644
index 000000000000..28837c8b0811
--- /dev/null
+++ b/devel/p5-TAP-Formatter-JUnit/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: TAP::Formatter::JUnit
+# Date created: 10 Apr 2009
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= TAP-Formatter-JUnit
+PORTVERSION= 0.02
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension for Harness output delegate for JUnit output
+
+RUN_DEPENDS= \
+ p5-Class-Field>0:${PORTSDIR}/devel/p5-Class-Field \
+ p5-File-Slurp>0:${PORTSDIR}/devel/p5-File-Slurp \
+ p5-Test-Harness>=3.12:${PORTSDIR}/devel/p5-Test-Harness \
+ p5-XML-Generator>0:${PORTSDIR}/textproc/p5-XML-Generator
+BUILD_DEPENDS= \
+ p5-Class-Field>0:${PORTSDIR}/devel/p5-Class-Field \
+ p5-File-Slurp>0:${PORTSDIR}/devel/p5-File-Slurp \
+ p5-Test-Harness>=3.12:${PORTSDIR}/devel/p5-Test-Harness \
+ p5-XML-Generator>0:${PORTSDIR}/textproc/p5-XML-Generator \
+ p5-Test-Differences>0:${PORTSDIR}/devel/p5-Test-Differences
+
+PERL_MODBUILD= yes
+
+MAN1= tap2junit.1
+MAN3= TAP::Formatter::JUnit.3 \
+ TAP::Formatter::JUnit::Session.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-TAP-Formatter-JUnit/distinfo b/devel/p5-TAP-Formatter-JUnit/distinfo
new file mode 100644
index 000000000000..a9a814ca2e03
--- /dev/null
+++ b/devel/p5-TAP-Formatter-JUnit/distinfo
@@ -0,0 +1,3 @@
+MD5 (TAP-Formatter-JUnit-0.02.tar.gz) = d3ae18d60e2bd4276cfe20ca569b3d43
+SHA256 (TAP-Formatter-JUnit-0.02.tar.gz) = 62c8f0df631067bacbbfe3bdb673d1b70c1c6c226ad2e2459e588a4527adf92b
+SIZE (TAP-Formatter-JUnit-0.02.tar.gz) = 13118
diff --git a/devel/p5-TAP-Formatter-JUnit/pkg-descr b/devel/p5-TAP-Formatter-JUnit/pkg-descr
new file mode 100644
index 000000000000..ed1b823fd3fe
--- /dev/null
+++ b/devel/p5-TAP-Formatter-JUnit/pkg-descr
@@ -0,0 +1,3 @@
+Harness output delegate for JUnit output.
+
+WWW: http://search.cpan.org/dist/TAP-Formatter-JUnit/
diff --git a/devel/p5-TAP-Formatter-JUnit/pkg-plist b/devel/p5-TAP-Formatter-JUnit/pkg-plist
new file mode 100644
index 000000000000..cacb9c5f1fca
--- /dev/null
+++ b/devel/p5-TAP-Formatter-JUnit/pkg-plist
@@ -0,0 +1,5 @@
+bin/tap2junit
+%%SITE_PERL%%/TAP/Formatter/JUnit.pm
+%%SITE_PERL%%/TAP/Formatter/JUnit/Session.pm
+@dirrm %%SITE_PERL%%/TAP/Formatter/JUnit
+@dirrmtry %%SITE_PERL%%/TAP/Formatter