aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2002-01-30 01:36:45 +0000
committerPatrick Li <pat@FreeBSD.org>2002-01-30 01:36:45 +0000
commitafe853995c622e6a7ab6ebc167479e5f654e7062 (patch)
tree15cd1fa29658644e99a617cd9905a13e076104f1 /devel
parentf4945ef9c078a83b6f3d3b5c516354235347b701 (diff)
downloadports-afe853995c622e6a7ab6ebc167479e5f654e7062.tar.gz
ports-afe853995c622e6a7ab6ebc167479e5f654e7062.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/sysconftool/Makefile30
-rw-r--r--devel/sysconftool/distinfo1
-rw-r--r--devel/sysconftool/pkg-comment1
-rw-r--r--devel/sysconftool/pkg-descr15
-rw-r--r--devel/sysconftool/pkg-plist8
6 files changed, 56 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index b8ce2d6fd785..08408bc587cc 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -623,6 +623,7 @@
SUBDIR += subversion
SUBDIR += swarm
SUBDIR += swigruby
+ SUBDIR += sysconftool
SUBDIR += t1lib
SUBDIR += tcl-memchan
SUBDIR += tcl-neo
diff --git a/devel/sysconftool/Makefile b/devel/sysconftool/Makefile
new file mode 100644
index 000000000000..a61c60176d31
--- /dev/null
+++ b/devel/sysconftool/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: sysconftool
+# Date created: 17 October 2001
+# Whom: Yarema <yds@CoolRat.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sysconftool
+PORTVERSION= 0.13
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= courier
+
+MAINTAINER= yds@CoolRat.org
+
+BUILD_DEPENDS= autoconf213:${PORTSDIR}/devel/autoconf213 \
+ automake14:${PORTSDIR}/devel/automake14
+
+GNU_CONFIGURE= yes
+USE_PERL5= yes
+
+MAN1= sysconftool.1 sysconftoolcheck.1
+MAN7= sysconftool.7
+
+pre-patch:
+ @${PERL} -pi.orig -e 's|autoconf|${AUTOCONF}|; \
+ s|autoheader|${AUTOHEADER}|; s|aclocal|${ACLOCAL}|; \
+ s|automake|${AUTOMAKE}|' ${WRKSRC}/configure
+
+.include <bsd.port.mk>
diff --git a/devel/sysconftool/distinfo b/devel/sysconftool/distinfo
new file mode 100644
index 000000000000..2a6a3dd4dd85
--- /dev/null
+++ b/devel/sysconftool/distinfo
@@ -0,0 +1 @@
+MD5 (sysconftool-0.13.tar.gz) = 151d2e4777ebbf26d8c8d4c4733772e9
diff --git a/devel/sysconftool/pkg-comment b/devel/sysconftool/pkg-comment
new file mode 100644
index 000000000000..a63e1c2d2763
--- /dev/null
+++ b/devel/sysconftool/pkg-comment
@@ -0,0 +1 @@
+Helps to install application configuration files
diff --git a/devel/sysconftool/pkg-descr b/devel/sysconftool/pkg-descr
new file mode 100644
index 000000000000..943b32d36d75
--- /dev/null
+++ b/devel/sysconftool/pkg-descr
@@ -0,0 +1,15 @@
+sysconftool is a development utility that helps to install application
+configuration files. sysconftool allows an existing application to be
+upgraded without losing the older version's configuration settings.
+
+sysconftool is a script that is used by applications to update configuration
+files when a new version of the application is installed. sysconftool reads
+the new application configuration files, reads any older versions of those
+files that are already installed, then replaces the old versions with the
+new ones, but preserving any custom changes contained in the old versions.
+
+For more information on sysconftool, and why applications need it, see
+the installed manual pages: sysconftool(1) and sysconftool(7). With most
+versions of the man command: "man 1 sysconftool" and "man 7 sysconftool".
+
+WWW: http://www.Courier-MTA.org/sysconftool/
diff --git a/devel/sysconftool/pkg-plist b/devel/sysconftool/pkg-plist
new file mode 100644
index 000000000000..f2759c7302d3
--- /dev/null
+++ b/devel/sysconftool/pkg-plist
@@ -0,0 +1,8 @@
+bin/sysconftoolize
+bin/sysconftoolcheck
+share/automake14/aclocal/sysconftool.m4
+share/sysconftool/sysconftool
+share/sysconftool/sysconftoolize.pl
+share/sysconftool/sysconftoolcheck
+share/sysconftool/sysconftoolize.am
+@dirrm share/sysconftool