aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2003-11-21 12:25:04 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2003-11-21 12:25:04 +0000
commit73925f7101fc1e1d9f523d0fe5a8e9aeb5f8c07c (patch)
tree8e00d26557e48a9afce2bcfd3848bd865fd47d0a /devel
parentd470a37d9dc3af0bc3ff34fe47441724df4630bf (diff)
downloadports-73925f7101fc1e1d9f523d0fe5a8e9aeb5f8c07c.tar.gz
ports-73925f7101fc1e1d9f523d0fe5a8e9aeb5f8c07c.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/pth/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/devel/pth/Makefile b/devel/pth/Makefile
index 18dbe3e4e01d..dbb1f3c0b15d 100644
--- a/devel/pth/Makefile
+++ b/devel/pth/Makefile
@@ -24,10 +24,15 @@ CONFIGURE_ARGS= --enable-pthread \
--enable-batch \
--includedir="${PREFIX}/include/pth" \
--libdir="${PREFIX}/lib/pth"
+USE_REINPLACE= yes
MAN1= pth-config.1 pthread-config.1
MAN3= pth.3 pthread.3
+post-patch:
+ ${REINPLACE_CMD} -e \
+ "s,-funroll-loops -fstrength-reduce -fomit-frame-pointer -ffast-math,${CFLAGS}," \
+ ${WRKSRC}/configure
post-build:
@${ECHO_MSG} "===> Use 'make test' to run a quick test suite."