aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2004-08-16 02:33:05 +0000
committerKris Kennaway <kris@FreeBSD.org>2004-08-16 02:33:05 +0000
commitc1a0f8ede9b1500fbfeeddd49e14619623f520ad (patch)
treeda64bfdf1b4f9333a4a03d016667a79a61bbe190 /devel
parent01977fcaeadf6fa6fe54d180a7f6ec93d5742226 (diff)
downloadports-c1a0f8ede9b1500fbfeeddd49e14619623f520ad.tar.gz
ports-c1a0f8ede9b1500fbfeeddd49e14619623f520ad.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/astyle/Makefile8
-rw-r--r--devel/clint/Makefile8
-rw-r--r--devel/commoncpp/Makefile8
-rw-r--r--devel/glrparser/Makefile8
-rw-r--r--devel/korelib/Makefile8
-rw-r--r--devel/xparam/Makefile8
6 files changed, 42 insertions, 6 deletions
diff --git a/devel/astyle/Makefile b/devel/astyle/Makefile
index 5c2027666e22..1181eca084f2 100644
--- a/devel/astyle/Makefile
+++ b/devel/astyle/Makefile
@@ -21,6 +21,12 @@ EXTRACT_AFTER_ARGS= -d ${DISTNAME}
ALL_TARGET= astyle
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile with gcc 3.4.2"
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/astyle ${PREFIX}/bin
.if !defined(NOPORTDOCS)
@@ -28,4 +34,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/*.html ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/clint/Makefile b/devel/clint/Makefile
index 9288152af72d..527dd29ab112 100644
--- a/devel/clint/Makefile
+++ b/devel/clint/Makefile
@@ -25,10 +25,16 @@ INSTALLS_SHLIB= yes
INFO= clint
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile with gcc 3.4.2"
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
's|-pedantic||g ; \
s|-ldl||g'
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/commoncpp/Makefile b/devel/commoncpp/Makefile
index 9246596f8c8b..d6e8acae0a90 100644
--- a/devel/commoncpp/Makefile
+++ b/devel/commoncpp/Makefile
@@ -26,4 +26,10 @@ INSTALLS_SHLIB= yes
INFO= commoncpp2
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile with gcc 3.4.2"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/glrparser/Makefile b/devel/glrparser/Makefile
index 143fa80705c0..9a1e51b90d87 100644
--- a/devel/glrparser/Makefile
+++ b/devel/glrparser/Makefile
@@ -16,4 +16,10 @@ COMMENT= A parser works with the GLR(0) algorithm
GNU_CONFIGURE= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile with gcc 3.4.2"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/korelib/Makefile b/devel/korelib/Makefile
index 5088df3a45f1..4ad89eedae94 100644
--- a/devel/korelib/Makefile
+++ b/devel/korelib/Makefile
@@ -22,9 +22,15 @@ MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
AUTOHEADER="${TRUE}"
INSTALLS_SHLIB= yes
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile with gcc 3.4.2"
+.endif
+
post-patch:
@${FIND} ${WRKSRC} -name "Makefile.am" | ${XARGS} ${REINPLACE_CMD} -e \
's|include kore demo|include kore|g ; \
s|= -g -O2 -Wall|= @CXXFLAGS@|g'
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/xparam/Makefile b/devel/xparam/Makefile
index b1f4f18f6989..fe627ffebca8 100644
--- a/devel/xparam/Makefile
+++ b/devel/xparam/Makefile
@@ -20,4 +20,10 @@ USE_GMAKE= yes
USE_LIBTOOL_VER= 13
INSTALLS_SHLIB= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile with gcc 3.4.2"
+.endif
+
+.include <bsd.port.post.mk>