aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2016-01-11 21:29:26 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2016-01-11 21:29:26 +0000
commit4b78ad21b8075298fe7cc166d3081c780ec2d851 (patch)
tree3cae4f5521ca269f0d346b56d08ef13affebc1db /devel
parent1872d73923c1d8081f91070be69ecab6d1b1abda (diff)
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-debtcollector/Makefile25
-rw-r--r--devel/py-debtcollector/distinfo2
-rw-r--r--devel/py-debtcollector/pkg-descr11
4 files changed, 39 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index d4dd7622c92d..2c3bd848bd9f 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3988,6 +3988,7 @@
SUBDIR += py-darcsver
SUBDIR += py-dateutil
SUBDIR += py-dbus
+ SUBDIR += py-debtcollector
SUBDIR += py-decorator
SUBDIR += py-decoratortools
SUBDIR += py-defusedxml
diff --git a/devel/py-debtcollector/Makefile b/devel/py-debtcollector/Makefile
new file mode 100644
index 000000000000..5a7d55d5fc2f
--- /dev/null
+++ b/devel/py-debtcollector/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= debtcollector
+PORTVERSION= 1.1.0
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= dave@gufi.org
+COMMENT= Collection of Python deprecation patterns and strategies
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pbr>=1.6:${PORTSDIR}/devel/py-pbr
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Babel>=1.3:${PORTSDIR}/devel/py-babel \
+ ${PYTHON_PKGNAMEPREFIX}six>0:${PORTSDIR}/devel/py-six \
+ ${PYTHON_PKGNAMEPREFIX}wrapt>0:${PORTSDIR}/devel/py-wrapt
+
+NO_ARCH= yes
+
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+
+.include <bsd.port.mk>
diff --git a/devel/py-debtcollector/distinfo b/devel/py-debtcollector/distinfo
new file mode 100644
index 000000000000..5ef59ab84bff
--- /dev/null
+++ b/devel/py-debtcollector/distinfo
@@ -0,0 +1,2 @@
+SHA256 (debtcollector-1.1.0.tar.gz) = 87da37838bffbe61b7ba4986579e0ae06bc5f8eb2e197e89ef7419322655ae9b
+SIZE (debtcollector-1.1.0.tar.gz) = 21563
diff --git a/devel/py-debtcollector/pkg-descr b/devel/py-debtcollector/pkg-descr
new file mode 100644
index 000000000000..449327da8aa7
--- /dev/null
+++ b/devel/py-debtcollector/pkg-descr
@@ -0,0 +1,11 @@
+A collection of Python deprecation patterns and strategies that help you
+collect your technical debt in a non-destructive manner.
+
+The goal of this library is to provide well documented developer facing
+deprecation patterns that start of with a basic set and can expand into
+a larger set of patterns as time goes on. The desired output of these
+patterns is to apply the warnings module to emit DeprecationWarning or
+PendingDeprecationWarning or similar derivative to developers using
+libraries (or potentially applications) about future deprecations.
+
+WWW: http://docs.openstack.org/developer/debtcollector/