aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2003-06-29 09:17:39 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2003-06-29 09:17:39 +0000
commitf3ea002a95bd4577b393ff11deaa9e754ca4af80 (patch)
treea175c2547399994acdfeb992e7b4904def454dc8 /devel
parentaeacf70455b0ce575740ee1b1ae50161e9cbf8b0 (diff)
downloadports-f3ea002a95bd4577b393ff11deaa9e754ca4af80.tar.gz
ports-f3ea002a95bd4577b393ff11deaa9e754ca4af80.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-ExtUtils-ParseXS/Makefile24
-rw-r--r--devel/p5-ExtUtils-ParseXS/distinfo1
-rw-r--r--devel/p5-ExtUtils-ParseXS/pkg-descr5
-rw-r--r--devel/p5-ExtUtils-ParseXS/pkg-plist6
5 files changed, 37 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index baf8c10383b9..0d7ce83686da 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -561,6 +561,7 @@
SUBDIR += p5-Event
SUBDIR += p5-Exception-Class
SUBDIR += p5-Exporter-Lite
+ SUBDIR += p5-ExtUtils-ParseXS
SUBDIR += p5-File-BasicFlock
SUBDIR += p5-File-Binary
SUBDIR += p5-File-Cache
diff --git a/devel/p5-ExtUtils-ParseXS/Makefile b/devel/p5-ExtUtils-ParseXS/Makefile
new file mode 100644
index 000000000000..9b08a33af13f
--- /dev/null
+++ b/devel/p5-ExtUtils-ParseXS/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: ExtUtils::ParseXS
+# Date created: 29 June 2003
+# Whom: Dmitry Sivachenko <demon@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ExtUtils-ParseXS
+PORTVERSION= 2.02
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ExtUtils
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= demon@FreeBSD.org
+COMMENT= Converts Perl XS code into C code
+
+PERL_CONFIGURE= yes
+MAN3= ExtUtils::ParseXS.3
+
+pre-patch:
+ @${PERL} -pi -e 's/INSTALLDIRS/bebe/' ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.mk>
diff --git a/devel/p5-ExtUtils-ParseXS/distinfo b/devel/p5-ExtUtils-ParseXS/distinfo
new file mode 100644
index 000000000000..00c6b35602bb
--- /dev/null
+++ b/devel/p5-ExtUtils-ParseXS/distinfo
@@ -0,0 +1 @@
+MD5 (ExtUtils-ParseXS-2.02.tar.gz) = f9f2b373789e91d673ed85654df3ea2b
diff --git a/devel/p5-ExtUtils-ParseXS/pkg-descr b/devel/p5-ExtUtils-ParseXS/pkg-descr
new file mode 100644
index 000000000000..38c5ce4ee91f
--- /dev/null
+++ b/devel/p5-ExtUtils-ParseXS/pkg-descr
@@ -0,0 +1,5 @@
+ExtUtils::ParseXS will compile XS code into C code by embedding the
+constructs necessary to let C functions manipulate Perl values and creates
+the glue necessary to let Perl access those functions. The compiler uses
+typemaps to determine how to map C function parameters and variables to Perl
+values.
diff --git a/devel/p5-ExtUtils-ParseXS/pkg-plist b/devel/p5-ExtUtils-ParseXS/pkg-plist
new file mode 100644
index 000000000000..634024b13bfd
--- /dev/null
+++ b/devel/p5-ExtUtils-ParseXS/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/ExtUtils/xsubpp
+%%SITE_PERL%%/ExtUtils/ParseXS.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/ExtUtils/ParseXS/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/ExtUtils/ParseXS
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/ExtUtils
+@dirrm %%SITE_PERL%%/ExtUtils