aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2018-10-21 07:51:32 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2018-10-21 07:51:32 +0000
commit607d01e8cb661af6b579bd7ee38d12e846afe542 (patch)
tree6bf9487a28ae67c35cb0e5fdba4663ef01008223 /devel
parentf9b0fb9a9f9a2796a3da3fc68ca0c1996336b897 (diff)
downloadports-607d01e8cb661af6b579bd7ee38d12e846afe542.tar.gz
ports-607d01e8cb661af6b579bd7ee38d12e846afe542.zip
MFH: r481377
devel/ace: update to 6.5.2 While here: * Relocate some variables * Rework some patches * USE localbase ChangeLog: https://github.com/DOCGroup/ACE_TAO/releases/tag/ACE%2BTAO-6_5_2 Reported by: portscout Approved by: tcberner (mentor, implicit)
Notes
Notes: svn path=/branches/2018Q4/; revision=482645
Diffstat (limited to 'devel')
-rw-r--r--devel/ace/Makefile20
-rw-r--r--devel/ace/distinfo6
-rw-r--r--devel/ace/files/patch-ace__SSL__SSL_Context.cpp18
-rw-r--r--devel/ace/files/patch-tests_Chrono__Test.cpp11
-rw-r--r--devel/ace/pkg-plist7
5 files changed, 39 insertions, 23 deletions
diff --git a/devel/ace/Makefile b/devel/ace/Makefile
index aed55fc03569..68047bdaf037 100644
--- a/devel/ace/Makefile
+++ b/devel/ace/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= ace
-PORTVERSION= 6.4.3
+PORTVERSION= 6.5.2
CATEGORIES= devel
MASTER_SITES= ftp://download.dre.vanderbilt.edu/previous_versions/ \
http://download.dre.vanderbilt.edu/previous_versions/
@@ -16,9 +16,12 @@ LICENSE_NAME= ACE
LICENSE_FILE= ${WRKSRC}/COPYING
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-WRKSRC= ${WRKDIR}/ACE_wrappers
+BROKEN_aarch64= Fails to link: missing sbrk
+BROKEN_powerpc= Does not compile on ${ARCH}
+BROKEN_powerpc64= Does not build on ${ARCH}: undefined reference to fmodl
+BROKEN_sparc64= Does not compile on ${ARCH}
-USES= gmake perl5 pkgconfig shebangfix tar:bzip2
+USES= gmake localbase:ldflags perl5 pkgconfig shebangfix tar:bzip2
USE_PERL5= build
SHEBANG_FILES= bin/*.pl MPC/*.pl
MAKE_ENV= LD_LIBRARY_PATH="${WRKSRC}/lib" ACE_ROOT="${WRKSRC}" \
@@ -26,19 +29,12 @@ MAKE_ENV= LD_LIBRARY_PATH="${WRKSRC}/lib" ACE_ROOT="${WRKSRC}" \
MAKEFILE= GNUmakefile
USE_LDCONFIG= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-CPPFLAGS+= -D_WANT_SEMUN
-LDFLAGS+= -L${LOCALBASE}/lib
+WRKSRC= ${WRKDIR}/ACE_wrappers
PLIST_SUB= VERSION="${PORTVERSION}"
CONFLICTS= ace+tao-5*
-BROKEN_aarch64= Fails to link: missing sbrk
-BROKEN_powerpc= Does not compile on ${ARCH}
-BROKEN_powerpc64= Does not build on ${ARCH}: undefined reference to fmodl
-BROKEN_sparc64= Does not compile on ${ARCH}
-
OPTIONS_DEFINE= FLTK QT4 SSL TK TRIO X11
OPTIONS_DEFAULT= SSL
OPTIONS_SUB= yes
@@ -61,6 +57,8 @@ TRIO_MAKE_ENV= trio=1
X11_USE= XORG=xt
X11_MAKE_ENV= xt=1
+CPPFLAGS+= -D_WANT_SEMUN
+
post-patch:
@${REINPLACE_CMD} -e \
's|/$$libdir/pkgconfig|/libdata/pkgconfig|g' \
diff --git a/devel/ace/distinfo b/devel/ace/distinfo
index 26e598e527d4..3182092e8270 100644
--- a/devel/ace/distinfo
+++ b/devel/ace/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1497530730
-SHA256 (ACE-6.4.3.tar.bz2) = b80e7b8137d48dc68b281233417fe19b21a904ea642a05ea795bd6a546bcbb1d
-SIZE (ACE-6.4.3.tar.bz2) = 9074739
+TIMESTAMP = 1537466321
+SHA256 (ACE-6.5.2.tar.bz2) = f0393d6df25ee92e0cbc6539c68ccf122caae0ffd5ae9a786163403bb2306cc5
+SIZE (ACE-6.5.2.tar.bz2) = 8074873
diff --git a/devel/ace/files/patch-ace__SSL__SSL_Context.cpp b/devel/ace/files/patch-ace__SSL__SSL_Context.cpp
index 51c339d91bb3..8b6f4c77d422 100644
--- a/devel/ace/files/patch-ace__SSL__SSL_Context.cpp
+++ b/devel/ace/files/patch-ace__SSL__SSL_Context.cpp
@@ -1,11 +1,11 @@
---- ace/SSL/SSL_Context.cpp.orig 2015-09-17 06:55:18 UTC
+--- ace/SSL/SSL_Context.cpp.orig 2018-09-18 07:26:56 UTC
+++ ace/SSL/SSL_Context.cpp
-@@ -683,7 +683,7 @@ ACE_SSL_Context::random_seed (const char
- int
- ACE_SSL_Context::egd_file (const char * socket_file)
- {
--#if OPENSSL_VERSION_NUMBER < 0x00905100L
+@@ -179,7 +179,7 @@ ACE_SSL_Context::ssl_library_init (void)
+ # endif /* OPENSSL_VERSION_NUMBER < 0x10100000L */
+ #endif /* WIN32 */
+
+-#if OPENSSL_VERSION_NUMBER >= 0x00905100L
+#if OPENSSL_VERSION_NUMBER < 0x00905100L || defined(LIBRESSL_VERSION_NUMBER)
- // OpenSSL < 0.9.5 doesn't have EGD support.
- ACE_UNUSED_ARG (socket_file);
- ACE_NOTSUP_RETURN (-1);
+ // OpenSSL < 0.9.5 doesn't have EGD support.
+
+ const char *egd_socket_file =
diff --git a/devel/ace/files/patch-tests_Chrono__Test.cpp b/devel/ace/files/patch-tests_Chrono__Test.cpp
new file mode 100644
index 000000000000..f16ca90e938e
--- /dev/null
+++ b/devel/ace/files/patch-tests_Chrono__Test.cpp
@@ -0,0 +1,11 @@
+--- tests/Chrono_Test.cpp.orig 2018-10-05 15:55:54 UTC
++++ tests/Chrono_Test.cpp
+@@ -208,7 +208,7 @@ test_streamers ()
+ std::chrono::seconds day_test_ts { day_test_h+day_test_s };
+ std::chrono::microseconds day_test_tus { day_test_ms+day_test_us };
+ ACE_Time_Value const test_day {
+- ACE_Time_Value { day_test_ts.count (), ACE_Utils::truncate_cast<suseconds_t>(day_test_tus.count ()) }};
++ ACE_Time_Value { (int)(day_test_ts.count ()), ACE_Utils::truncate_cast<suseconds_t>(day_test_tus.count ()) }};
+
+ constexpr int expected_min {nr_hours * 60};
+ constexpr int64_t expected_sec { expected_min * 60 + 54 };
diff --git a/devel/ace/pkg-plist b/devel/ace/pkg-plist
index 9ea2ba9de945..7a34888bbfc0 100644
--- a/devel/ace/pkg-plist
+++ b/devel/ace/pkg-plist
@@ -1105,12 +1105,14 @@ include/ace/config-lite.h
include/ace/config-lynxos.h
include/ace/config-lynxos-178.h
include/ace/config-macosx-elcapitan.h
+include/ace/config-macosx-highsierra.h
include/ace/config-macosx-iOS-hardware.h
include/ace/config-macosx-iOS-simulator.h
include/ace/config-macosx-jaguar.h
include/ace/config-macosx-leopard.h
include/ace/config-macosx-lion.h
include/ace/config-macosx-mavericks.h
+include/ace/config-macosx-mojave.h
include/ace/config-macosx-mountainlion.h
include/ace/config-macosx-panther.h
include/ace/config-macosx-sierra.h
@@ -1380,6 +1382,9 @@ libdata/pkgconfig/Kokyu.pc
%%DATADIR%%/bin/MakeProjectCreator/config/ace_qt.mpb
%%DATADIR%%/bin/MakeProjectCreator/config/ace_qt4.mpb
%%DATADIR%%/bin/MakeProjectCreator/config/ace_qt4reactor.mpb
+%%DATADIR%%/bin/MakeProjectCreator/config/ace_qt5.mpb
+%%DATADIR%%/bin/MakeProjectCreator/config/ace_qt5reactor.mpb
+%%DATADIR%%/bin/MakeProjectCreator/config/ace_qtreactor.mpb
%%DATADIR%%/bin/MakeProjectCreator/config/ace_rlecompressionlib.mpb
%%DATADIR%%/bin/MakeProjectCreator/config/ace_tk.mpb
%%DATADIR%%/bin/MakeProjectCreator/config/ace_tkreactor.mpb
@@ -1523,12 +1528,14 @@ libdata/pkgconfig/Kokyu.pc
%%DATADIR%%/include/makeinclude/platform_macosx.GNU
%%DATADIR%%/include/makeinclude/platform_macosx_common.GNU
%%DATADIR%%/include/makeinclude/platform_macosx_elcapitan.GNU
+%%DATADIR%%/include/makeinclude/platform_macosx_highsierra.GNU
%%DATADIR%%/include/makeinclude/platform_macosx_iOS.GNU
%%DATADIR%%/include/makeinclude/platform_macosx_icc.GNU
%%DATADIR%%/include/makeinclude/platform_macosx_jaguar.GNU
%%DATADIR%%/include/makeinclude/platform_macosx_leopard.GNU
%%DATADIR%%/include/makeinclude/platform_macosx_lion.GNU
%%DATADIR%%/include/makeinclude/platform_macosx_mavericks.GNU
+%%DATADIR%%/include/makeinclude/platform_macosx_mojave.GNU
%%DATADIR%%/include/makeinclude/platform_macosx_mountainlion.GNU
%%DATADIR%%/include/makeinclude/platform_macosx_panther.GNU
%%DATADIR%%/include/makeinclude/platform_macosx_sierra.GNU