aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2018-10-28 09:38:41 +0000
committerJan Beich <jbeich@FreeBSD.org>2018-10-28 09:38:41 +0000
commitd9ab8b889ac55909943e1e179353338a6bd247ed (patch)
treec3b89f56e54e7f0b6526dc0452aa65fa09b8e3c9 /devel
parentd9865c8e3fc76ec6dd6f1ee9f9fe3fbab344ea12 (diff)
downloadports-d9ab8b889ac55909943e1e179353338a6bd247ed.tar.gz
ports-d9ab8b889ac55909943e1e179353338a6bd247ed.zip
MFH: r483249
Downgrade C++03 to C++98, actual default for GCC < 6 GCC 4.2 in base system doesn't support C++03: cc1plus: error: unrecognized command line option "-std=gnu++03" Approved by: ports-secteam blanket
Notes
Notes: svn path=/branches/2018Q4/; revision=483250
Diffstat (limited to 'devel')
-rw-r--r--devel/aegis/Makefile2
-rw-r--r--devel/rhtvision/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/devel/aegis/Makefile b/devel/aegis/Makefile
index ed0ce99691ae..5925223260d4 100644
--- a/devel/aegis/Makefile
+++ b/devel/aegis/Makefile
@@ -28,7 +28,7 @@ MAKE_JOBS_UNSAFE= yes
# GCC 6 switched to -std=gnu++14 by default, which breaks the port (bug
# 219284). Explicitly use the previous default to keep things going.
-USE_CXXSTD= gnu++03
+USE_CXXSTD= gnu++98
OPTIONS_DEFINE= DOCS NLS
OPTIONS_SUB= yes
diff --git a/devel/rhtvision/Makefile b/devel/rhtvision/Makefile
index 41328ab26a2b..5be913026f08 100644
--- a/devel/rhtvision/Makefile
+++ b/devel/rhtvision/Makefile
@@ -29,7 +29,7 @@ CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
# The port does not build with C++11 or later (bug 219275).
-USE_CXXSTD= gnu++03
+USE_CXXSTD= gnu++98
PLIST_SUB= VERSION="${PORTVERSION:R}"