aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorMichael Gmelin <grembo@FreeBSD.org>2019-09-30 09:12:53 +0000
committerMichael Gmelin <grembo@FreeBSD.org>2019-09-30 09:12:53 +0000
commit1f04bcd099005697c39c184005c9b3c5b8e90d42 (patch)
treed4bd0ef11e1beff278b22bb9519c9bbf5e195c7e /devel
parentb4789211bf281b05bd0d73953c955ac7e105190e (diff)
downloadports-1f04bcd099005697c39c184005c9b3c5b8e90d42.tar.gz
ports-1f04bcd099005697c39c184005c9b3c5b8e90d42.zip
Fix use of implode() to avoid warnings when running on newer versions
of PHP. See also https://www.php.net/manual/en/function.implode.php Committed with minor changes. PR: 240931 Submitted by: lutz@donnerhacke.de
Notes
Notes: svn path=/head/; revision=513334
Diffstat (limited to 'devel')
-rw-r--r--devel/libphutil/Makefile1
-rw-r--r--devel/libphutil/files/patch-src_utils_utils.php11
2 files changed, 12 insertions, 0 deletions
diff --git a/devel/libphutil/Makefile b/devel/libphutil/Makefile
index 6f033bceee4d..a62a79a7a0c4 100644
--- a/devel/libphutil/Makefile
+++ b/devel/libphutil/Makefile
@@ -2,6 +2,7 @@
PORTNAME= libphutil
PORTVERSION= 20190831
+PORTREVISION= 1
CATEGORIES= devel
PKGNAMEPREFIX= ${PHP_PKGNAMEPREFIX}
diff --git a/devel/libphutil/files/patch-src_utils_utils.php b/devel/libphutil/files/patch-src_utils_utils.php
new file mode 100644
index 000000000000..d27c1f314d44
--- /dev/null
+++ b/devel/libphutil/files/patch-src_utils_utils.php
@@ -0,0 +1,11 @@
+--- src/utils/utils.php.orig 2019-08-31 14:54:35 UTC
++++ src/utils/utils.php
+@@ -1703,7 +1703,7 @@ function phutil_build_http_querystring_f
+ list($key, $value) = phutil_http_parameter_pair($key, $value);
+ $query[] = rawurlencode($key).'='.rawurlencode($value);
+ }
+- $query = implode($query, '&');
++ $query = implode('&', $query);
+
+ return $query;
+ }