aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorPhilip Paeps <philip@FreeBSD.org>2006-12-05 22:51:12 +0000
committerPhilip Paeps <philip@FreeBSD.org>2006-12-05 22:51:12 +0000
commit463177d875fdc8a962404d4bb9f13030d5ea8b26 (patch)
tree434fb08852bdff09c2c5942a2841697de81f10ab /devel
parent7a52d004a07218675363f2ec795880f9c31ef59a (diff)
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/lua-pty/Makefile11
-rw-r--r--devel/lua-pty/files/Makefile5
-rw-r--r--devel/lua-pty/files/patch-pty.c18
-rw-r--r--devel/lua-pty/files/patch-pty.lua13
-rw-r--r--devel/lua50-pty/Makefile33
-rw-r--r--devel/lua50-pty/distinfo6
-rw-r--r--devel/lua50-pty/files/Makefile11
8 files changed, 44 insertions, 54 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 5a2e39d5bc9d..623ce1a17b91 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -641,6 +641,7 @@
SUBDIR += lua-filename
SUBDIR += lua-gettext
SUBDIR += lua-posix
+ SUBDIR += lua-pty
SUBDIR += lwp
SUBDIR += m17n-db
SUBDIR += m17n-docs
diff --git a/devel/lua-pty/Makefile b/devel/lua-pty/Makefile
index 0ee1db962e74..9ae1cd8e746f 100644
--- a/devel/lua-pty/Makefile
+++ b/devel/lua-pty/Makefile
@@ -14,15 +14,16 @@ PKGNAMEPREFIX= ${LUA_PKGNAMEPREFIX}
DISTFILES= pty.lua?rev=1.2 pty.c?rev=1.25
MAINTAINER= andrew+ports@fubar.geek.nz
-COMMENT= Pty (pseudo-terminal) bindings for Lua 5.0.x
+COMMENT= Pty (pseudo-terminal) bindings for Lua 5
-BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/devel/lua50-compat51:extract
-
-USE_LUA= 5.0
-LUA_COMPS= lua compat51
+USE_LUA?= 5.1
+.if ${USE_LUA} == 5.0
+LUA_COMPS= compat51 lua
+BUILD_DEPENDS+= ${NONEXISTENT}:${PORTSDIR}/devel/lua50-compat51:extract
COMPAT_SRC= `(cd ${PORTSDIR}/devel/lua50-compat51 && ${MAKE} -V WRKSRC)`
MAKE_ENV= COMPATDIR="${COMPAT_SRC}"
+.endif
PLIST_FILES= %%LUA_MODSHAREDIR%%/pty.lua \
%%LUA_MODLIBDIR%%/lpty.so
diff --git a/devel/lua-pty/files/Makefile b/devel/lua-pty/files/Makefile
index e6a0fb23c49f..37955a7679db 100644
--- a/devel/lua-pty/files/Makefile
+++ b/devel/lua-pty/files/Makefile
@@ -3,7 +3,10 @@
SHLIB= pty
SHLIB_NAME= lpty.so
-SRCS= pty.c ${COMPATDIR}/compat-5.1.c
+SRCS= pty.c
+.if defined(COMPATDIR)
+SRCS+= ${COMPATDIR}/compat-5.1.c
+.endif
CFLAGS+= -I${LUA_INCDIR}
LDFLAGS+= -L/usr/lib -lutil
diff --git a/devel/lua-pty/files/patch-pty.c b/devel/lua-pty/files/patch-pty.c
new file mode 100644
index 000000000000..d037c680fb7c
--- /dev/null
+++ b/devel/lua-pty/files/patch-pty.c
@@ -0,0 +1,18 @@
+--- pty.c.orig Wed Nov 29 21:26:24 2006
++++ pty.c Wed Nov 29 21:29:38 2006
+@@ -66,6 +66,15 @@
+ #define WEXIT_TYPE union wait
+ #endif
+
++#ifndef lua_boxpointer
++#define lua_boxpointer(L,u) \
++ (*(void **)(lua_newuserdata(L, sizeof(void *))) = (u))
++#endif
++
++#ifndef lua_unboxpointer
++#define lua_unboxpointer(L,i) (*(void **)(lua_touserdata(L, i)))
++#endif
++
+ struct lua_pty {
+ FILE *stream;
+ pid_t child;
diff --git a/devel/lua-pty/files/patch-pty.lua b/devel/lua-pty/files/patch-pty.lua
new file mode 100644
index 000000000000..deabb00649e8
--- /dev/null
+++ b/devel/lua-pty/files/patch-pty.lua
@@ -0,0 +1,13 @@
+--- pty.lua.orig Wed Nov 29 22:38:08 2006
++++ pty.lua Wed Nov 29 22:39:00 2006
+@@ -1,9 +1,8 @@
+ -- $Id: pty.lua,v 1.2 2005/08/13 20:00:40 cpressey Exp $
+ -- Lua wrapper functions for Lua 5.0.x Pty (pseudo-terminal) binding.
+
++local Pty = require("lpty")
+ module("pty")
+-
+-Pty = require("lpty")
+
+ --[[------------]]--
+ --[[ Pty.Logged ]]--
diff --git a/devel/lua50-pty/Makefile b/devel/lua50-pty/Makefile
index 0ee1db962e74..6d243c4b9ea3 100644
--- a/devel/lua50-pty/Makefile
+++ b/devel/lua50-pty/Makefile
@@ -5,37 +5,8 @@
# $FreeBSD$
#
-PORTNAME= pty
-PORTVERSION= 1.25
-CATEGORIES= devel
-MASTER_SITES= ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= philip
-PKGNAMEPREFIX= ${LUA_PKGNAMEPREFIX}
-DISTFILES= pty.lua?rev=1.2 pty.c?rev=1.25
-
-MAINTAINER= andrew+ports@fubar.geek.nz
-COMMENT= Pty (pseudo-terminal) bindings for Lua 5.0.x
-
-BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/devel/lua50-compat51:extract
-
USE_LUA= 5.0
-LUA_COMPS= lua compat51
-
-COMPAT_SRC= `(cd ${PORTSDIR}/devel/lua50-compat51 && ${MAKE} -V WRKSRC)`
-MAKE_ENV= COMPATDIR="${COMPAT_SRC}"
-
-PLIST_FILES= %%LUA_MODSHAREDIR%%/pty.lua \
- %%LUA_MODLIBDIR%%/lpty.so
-
-do-extract:
- @${MKDIR} ${WRKSRC}
-.for file in ${DISTFILES}
- @${CP} ${DISTDIR}/${file} ${WRKSRC}/${file:C/\?.*$//}
-.endfor
- @${CP} ${FILESDIR}/Makefile ${WRKSRC}
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/lpty.so ${LUA_MODLIBDIR}
- ${INSTALL_DATA} ${WRKSRC}/pty.lua ${LUA_MODSHAREDIR}
+MASTERDIR= ${.CURDIR}/../lua-pty
-.include <bsd.port.mk>
+.include "${MASTERDIR}/Makefile"
diff --git a/devel/lua50-pty/distinfo b/devel/lua50-pty/distinfo
deleted file mode 100644
index 0650f2bdb2ca..000000000000
--- a/devel/lua50-pty/distinfo
+++ /dev/null
@@ -1,6 +0,0 @@
-MD5 (pty.lua?rev=1.2) = a28e98428f2feabda7465006939eacea
-SHA256 (pty.lua?rev=1.2) = 18f1a623b727a3172b6e16142c057659a76614741a65533a9747034886edcb9a
-SIZE (pty.lua?rev=1.2) = 1077
-MD5 (pty.c?rev=1.25) = ec00d34a5f613b9c55a66345dd6c390d
-SHA256 (pty.c?rev=1.25) = f8ce982883ba917abeab623ca63e07aafb05d2820fe35e5d8563caf579240af1
-SIZE (pty.c?rev=1.25) = 9264
diff --git a/devel/lua50-pty/files/Makefile b/devel/lua50-pty/files/Makefile
deleted file mode 100644
index e6a0fb23c49f..000000000000
--- a/devel/lua50-pty/files/Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
-# $FreeBSD$
-
-SHLIB= pty
-SHLIB_NAME= lpty.so
-
-SRCS= pty.c ${COMPATDIR}/compat-5.1.c
-
-CFLAGS+= -I${LUA_INCDIR}
-LDFLAGS+= -L/usr/lib -lutil
-
-.include <bsd.lib.mk>