aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorGreg Larkin <glarkin@FreeBSD.org>2010-11-18 14:51:28 +0000
committerGreg Larkin <glarkin@FreeBSD.org>2010-11-18 14:51:28 +0000
commit48da8fb1c7877ce4cde726f71df645cd83c6333c (patch)
tree5fb68683819821cda9baf3efb4c6be349624d10c /devel
parent8264302b8d4bea098cbcfc2bbb17858301ca5052 (diff)
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/bzr-pipeline/Makefile28
-rw-r--r--devel/bzr-pipeline/distinfo2
-rw-r--r--devel/bzr-pipeline/pkg-descr10
-rw-r--r--devel/bzr-pipeline/pkg-plist25
5 files changed, 66 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 62e9a068794d..f6f9eb75f3fe 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -140,6 +140,7 @@
SUBDIR += bzr-grep
SUBDIR += bzr-gtk
SUBDIR += bzr-loom
+ SUBDIR += bzr-pipeline
SUBDIR += bzr-rewrite
SUBDIR += bzr-svn
SUBDIR += bzrtools
diff --git a/devel/bzr-pipeline/Makefile b/devel/bzr-pipeline/Makefile
new file mode 100644
index 000000000000..6179fe19ceb5
--- /dev/null
+++ b/devel/bzr-pipeline/Makefile
@@ -0,0 +1,28 @@
+# Ports collection makefile for: bzr-pipeline
+# Date created: 2010-11-16
+# Whom: Carlo Strub <c-s@c-s.li>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bzr-pipeline
+PORTVERSION= 1.0.0
+CATEGORIES= devel
+MASTER_SITES= http://launchpadlibrarian.net/58976607/ \
+ http://www.c-s.li/ports/
+
+MAINTAINER= c-s@c-s.li
+COMMENT= Bzr tools for working with a sequence of branches
+
+BUILD_DEPENDS= bzr:${PORTSDIR}/devel/bazaar-ng
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+LICENSE= GPLv2
+
+WRKSRC= ${WRKDIR}/pipeline
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= BzrPipeline
+
+.include <bsd.port.mk>
diff --git a/devel/bzr-pipeline/distinfo b/devel/bzr-pipeline/distinfo
new file mode 100644
index 000000000000..71f6a6aca3ef
--- /dev/null
+++ b/devel/bzr-pipeline/distinfo
@@ -0,0 +1,2 @@
+SHA256 (bzr-pipeline-1.0.0.tar.gz) = 632446d69f5592ef132bc85a4874bd13830aa68c77fbe226f4cdd67125de0a03
+SIZE (bzr-pipeline-1.0.0.tar.gz) = 29623
diff --git a/devel/bzr-pipeline/pkg-descr b/devel/bzr-pipeline/pkg-descr
new file mode 100644
index 000000000000..f0bfe0f5b3a8
--- /dev/null
+++ b/devel/bzr-pipeline/pkg-descr
@@ -0,0 +1,10 @@
+The Bazaar pipeline plugin helps you organize your changes into
+sections called "pipes". Pipelines can help you:
+
+* focus on each set of changes as a coherent piece, without being
+ distracted by other sets of changes.
+* respect diff size limits when submitting changes
+* avoid reviewer fatigue when submitting changes for code review
+* maintain a set of patches against an upstream branch
+
+WWW: http://wiki.bazaar.canonical.com/BzrPipeline
diff --git a/devel/bzr-pipeline/pkg-plist b/devel/bzr-pipeline/pkg-plist
new file mode 100644
index 000000000000..a9f054b18044
--- /dev/null
+++ b/devel/bzr-pipeline/pkg-plist
@@ -0,0 +1,25 @@
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/pipeline/__init__.py
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/pipeline/__init__.pyc
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/pipeline/__init__.pyo
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/pipeline/commands.py
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/pipeline/commands.pyc
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/pipeline/commands.pyo
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/pipeline/loom.py
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/pipeline/loom.pyc
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/pipeline/loom.pyo
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/pipeline/pipeline.py
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/pipeline/pipeline.pyc
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/pipeline/pipeline.pyo
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/pipeline/tests/__init__.py
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/pipeline/tests/__init__.pyc
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/pipeline/tests/__init__.pyo
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/pipeline/tests/test_blackbox.py
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/pipeline/tests/test_blackbox.pyc
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/pipeline/tests/test_blackbox.pyo
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/pipeline/tests/test_pipeline.py
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/pipeline/tests/test_pipeline.pyc
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/pipeline/tests/test_pipeline.pyo
+@dirrm %%PYTHON_SITELIBDIR%%/bzrlib/plugins/pipeline/tests
+@dirrm %%PYTHON_SITELIBDIR%%/bzrlib/plugins/pipeline
+@dirrmtry %%PYTHON_SITELIBDIR%%/bzrlib/plugins
+@dirrmtry %%PYTHON_SITELIBDIR%%/bzrlib