aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2014-09-27 08:34:11 +0000
committerMarcus von Appen <mva@FreeBSD.org>2014-09-27 08:34:11 +0000
commit17ba3fa7bb1e7d33e96d4888bf000cb6dfb5815f (patch)
treeec4e758159a80cc18f31372387d6fa068f958b82 /devel
parentb97f4dcc3a1b65539ecb1deb3f2f3b57e9ea7839 (diff)
downloadports-17ba3fa7bb1e7d33e96d4888bf000cb6dfb5815f.tar.gz
ports-17ba3fa7bb1e7d33e96d4888bf000cb6dfb5815f.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-characteristic/Makefile19
-rw-r--r--devel/py-characteristic/distinfo2
-rw-r--r--devel/py-characteristic/pkg-descr12
4 files changed, 34 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 03bc5c9446f3..91adbbb493ed 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3622,6 +3622,7 @@
SUBDIR += py-celery
SUBDIR += py-cffi
SUBDIR += py-cfgparse
+ SUBDIR += py-characteristic
SUBDIR += py-checkmanifest
SUBDIR += py-cheetah
SUBDIR += py-ciphon
diff --git a/devel/py-characteristic/Makefile b/devel/py-characteristic/Makefile
new file mode 100644
index 000000000000..c87d2476f973
--- /dev/null
+++ b/devel/py-characteristic/Makefile
@@ -0,0 +1,19 @@
+# Created by: Axel Rau <axel.rau@chaos1.de>
+# $FreeBSD$
+
+PORTNAME= characteristic
+PORTVERSION= 14.1.0
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= axel.rau@chaos1.de
+COMMENT= Python attributes without boilerplate
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= python
+USE_PYTHON= distutils autoplist
+
+.include <bsd.port.mk>
diff --git a/devel/py-characteristic/distinfo b/devel/py-characteristic/distinfo
new file mode 100644
index 000000000000..04e059c1799f
--- /dev/null
+++ b/devel/py-characteristic/distinfo
@@ -0,0 +1,2 @@
+SHA256 (characteristic-14.1.0.tar.gz) = 91e254948180678dd69e6143202b4686f2fa47cce136936079bb4d9a3b82419d
+SIZE (characteristic-14.1.0.tar.gz) = 24612
diff --git a/devel/py-characteristic/pkg-descr b/devel/py-characteristic/pkg-descr
new file mode 100644
index 000000000000..7ac61fe880fc
--- /dev/null
+++ b/devel/py-characteristic/pkg-descr
@@ -0,0 +1,12 @@
+characteristic is a Python package with class decorators that ease the
+chores of implementing the most common attribute-related object protocols.
+
+You just specify the attributes to work with and characteristic gives you
+any or all of:
+ a nice human-readable __repr__,
+ a complete set of comparison methods,
+ immutability for attributes,
+ and a kwargs-based initializer
+without writing dull boilerplate code again and again.
+
+WWW: https://github.com/hynek/characteristic