aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-11-01 20:03:04 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-11-01 20:03:04 +0000
commit19cd732005cb8269c43986f658d7225bb2301f47 (patch)
tree50d57ec4d4de24f7e9d65c6b0c9bbd095260f65a /devel
parent57a056d2bc0459f41ae0e61fd431c28d2849f7a8 (diff)
Add ruby-timex, a Ruby library to extend the Time class.
Notes
Notes: svn path=/head/; revision=49464
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/ruby-timex/Makefile37
-rw-r--r--devel/ruby-timex/distinfo1
-rw-r--r--devel/ruby-timex/pkg-comment1
-rw-r--r--devel/ruby-timex/pkg-descr6
-rw-r--r--devel/ruby-timex/pkg-plist3
6 files changed, 49 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 8c17f83c0675..9ba35888c0ef 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -522,6 +522,7 @@
SUBDIR += ruby-strscan
SUBDIR += ruby-sysvipc
SUBDIR += ruby-textbuf
+ SUBDIR += ruby-timex
SUBDIR += ruby-tzfile
SUBDIR += ruby-unit
SUBDIR += rudiments
diff --git a/devel/ruby-timex/Makefile b/devel/ruby-timex/Makefile
new file mode 100644
index 000000000000..6320d235e105
--- /dev/null
+++ b/devel/ruby-timex/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: Ruby/timex
+# Date created: 2 November 2001
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= timex
+PORTVERSION= 0.2
+CATEGORIES= devel ruby
+MASTER_SITES= http://cvs.m17n.org/cgi-bin/viewcvs/${PORTNAME}/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= timex-${PORTVERSION}${EXTRACT_SUFX}\?tarball=1\&only_with_tag=${PORTNAME}-${PORTVERSION:S/./_/g}\&cvsroot=ruby\&
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+USE_RUBY= yes
+.if !defined(NOPORTDOCS)
+USE_RUBY_RD= yes
+.endif
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+do-build:
+.if !defined(NOPORTDOCS)
+ cd ${WRKSRC} && ${RUBY_RD} timex.rb > timex.html
+.endif
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/timex.rb ${RUBY_SITELIBDIR}/
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/timex.html ${RUBY_DOCDIR}/${PORTNAME}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/ruby-timex/distinfo b/devel/ruby-timex/distinfo
new file mode 100644
index 000000000000..f75908a3c46e
--- /dev/null
+++ b/devel/ruby-timex/distinfo
@@ -0,0 +1 @@
+MD5 (ruby/timex-0.2.tar.gz?tarball=1&only_with_tag=timex-0_2&cvsroot=ruby&.tar.gz) = 33e4cd81642e3126cad6f565d4588286
diff --git a/devel/ruby-timex/pkg-comment b/devel/ruby-timex/pkg-comment
new file mode 100644
index 000000000000..685725e5ff1f
--- /dev/null
+++ b/devel/ruby-timex/pkg-comment
@@ -0,0 +1 @@
+A Ruby library to extend the Time class
diff --git a/devel/ruby-timex/pkg-descr b/devel/ruby-timex/pkg-descr
new file mode 100644
index 000000000000..4da8676e52f9
--- /dev/null
+++ b/devel/ruby-timex/pkg-descr
@@ -0,0 +1,6 @@
+The timex library extends Time to provide leapseconds and localtime -
+UTC offset information. It also provides stringization methods for
+RFC 2822 and ISO 8601 and a date string parser method.
+
+Author: Tanaka Akira <akr@m17n.org>
+WWW: http://cvs.m17n.org/~akr/timex/
diff --git a/devel/ruby-timex/pkg-plist b/devel/ruby-timex/pkg-plist
new file mode 100644
index 000000000000..a06c63694ea2
--- /dev/null
+++ b/devel/ruby-timex/pkg-plist
@@ -0,0 +1,3 @@
+%%RUBY_SITELIBDIR%%/timex.rb
+%%PORTDOCS%%%%RUBY_DOCDIR%%/timex/timex.html
+%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/timex