aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2002-11-04 03:05:48 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2002-11-04 03:05:48 +0000
commit5b96d0a9567e649c783ac418d8e2bde2f6adfc22 (patch)
tree8b423bf71fff78a00604f3c63e5c97500c8a780a /devel
parent3e84456d0e9ec790ccd9350f80ea60af92eb7d68 (diff)
downloadports-5b96d0a9567e649c783ac418d8e2bde2f6adfc22.tar.gz
ports-5b96d0a9567e649c783ac418d8e2bde2f6adfc22.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/clo++/Makefile1
-rw-r--r--devel/dmalloc/Makefile3
-rw-r--r--devel/libtai/Makefile2
3 files changed, 4 insertions, 2 deletions
diff --git a/devel/clo++/Makefile b/devel/clo++/Makefile
index d08a25411485..0992ba88c594 100644
--- a/devel/clo++/Makefile
+++ b/devel/clo++/Makefile
@@ -15,6 +15,7 @@ MAINTAINER= kevlo@FreeBSD.org
LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2
USE_GCC= 3.1
+USE_PERL5= yes
CONFGARGS= --prefix ${PREFIX}
CONFGARGS+= --xml2-config ${PREFIX}/bin/xml2-config
diff --git a/devel/dmalloc/Makefile b/devel/dmalloc/Makefile
index a8ecfa7b6c9c..3ab314bd33e3 100644
--- a/devel/dmalloc/Makefile
+++ b/devel/dmalloc/Makefile
@@ -16,6 +16,7 @@ MAINTAINER= jeremy@external.org
INSTALLS_SHLIB= YES
GNU_CONFIGURE= YES
+USE_REINPLACE= yes
CONFIGURE_ARGS+=--enable-threads --enable-shlib
# NOTE: we make the test program first because otherwise it screws up
@@ -23,7 +24,7 @@ CONFIGURE_ARGS+=--enable-threads --enable-shlib
ALL_TARGET= dmalloc_t all light
pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/dmalloc ${PREFIX}/bin
diff --git a/devel/libtai/Makefile b/devel/libtai/Makefile
index dd3c3ae30920..6e341899f952 100644
--- a/devel/libtai/Makefile
+++ b/devel/libtai/Makefile
@@ -34,7 +34,7 @@ PROGRAM_FILES= easter nowutc leapsecs yearcal
HEADER_FILES= caldate.h caltime.h leapsecs.h tai.h taia.h uint64.h
do-configure:
- @${PERL} -pi -e "s!%%PREFIX%%!${PREFIX}!g" \
+ @${REINPLACE_CMD} -e "s!%%PREFIX%%!${PREFIX}!g" \
${WRKSRC}/leapsecs.3 ${WRKSRC}/leapsecs_read.c
@${ECHO_CMD} "${CC} ${CFLAGS}" > ${WRKSRC}/conf-cc
@${ECHO_CMD} "${CC} -s" > ${WRKSRC}/conf-ld