aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorArmin Pirkovitsch <sperber@FreeBSD.org>2012-07-19 17:24:52 +0000
committerArmin Pirkovitsch <sperber@FreeBSD.org>2012-07-19 17:24:52 +0000
commit5e49974d81dce1deec47276cbb4236054edb0aa9 (patch)
tree1bbf0162d1d75a1b654a882c77fc43102cc1ba81 /devel
parent9df88a92a3517924d6d7b307ec22373dd2ecbc8e (diff)
downloadports-5e49974d81dce1deec47276cbb4236054edb0aa9.tar.gz
ports-5e49974d81dce1deec47276cbb4236054edb0aa9.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/asmx/Makefile28
-rw-r--r--devel/asmx/files/Makefile34
2 files changed, 15 insertions, 47 deletions
diff --git a/devel/asmx/Makefile b/devel/asmx/Makefile
index 90290963b882..9360ee326aaf 100644
--- a/devel/asmx/Makefile
+++ b/devel/asmx/Makefile
@@ -7,19 +7,13 @@
PORTNAME= asmx
PORTVERSION= 1.8.2
+PORTREVISION= 1
CATEGORIES= devel
-MASTER_SITES= http://xi6.com/files/ \
- http://distfiles.arcadebsd.org/
+MASTER_SITES= http://xi6.com/files/
MAINTAINER= ports@FreeBSD.org
COMMENT= Multi-CPU macro assembler for many major 8-bit and 16-bit CPUs
-WRKSRC= ${WRKDIR}
-USE_ZIP= yes
-ALL_TARGET=
-
-PORTDOCS= README.txt
-
OPTIONS_DEFINE= 1802 6502 6809 68HC11 68HC16 8051 8085 F8 Z80 DOCS
OPTIONS_DEFAULT= 1802 6502 6809 68HC11 68HC16 8051 8085 F8 Z80
@@ -34,6 +28,12 @@ OPTIONS_DEFAULT= 1802 6502 6809 68HC11 68HC16 8051 8085 F8 Z80
F8_DESC= Fairchild F8
Z80_DESC= Zilog Z-80 and Nintendo Gameboy Z-80 variant
+NO_WRKSUBDIR= yes
+
+USE_ZIP= yes
+
+PORTDOCS= README.txt
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:M1802}
@@ -86,15 +86,17 @@ ALL_TARGET+= asmx-z80
PLIST_FILES+= bin/asmx-z80
.endif
-post-extract:
- ${CP} ${FILESDIR}/Makefile ${WRKSRC}
+post-patch:
+ @${ECHO_CMD} >> ${WRKSRC}/asmguts.h
-pre-build:
- ${ECHO_CMD} ALL_TARGET=${ALL_TARGET}
+do-build:
+.for f in ${ALL_TARGET}
+ (cd ${BUILD_WRKSRC} && ${CC} ${CFLAGS} ${f:S/asmx-/asm/}.c -o ${f})
+.endfor
do-install:
.for f in ${ALL_TARGET}
- ${INSTALL_PROGRAM} ${WRKSRC}/${f} ${PREFIX}/bin/
+ ${INSTALL_PROGRAM} ${WRKSRC}/${f} ${PREFIX}/bin
.endfor
.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
diff --git a/devel/asmx/files/Makefile b/devel/asmx/files/Makefile
deleted file mode 100644
index 8585a6464b0e..000000000000
--- a/devel/asmx/files/Makefile
+++ /dev/null
@@ -1,34 +0,0 @@
-# $FreeBSD$
-
-all:
- @echo "You have to select an options"
-
-asmx-1802:
- ${CC} asm1802.c -o asmx-1802
-
-asmx-6502:
- ${CC} asm6502.c -o asmx-6502
-
-asmx-6809:
- ${CC} asm6809.c -o asmx-6809
-
-asmx-68hc11:
- ${CC} asm68hc11.c -o asmx-68hc11
-
-asmx-68hc16:
- ${CC} asm68hc16.c -o asmx-68hc16
-
-asmx-68k:
- ${CC} asm68k.c -o asmx-68k
-
-asmx-8051:
- ${CC} asm8051.c -o asmx-8051
-
-asmx-8085:
- ${CC} asm8085.c -o asmx-8085
-
-asmx-f8:
- ${CC} asmf8.c -o asmx-f8
-
-asmx-z80:
- ${CC} asmz80.c -o asmx-z80