aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2019-02-21 09:28:42 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2019-02-21 09:28:42 +0000
commit6c2d9cbf940267ff44d4d91e838eca32136dabaf (patch)
tree4b18f0b48dacd1ed1a8cf86ae242c897059422bf /devel
parent77705f6c9757c04b2b49acf70800e579fcfce9be (diff)
downloadports-6c2d9cbf940267ff44d4d91e838eca32136dabaf.tar.gz
ports-6c2d9cbf940267ff44d4d91e838eca32136dabaf.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/fossil/Makefile14
-rw-r--r--devel/fossil/distinfo6
2 files changed, 13 insertions, 7 deletions
diff --git a/devel/fossil/Makefile b/devel/fossil/Makefile
index a85de4344705..0c5f805ad41d 100644
--- a/devel/fossil/Makefile
+++ b/devel/fossil/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= fossil
-PORTVERSION= 2.7
+PORTVERSION= 2.8
DISTVERSIONPREFIX= src-
PORTREVISION= 0
PORTEPOCH= 2
@@ -14,31 +14,36 @@ COMMENT= DSCM with built-in wiki, http interface and server, tickets database
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYRIGHT-BSD2.txt
+USES= ssl
+
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-USES= ssl
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX}
USE_RC_SUBR= fossil
MAKE_JOBS_UNSAFE=yes
-PLIST_FILES= bin/fossil
+PLIST_FILES= bin/fossil man/man1/fossil.1.gz
-OPTIONS_DEFINE= JSON FUSE STATIC TH1HOOKS TCL
+OPTIONS_DEFINE= JSON FUSE SQLITE STATIC TH1HOOKS TCL
OPTIONS_DEFAULT=JSON
JSON_DESC= JSON API support
FUSE_DESC= Enable fossil fusefs command
+SQLITE_DESC= Use sqlite3 from ports
TH1HOOKS_DESC= Enable TH1 command and web page hooks
TCL_DESC= Enable Tcl integration
JSON_CONFIGURE_ON= --json
+SQLITE_CONFIGURE_ON= --disable-internal-sqlite
STATIC_CONFIGURE_ON= --static
+STATIC_LDFLAGS= -pthread
FUSE_CONFIGURE_OFF= --disable-fusefs
TH1HOOKS_CONFIGURE_ON= --with-th1-hooks
TCL_CONFIGURE_ON= --with-tcl-stubs --with-tcl=${TCL_LIBDIR}
TCL_USES= tcl
TCL_CFLAGS= -DTCL_LIBRARY_NAME=\\\"libtcl${TCL_SHLIB_VER}.so\\\" \
-DTCL_MINOR_OFFSET=7
+SQLITE_USES= sqlite localbase:ldflags
FUSE_LIB_DEPENDS= libfuse.so:sysutils/fusefs-libs
FUSE_USES= localbase:ldflags
@@ -47,5 +52,6 @@ post-patch-FUSE-on:
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/fossil
+ ${INSTALL_MAN} ${WRKSRC}/fossil.1 ${STAGEDIR}${MANPREFIX}/man/man1
.include <bsd.port.mk>
diff --git a/devel/fossil/distinfo b/devel/fossil/distinfo
index 800dce79dbac..bfb0dedcbcb0 100644
--- a/devel/fossil/distinfo
+++ b/devel/fossil/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1537775822
-SHA256 (fossil-src-2.7.tar.gz) = 2c24359131d7495e47dc95021eb35f1ba408ded9087e36370d94742a4011033c
-SIZE (fossil-src-2.7.tar.gz) = 5276161
+TIMESTAMP = 1550738988
+SHA256 (fossil-src-2.8.tar.gz) = 6a32bec73de26ff5cc8bbb0b7b45360f4e4145931fd215ed91414ed190b3715d
+SIZE (fossil-src-2.8.tar.gz) = 5359975