aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-12-19 00:49:34 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-12-19 00:49:34 +0000
commit73ce74bbae98df4a98ed042dc563121231aea1d1 (patch)
treeb4ec9e144e51198fabee6c59aba88a7c68874b27 /devel
parent618d32c2fd322770a8b1f0a057271e057045c325 (diff)
DeforaOS system library
PR: ports/172987 Submitted by: Olivier Cochard-Labbe <olivier@cochard.me>
Notes
Notes: svn path=/head/; revision=309213
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/deforaos-libsystem/Makefile23
-rw-r--r--devel/deforaos-libsystem/distinfo2
-rw-r--r--devel/deforaos-libsystem/pkg-descr3
-rw-r--r--devel/deforaos-libsystem/pkg-plist22
5 files changed, 51 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 692ca75398b0..6c0e18d67f3b 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -321,6 +321,7 @@
SUBDIR += dcmtk
SUBDIR += dconf
SUBDIR += ddd
+ SUBDIR += deforaos-libsystem
SUBDIR += deheader
SUBDIR += delta
SUBDIR += deputy
diff --git a/devel/deforaos-libsystem/Makefile b/devel/deforaos-libsystem/Makefile
new file mode 100644
index 000000000000..c1cac76da507
--- /dev/null
+++ b/devel/deforaos-libsystem/Makefile
@@ -0,0 +1,23 @@
+# Created by: Olivier Cochard-Labbe <olivier@cochard.me>
+# $FreeBSD$
+
+PORTNAME= libsystem
+PORTVERSION= 0.1.6
+CATEGORIES= devel
+MASTER_SITES= http://www.defora.org/os/download/download/3527/
+DISTNAME= libSystem-${PORTVERSION}
+PKGNAMEPREFIX= deforaos-
+
+MAINTAINER= olivier@cochard.me
+COMMENT= DeforaOS core system library
+
+LICENSE= GPLv3
+
+USE_LDCONFIG= yes
+USE_PKGCONFIG= build
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|/lib/|/libdata/|g' \
+ ${WRKSRC}/data/pkgconfig.sh
+
+.include <bsd.port.mk>
diff --git a/devel/deforaos-libsystem/distinfo b/devel/deforaos-libsystem/distinfo
new file mode 100644
index 000000000000..ff9cd5bce06a
--- /dev/null
+++ b/devel/deforaos-libsystem/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libSystem-0.1.6.tar.gz) = 6eb4ffa278072c8e1e0aeb5cb27a204af6c35a4d63387d495113d7ca8a8ae69f
+SIZE (libSystem-0.1.6.tar.gz) = 44092
diff --git a/devel/deforaos-libsystem/pkg-descr b/devel/deforaos-libsystem/pkg-descr
new file mode 100644
index 000000000000..99e9d5913b22
--- /dev/null
+++ b/devel/deforaos-libsystem/pkg-descr
@@ -0,0 +1,3 @@
+DeforaOS system library
+
+WWW: http://www.defora.org/
diff --git a/devel/deforaos-libsystem/pkg-plist b/devel/deforaos-libsystem/pkg-plist
new file mode 100644
index 000000000000..13f2fc043bbe
--- /dev/null
+++ b/devel/deforaos-libsystem/pkg-plist
@@ -0,0 +1,22 @@
+bin/AppBroker
+include/System.h
+include/System/appclient.h
+include/System/appserver.h
+include/System/array.h
+include/System/buffer.h
+include/System/config.h
+include/System/error.h
+include/System/event.h
+include/System/file.h
+include/System/hash.h
+include/System/object.h
+include/System/parser.h
+include/System/plugin.h
+include/System/string.h
+include/System/token.h
+lib/libSystem.a
+lib/libSystem.so
+lib/libSystem.so.0
+lib/libSystem.so.0.0
+libdata/pkgconfig/libSystem.pc
+@dirrm include/System