aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2002-07-05 12:14:03 +0000
committerAnton Berezin <tobez@FreeBSD.org>2002-07-05 12:14:03 +0000
commit9c5080165f1e32ac2269917c8f5655b63a0393c8 (patch)
treec3f7cd8e8c876b6f2d33d7d5443ea4c4162d81e3 /devel
parent34a9256d6580372bacbeb84489cae9ae29ee20c6 (diff)
downloadports-9c5080165f1e32ac2269917c8f5655b63a0393c8.tar.gz
ports-9c5080165f1e32ac2269917c8f5655b63a0393c8.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Class-Container/Makefile27
-rw-r--r--devel/p5-Class-Container/distinfo1
-rw-r--r--devel/p5-Class-Container/pkg-comment1
-rw-r--r--devel/p5-Class-Container/pkg-descr16
-rw-r--r--devel/p5-Class-Container/pkg-plist5
6 files changed, 51 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 5e5ade72c3bc..1f36d064e336 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -379,6 +379,7 @@
SUBDIR += p5-Cdk
SUBDIR += p5-Class-Accessor
SUBDIR += p5-Class-BlackHole
+ SUBDIR += p5-Class-Container
SUBDIR += p5-Class-Contract
SUBDIR += p5-Class-Data-Inheritable
SUBDIR += p5-Class-Date
diff --git a/devel/p5-Class-Container/Makefile b/devel/p5-Class-Container/Makefile
new file mode 100644
index 000000000000..df50217e6036
--- /dev/null
+++ b/devel/p5-Class-Container/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: Class::Container
+# Date created: 5 July 2002
+# Whom: Denis Shaposhnikov <dsh@vlink.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Class-Container
+PORTVERSION= 0.05
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Class
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= dsh@vlink.ru
+
+BUILD_DEPENDS= ${SITE_PERL}/Params/Validate.pm:${PORTSDIR}/devel/p5-Params-Validate \
+ ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+MAN3= Class::Container.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Class-Container/distinfo b/devel/p5-Class-Container/distinfo
new file mode 100644
index 000000000000..6ef0d5329672
--- /dev/null
+++ b/devel/p5-Class-Container/distinfo
@@ -0,0 +1 @@
+MD5 (Class-Container-0.05.tar.gz) = e96ce7b862329929c5139c56796512a6
diff --git a/devel/p5-Class-Container/pkg-comment b/devel/p5-Class-Container/pkg-comment
new file mode 100644
index 000000000000..925f827083d6
--- /dev/null
+++ b/devel/p5-Class-Container/pkg-comment
@@ -0,0 +1 @@
+Glues object frameworks together transparently
diff --git a/devel/p5-Class-Container/pkg-descr b/devel/p5-Class-Container/pkg-descr
new file mode 100644
index 000000000000..668c8233fbef
--- /dev/null
+++ b/devel/p5-Class-Container/pkg-descr
@@ -0,0 +1,16 @@
+This class facilitates building frameworks of several classes that
+inter-operate. It was first designed and built for "HTML::Mason", in
+which the Compiler, Lexer, Interpreter, Resolver, Component, Buffer,
+and several other objects must create each other transparently,
+passing the appropriate parameters to the right class, possibly
+substituting their own subclass for any of these objects.
+
+The main features of "Class::Container" are:
+
+ * Declaration of parameters used by each member in a class framework
+
+ * Transparent passing of constructor parameters to the class that
+ needs them
+
+ * Ability to create one (automatic) or many (manual) contained
+ objects automatically and transparently
diff --git a/devel/p5-Class-Container/pkg-plist b/devel/p5-Class-Container/pkg-plist
new file mode 100644
index 000000000000..4a3c980071b5
--- /dev/null
+++ b/devel/p5-Class-Container/pkg-plist
@@ -0,0 +1,5 @@
+lib/perl5/site_perl/%%PERL_VER%%/Class/Container.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Class/Container/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Class
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Class/Container
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Class