aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-12-24 21:22:21 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-12-24 21:22:21 +0000
commitb1bf1620a6571c5eb84bed4e3f06cf52094d0a48 (patch)
tree93506aaee5230ee46b75930c4b3a6b8e0f243d74 /devel
parent123411e1ee17366ee88efd54b8482949b8e76eb5 (diff)
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/cmake-modules/Makefile2
-rw-r--r--devel/cmake/files/patch-Modules_FindFreetype.cmake28
-rw-r--r--devel/lasi/Makefile2
-rw-r--r--devel/lasi/files/patch-include_LASi.h12
-rw-r--r--devel/lasi/files/patch-src_drawGlyph.cpp12
-rw-r--r--devel/lasi/files/patch-src_drawGlyph.h12
-rw-r--r--devel/lasi/files/patch-src_glyphMgr.cpp12
-rw-r--r--devel/lasi/files/patch-src_glyphMgr.h12
-rw-r--r--devel/lasi/files/patch-src_util.h11
-rw-r--r--devel/love/files/patch-src_modules_font_freetype_Font.h17
-rw-r--r--devel/love/files/patch-src_modules_font_freetype_TrueTypeRasterizer.h17
-rw-r--r--devel/love07/files/patch-src_modules_font_freetype_Font.h17
-rw-r--r--devel/love07/files/patch-src_modules_font_freetype_TrueTypeRasterizer.h17
-rw-r--r--devel/love5/files/patch-src_opengl_TrueTypeFont.h17
14 files changed, 186 insertions, 2 deletions
diff --git a/devel/cmake-modules/Makefile b/devel/cmake-modules/Makefile
index 45f8e120f2c5..d8483a64e742 100644
--- a/devel/cmake-modules/Makefile
+++ b/devel/cmake-modules/Makefile
@@ -1,7 +1,7 @@
# Created by: gahr
# $FreeBSD$
-PORTREVISION= 0
+PORTREVISION= 1
PKGNAMESUFFIX= -modules
COMMENT= Modules and Templates for CMake
diff --git a/devel/cmake/files/patch-Modules_FindFreetype.cmake b/devel/cmake/files/patch-Modules_FindFreetype.cmake
new file mode 100644
index 000000000000..e053e80bea84
--- /dev/null
+++ b/devel/cmake/files/patch-Modules_FindFreetype.cmake
@@ -0,0 +1,28 @@
+In the 2.5.1 release of freetype most of the headers where moved from
+freetype2/freetype/* -> freetype2/*. So we need to update the detection
+rules to take this into account.
+
+http://public.kitware.com/Bug/view.php?id=14601
+
+--- Modules/FindFreetype.cmake.orig 2013-12-13 11:15:05.000000000 +0100
++++ Modules/FindFreetype.cmake 2013-12-13 11:15:39.000000000 +0100
+@@ -56,7 +56,7 @@
+ PATH_SUFFIXES include/freetype2 include
+ )
+
+-find_path(FREETYPE_INCLUDE_DIR_freetype2 freetype/config/ftheader.h
++find_path(FREETYPE_INCLUDE_DIR_freetype2 config/ftheader.h
+ HINTS
+ ENV FREETYPE_DIR
+ PATHS
+@@ -91,8 +91,8 @@
+ endif()
+ set(FREETYPE_LIBRARIES "${FREETYPE_LIBRARY}")
+
+-if(FREETYPE_INCLUDE_DIR_freetype2 AND EXISTS "${FREETYPE_INCLUDE_DIR_freetype2}/freetype/freetype.h")
+- file(STRINGS "${FREETYPE_INCLUDE_DIR_freetype2}/freetype/freetype.h" freetype_version_str
++if(FREETYPE_INCLUDE_DIR_freetype2 AND EXISTS "${FREETYPE_INCLUDE_DIR_freetype2}/freetype.h")
++ file(STRINGS "${FREETYPE_INCLUDE_DIR_freetype2}/freetype.h" freetype_version_str
+ REGEX "^#[\t ]*define[\t ]+FREETYPE_(MAJOR|MINOR|PATCH)[\t ]+[0-9]+$")
+
+ unset(FREETYPE_VERSION_STRING)
diff --git a/devel/lasi/Makefile b/devel/lasi/Makefile
index 0b74f6fbd7ff..7f4f39febe67 100644
--- a/devel/lasi/Makefile
+++ b/devel/lasi/Makefile
@@ -4,7 +4,7 @@
PORTNAME= lasi
PORTVERSION= 1.1.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}%20Source
DISTNAME= libLASi-${PORTVERSION}
diff --git a/devel/lasi/files/patch-include_LASi.h b/devel/lasi/files/patch-include_LASi.h
new file mode 100644
index 000000000000..613b5c712c83
--- /dev/null
+++ b/devel/lasi/files/patch-include_LASi.h
@@ -0,0 +1,12 @@
+--- include/LASi.h.orig 2013-12-13 10:12:32.000000000 +0100
++++ include/LASi.h 2013-12-13 10:14:20.000000000 +0100
+@@ -11,7 +11,8 @@
+ #include <sstream>
+ #include <map>
+ #include <pango/pango.h>
+-#include <freetype/ftglyph.h>
++#include <ft2build.h>
++#include FT_GLYPH_H
+
+ class FreetypeGlyphMgr;
+ class ContextMgr;
diff --git a/devel/lasi/files/patch-src_drawGlyph.cpp b/devel/lasi/files/patch-src_drawGlyph.cpp
new file mode 100644
index 000000000000..1ce9a4c23382
--- /dev/null
+++ b/devel/lasi/files/patch-src_drawGlyph.cpp
@@ -0,0 +1,12 @@
+--- src/drawGlyph.cpp.orig 2013-12-13 10:13:26.000000000 +0100
++++ src/drawGlyph.cpp 2013-12-13 10:15:19.000000000 +0100
+@@ -6,7 +6,8 @@
+ */
+
+ #include <ostream>
+-#include <freetype/ftoutln.h>
++#include <ft2build.h>
++#include FT_OUTLINE_H
+ #include <algorithm>
+ #include <LASi.h>
+ #include <config.h>
diff --git a/devel/lasi/files/patch-src_drawGlyph.h b/devel/lasi/files/patch-src_drawGlyph.h
new file mode 100644
index 000000000000..cb174aae7889
--- /dev/null
+++ b/devel/lasi/files/patch-src_drawGlyph.h
@@ -0,0 +1,12 @@
+--- src/drawGlyph.h.orig 2013-12-13 10:13:05.000000000 +0100
++++ src/drawGlyph.h 2013-12-13 10:15:40.000000000 +0100
+@@ -10,7 +10,8 @@
+
+ #include <iostream>
+ #include <pango/pango.h>
+-#include <freetype/freetype.h>
++#include <ft2build.h>
++#include FT_FREETYPE_H
+
+ /** Generate the Postscript commands to draw the glyph
+ * using the font in pPangoCtx.
diff --git a/devel/lasi/files/patch-src_glyphMgr.cpp b/devel/lasi/files/patch-src_glyphMgr.cpp
new file mode 100644
index 000000000000..426821e6d803
--- /dev/null
+++ b/devel/lasi/files/patch-src_glyphMgr.cpp
@@ -0,0 +1,12 @@
+--- src/glyphMgr.cpp.orig 2013-12-13 10:13:39.000000000 +0100
++++ src/glyphMgr.cpp 2013-12-13 10:17:39.000000000 +0100
+@@ -10,8 +10,7 @@
+
+ #include <ft2build.h>
+ #include FT_FREETYPE_H
+-
+-#include <freetype/ftglyph.h>
++#include FT_GLYPH_H
+
+ #include <cassert>
+ #include "util.h"
diff --git a/devel/lasi/files/patch-src_glyphMgr.h b/devel/lasi/files/patch-src_glyphMgr.h
new file mode 100644
index 000000000000..23afe4b1052f
--- /dev/null
+++ b/devel/lasi/files/patch-src_glyphMgr.h
@@ -0,0 +1,12 @@
+--- src/glyphMgr.h.orig 2013-12-13 10:13:45.000000000 +0100
++++ src/glyphMgr.h 2013-12-13 10:17:50.000000000 +0100
+@@ -15,8 +15,7 @@
+
+ #include <ft2build.h>
+ #include FT_FREETYPE_H
+-
+-#include <freetype/ftglyph.h>
++#include FT_GLYPH_H
+
+ /** Manage FT_Glyph by insuring that FT_Glyph is handled correctly.
+ */
diff --git a/devel/lasi/files/patch-src_util.h b/devel/lasi/files/patch-src_util.h
new file mode 100644
index 000000000000..567da584216a
--- /dev/null
+++ b/devel/lasi/files/patch-src_util.h
@@ -0,0 +1,11 @@
+--- src/util.h.orig 2013-12-13 10:13:16.000000000 +0100
++++ src/util.h 2013-12-13 10:17:01.000000000 +0100
+@@ -18,7 +18,7 @@
+
+ #include <ft2build.h>
+ #include FT_FREETYPE_H
+-#include <freetype/ftglyph.h>
++#include FT_GLYPH_H
+
+ std::ostream& operator<<(std::ostream&, const FT_Library);
+ std::ostream& operator<<(std::ostream&, const FT_Face);
diff --git a/devel/love/files/patch-src_modules_font_freetype_Font.h b/devel/love/files/patch-src_modules_font_freetype_Font.h
new file mode 100644
index 000000000000..361373507e0f
--- /dev/null
+++ b/devel/love/files/patch-src_modules_font_freetype_Font.h
@@ -0,0 +1,17 @@
+--- src/modules/font/freetype/Font.h.orig 2013-12-13 10:24:12.000000000 +0100
++++ src/modules/font/freetype/Font.h 2013-12-13 10:25:51.000000000 +0100
+@@ -30,10 +30,10 @@
+ #else
+ #include <ft2build.h>
+ #endif
+-#include <freetype/freetype.h>
+-#include <freetype/ftglyph.h>
+-#include <freetype/ftoutln.h>
+-#include <freetype/fttrigon.h>
++#include FT_FREETYPE_H
++#include FT_GLYPH_H
++#include FT_OUTLINE_H
++#include FT_TRIGONOMETRY_H
+
+ namespace love
+ {
diff --git a/devel/love/files/patch-src_modules_font_freetype_TrueTypeRasterizer.h b/devel/love/files/patch-src_modules_font_freetype_TrueTypeRasterizer.h
new file mode 100644
index 000000000000..29204d223e88
--- /dev/null
+++ b/devel/love/files/patch-src_modules_font_freetype_TrueTypeRasterizer.h
@@ -0,0 +1,17 @@
+--- src/modules/font/freetype/TrueTypeRasterizer.h.orig 2013-12-13 10:24:01.000000000 +0100
++++ src/modules/font/freetype/TrueTypeRasterizer.h 2013-12-13 10:26:35.000000000 +0100
+@@ -27,10 +27,10 @@
+
+ // TrueType2
+ #include <ft2build.h>
+-#include <freetype/freetype.h>
+-#include <freetype/ftglyph.h>
+-#include <freetype/ftoutln.h>
+-#include <freetype/fttrigon.h>
++#include FT_FREETYPE_H
++#include FT_GLYPH_H
++#include FT_OUTLINE_H
++#include FT_TRIGONOMETRY_H
+
+ namespace love
+ {
diff --git a/devel/love07/files/patch-src_modules_font_freetype_Font.h b/devel/love07/files/patch-src_modules_font_freetype_Font.h
new file mode 100644
index 000000000000..361373507e0f
--- /dev/null
+++ b/devel/love07/files/patch-src_modules_font_freetype_Font.h
@@ -0,0 +1,17 @@
+--- src/modules/font/freetype/Font.h.orig 2013-12-13 10:24:12.000000000 +0100
++++ src/modules/font/freetype/Font.h 2013-12-13 10:25:51.000000000 +0100
+@@ -30,10 +30,10 @@
+ #else
+ #include <ft2build.h>
+ #endif
+-#include <freetype/freetype.h>
+-#include <freetype/ftglyph.h>
+-#include <freetype/ftoutln.h>
+-#include <freetype/fttrigon.h>
++#include FT_FREETYPE_H
++#include FT_GLYPH_H
++#include FT_OUTLINE_H
++#include FT_TRIGONOMETRY_H
+
+ namespace love
+ {
diff --git a/devel/love07/files/patch-src_modules_font_freetype_TrueTypeRasterizer.h b/devel/love07/files/patch-src_modules_font_freetype_TrueTypeRasterizer.h
new file mode 100644
index 000000000000..29204d223e88
--- /dev/null
+++ b/devel/love07/files/patch-src_modules_font_freetype_TrueTypeRasterizer.h
@@ -0,0 +1,17 @@
+--- src/modules/font/freetype/TrueTypeRasterizer.h.orig 2013-12-13 10:24:01.000000000 +0100
++++ src/modules/font/freetype/TrueTypeRasterizer.h 2013-12-13 10:26:35.000000000 +0100
+@@ -27,10 +27,10 @@
+
+ // TrueType2
+ #include <ft2build.h>
+-#include <freetype/freetype.h>
+-#include <freetype/ftglyph.h>
+-#include <freetype/ftoutln.h>
+-#include <freetype/fttrigon.h>
++#include FT_FREETYPE_H
++#include FT_GLYPH_H
++#include FT_OUTLINE_H
++#include FT_TRIGONOMETRY_H
+
+ namespace love
+ {
diff --git a/devel/love5/files/patch-src_opengl_TrueTypeFont.h b/devel/love5/files/patch-src_opengl_TrueTypeFont.h
new file mode 100644
index 000000000000..bb88d134a49b
--- /dev/null
+++ b/devel/love5/files/patch-src_opengl_TrueTypeFont.h
@@ -0,0 +1,17 @@
+--- src/opengl/TrueTypeFont.h.orig 2013-12-13 10:36:51.000000000 +0100
++++ src/opengl/TrueTypeFont.h 2013-12-13 10:38:20.000000000 +0100
+@@ -13,10 +13,10 @@
+
+ // FreeType2
+ #include <ft2build.h>
+-#include <freetype/freetype.h>
+-#include <freetype/ftglyph.h>
+-#include <freetype/ftoutln.h>
+-#include <freetype/fttrigon.h>
++#include FT_FREETYPE_H
++#include FT_GLYPH_H
++#include FT_OUTLINE_H
++#include FT_TRIGONOMETRY_H
+
+ // STD
+ #include <string>