aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorSimon Barner <barner@FreeBSD.org>2005-11-22 11:02:22 +0000
committerSimon Barner <barner@FreeBSD.org>2005-11-22 11:02:22 +0000
commitc4f287ff6e960ee6d9576e8a9748a06d8c8d6ef5 (patch)
tree610b8124fa6217c7de07f3dd7a603fde7ca4601c /devel
parentabb71e55cf110ce51cbf959783ffebe91c0017c4 (diff)
downloadports-c4f287ff6e960ee6d9576e8a9748a06d8c8d6ef5.tar.gz
ports-c4f287ff6e960ee6d9576e8a9748a06d8c8d6ef5.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/boost-gcc3/Makefile24
-rw-r--r--devel/boost-gcc3/pkg-descr15
3 files changed, 40 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 6bdcef85fecc..000f3e386bb2 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -90,6 +90,7 @@
SUBDIR += bonobo
SUBDIR += bonobo-conf
SUBDIR += boost
+ SUBDIR += boost-gcc3
SUBDIR += boost-python
SUBDIR += bouml
SUBDIR += bugbuddy
diff --git a/devel/boost-gcc3/Makefile b/devel/boost-gcc3/Makefile
new file mode 100644
index 000000000000..3dee9cc58eae
--- /dev/null
+++ b/devel/boost-gcc3/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: boost-gcc3
+# Date Created: Nov 11 2005
+# Whom: barner
+#
+# $FreeBSD$
+#
+
+COMMENT= Free portable C++ source libraries (built with GCC 3.4+)
+
+MASTERDIR= ${.CURDIR}/../../devel/boost
+PKGDIR= ${.CURDIR}
+PLIST= ${MASTERDIR}/pkg-plist
+
+WITH_PYTHON= yes
+WITH_THREADS= yes
+WITHOUT_ICU= yes
+WITH_OPTIMIZED_CFLAGS= yes
+WITH_GCC34= yes
+WITHOUT_VERBOSE_BUILD= yes
+WITHOUT_DEBUG= yes
+
+BOOST_GCC3_PORT= yes
+
+.include "${MASTERDIR}/Makefile"
diff --git a/devel/boost-gcc3/pkg-descr b/devel/boost-gcc3/pkg-descr
new file mode 100644
index 000000000000..a6f88a6615e2
--- /dev/null
+++ b/devel/boost-gcc3/pkg-descr
@@ -0,0 +1,15 @@
+The Boost web site provides free peer-reviewed portable C++ source
+libraries. The emphasis is on libraries which work well with the C++
+Standard Library. One goal is to establish "existing practice" and
+provide reference implementations so that the Boost libraries are
+suitable for eventual standardization. Some of the libraries have
+already been proposed for inclusion in the C++ Standards Committee's
+upcoming C++ Standard Library Technical Report.
+
+This slave port forces the use of GCC 3.4+ and is intended for FreeBSD 4.x
+only (in fact, it's IGNOREd on later FreeBSD versions).
+
+So, if you port needs GCC 3.4+ and Boost, or it needs spirit 1.8, that is
+not available with GCC 2.95.4, you can use this port as a dependency.
+
+WWW: http://www.boost.org/