aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2003-08-19 10:57:34 +0000
committerMathieu Arnold <mat@FreeBSD.org>2003-08-19 10:57:34 +0000
commitd61d3045ff9d8ad8d9db4c60d98838d25e46b6f3 (patch)
treec0e73e9d061c91819efe10486653557d7e516082 /devel
parent8187eb918d97cf13399d0cc0966cac586d2bc353 (diff)
downloadports-d61d3045ff9d8ad8d9db4c60d98838d25e46b6f3.tar.gz
ports-d61d3045ff9d8ad8d9db4c60d98838d25e46b6f3.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-DateTime-Format-HTTP/Makefile40
-rw-r--r--devel/p5-DateTime-Format-HTTP/distinfo1
-rw-r--r--devel/p5-DateTime-Format-HTTP/pkg-descr4
-rw-r--r--devel/p5-DateTime-Format-HTTP/pkg-plist7
5 files changed, 53 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index a22a95733a06..05388df8119a 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -563,6 +563,7 @@
SUBDIR += p5-DateTime-Format-DateManip
SUBDIR += p5-DateTime-Format-Epoch
SUBDIR += p5-DateTime-Format-Excel
+ SUBDIR += p5-DateTime-Format-HTTP
SUBDIR += p5-DateTime-Format-ICal
SUBDIR += p5-DateTime-Format-ISO8601
SUBDIR += p5-DateTime-Format-Mail
diff --git a/devel/p5-DateTime-Format-HTTP/Makefile b/devel/p5-DateTime-Format-HTTP/Makefile
new file mode 100644
index 000000000000..2fe071a2977a
--- /dev/null
+++ b/devel/p5-DateTime-Format-HTTP/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: p5-DateTime-Format-HTTP
+# Date created: 7 july 2003
+# Whom: Mathieu Arnold <mat@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DateTime-Format-HTTP
+PORTVERSION= 0.35
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= DateTime
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= mat@FreeBSD.org
+COMMENT= HTTP date conversion routines
+
+BUILD_DEPENDS= ${RUN_DEPENDS} \
+ ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DateTime.pm:${PORTSDIR}/devel/p5-DateTime \
+ ${SITE_PERL}/Test/Pod.pm:${PORTSDIR}/devel/p5-Test-Pod \
+ ${SITE_PERL}/HTTP/Date.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/File/Find/Rule.pm:${PORTSDIR}/devel/p5-File-Find-Rule
+
+PERL_CONFIGURE= yes
+
+MAN3= DateTime::Format::HTTP.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} <= 500600
+RUN_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
+.endif
+.if ${PERL_LEVEL} < 500600
+post-patch:
+ @${PERL} -pi -e '$$_ = "" if /use warnings/;' \
+ ${WRKSRC}/lib/DateTime/Format/HTTP.pm
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-DateTime-Format-HTTP/distinfo b/devel/p5-DateTime-Format-HTTP/distinfo
new file mode 100644
index 000000000000..7b45a30945f2
--- /dev/null
+++ b/devel/p5-DateTime-Format-HTTP/distinfo
@@ -0,0 +1 @@
+MD5 (DateTime-Format-HTTP-0.35.tar.gz) = 43e7a44bad1c6c4e0385c58caf9f36f9
diff --git a/devel/p5-DateTime-Format-HTTP/pkg-descr b/devel/p5-DateTime-Format-HTTP/pkg-descr
new file mode 100644
index 000000000000..d2aea756eb4d
--- /dev/null
+++ b/devel/p5-DateTime-Format-HTTP/pkg-descr
@@ -0,0 +1,4 @@
+This module provides functions that deal the date formats used by the HTTP
+protocol (and then some more).
+
+WWW: http://datetime.perl.org/
diff --git a/devel/p5-DateTime-Format-HTTP/pkg-plist b/devel/p5-DateTime-Format-HTTP/pkg-plist
new file mode 100644
index 000000000000..f560b390da68
--- /dev/null
+++ b/devel/p5-DateTime-Format-HTTP/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/DateTime/Format/HTTP.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime/Format/HTTP/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime/Format/HTTP
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime/Format 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/DateTime/Format 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/DateTime 2>/dev/null || true