aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2002-02-15 07:40:02 +0000
committerKevin Lo <kevlo@FreeBSD.org>2002-02-15 07:40:02 +0000
commitda648eea86883b6403f105d8ab4ed20ce6d67154 (patch)
tree8183b86047a7d7e4905a7b8230f61a51fe640d32 /devel
parentdaa8cb06f00b9558795f1028a6e661fb43ffe666 (diff)
downloadports-da648eea86883b6403f105d8ab4ed20ce6d67154.tar.gz
ports-da648eea86883b6403f105d8ab4ed20ce6d67154.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-File-FTS/Makefile22
-rw-r--r--devel/p5-File-FTS/distinfo1
-rw-r--r--devel/p5-File-FTS/pkg-comment1
-rw-r--r--devel/p5-File-FTS/pkg-descr6
-rw-r--r--devel/p5-File-FTS/pkg-plist5
6 files changed, 36 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index b83e6964b373..04853bf3609f 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -385,6 +385,7 @@
SUBDIR += p5-File-BasicFlock
SUBDIR += p5-File-Binary
SUBDIR += p5-File-Cache
+ SUBDIR += p5-File-FTS
SUBDIR += p5-File-Lock
SUBDIR += p5-File-MMagic
SUBDIR += p5-File-ReadBackwards
diff --git a/devel/p5-File-FTS/Makefile b/devel/p5-File-FTS/Makefile
new file mode 100644
index 000000000000..4aeb19b6762d
--- /dev/null
+++ b/devel/p5-File-FTS/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: File::FTS
+# Date created: 24 Jan 2002
+# Whom: Seamus Venasse <svenasse@polaris.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= File-FTS
+PORTVERSION= 0.01
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= File
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= svenasse@polaris.ca
+
+PERL_CONFIGURE= yes
+
+MAN3= File::FTS.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/devel/p5-File-FTS/distinfo b/devel/p5-File-FTS/distinfo
new file mode 100644
index 000000000000..282f88bdd178
--- /dev/null
+++ b/devel/p5-File-FTS/distinfo
@@ -0,0 +1 @@
+MD5 (File-FTS-0.01.tar.gz) = bcdd80f05b083adcdae4514b3a75164b
diff --git a/devel/p5-File-FTS/pkg-comment b/devel/p5-File-FTS/pkg-comment
new file mode 100644
index 000000000000..858968176efd
--- /dev/null
+++ b/devel/p5-File-FTS/pkg-comment
@@ -0,0 +1 @@
+Perl extension for File Traversing System
diff --git a/devel/p5-File-FTS/pkg-descr b/devel/p5-File-FTS/pkg-descr
new file mode 100644
index 000000000000..ee2532649efa
--- /dev/null
+++ b/devel/p5-File-FTS/pkg-descr
@@ -0,0 +1,6 @@
+This is similar to File::Find, but works non recursively.
+Symbolic links to directories are skipped.
+
+WWW: http://search.cpan.org/search?dist=File-FTS
+
+Seamus Venasse <svenasse@polaris.ca>
diff --git a/devel/p5-File-FTS/pkg-plist b/devel/p5-File-FTS/pkg-plist
new file mode 100644
index 000000000000..ad50f526ab45
--- /dev/null
+++ b/devel/p5-File-FTS/pkg-plist
@@ -0,0 +1,5 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/File/FTS/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/File/FTS.pm
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/File 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/File/FTS 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/File 2>/dev/null || true