aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-02-11 19:16:38 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-02-11 19:16:38 +0000
commitf4007305b3b74044616f3c550d184080d128e9d6 (patch)
tree9a1830b2f3f7fe11aeba539bcc16e200afcae10d /devel
parentaeefc83b6ce0f12649d48480725bd0f44ea14563 (diff)
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/gnomevfs-extras/Makefile37
-rw-r--r--devel/gnomevfs-extras/distinfo1
-rw-r--r--devel/gnomevfs-extras/files/patch-Makefile.in11
-rw-r--r--devel/gnomevfs-extras/files/patch-configure28
-rw-r--r--devel/gnomevfs-extras/files/patch-smb.desktop.in9
-rw-r--r--devel/gnomevfs-extras/pkg-comment1
-rw-r--r--devel/gnomevfs-extras/pkg-descr14
-rw-r--r--devel/gnomevfs-extras/pkg-plist24
9 files changed, 126 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 43d29afbafdf..4c0d83a025bb 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -217,6 +217,7 @@
SUBDIR += gnomecrash
SUBDIR += gnomedebug
SUBDIR += gnomevfs
+ SUBDIR += gnomevfs-extras
SUBDIR += gnomevfs2
SUBDIR += gnustep
SUBDIR += gnustep-make
diff --git a/devel/gnomevfs-extras/Makefile b/devel/gnomevfs-extras/Makefile
new file mode 100644
index 000000000000..648745726773
--- /dev/null
+++ b/devel/gnomevfs-extras/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: gnomevfs-extras
+# Date created: 20 January 2003
+# Whom: Koop Mast <einekoai@chello.nl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnomevfs-extras
+PORTVERSION= 0.99.9
+CATEGORIES= devel gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/gnome-vfs-extras/0.99
+DISTNAME= gnome-vfs-extras-${PORTVERSION}
+DIST_SUBDIR= gnome2
+
+MAINTAINER= einekoai@chello.nl
+
+LIB_DEPENDS= gnomevfs-2.0:${PORTSDIR}/devel/gnomevfs2
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomeprefix gnomehack gnomehier
+USE_REINPLACE= yes
+USE_LIBTOOL= yes
+CONFIGURE_ARGS= --without-rio500
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @${FIND} ${WRKSRC} -name "*.[ch]" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|malloc\.h|stdlib.h|g'
+
+.include <bsd.port.mk>
diff --git a/devel/gnomevfs-extras/distinfo b/devel/gnomevfs-extras/distinfo
new file mode 100644
index 000000000000..251d76f93e6f
--- /dev/null
+++ b/devel/gnomevfs-extras/distinfo
@@ -0,0 +1 @@
+MD5 (gnome2/gnome-vfs-extras-0.99.9.tar.bz2) = 3a08e29319d0b03072796603a4df1d58
diff --git a/devel/gnomevfs-extras/files/patch-Makefile.in b/devel/gnomevfs-extras/files/patch-Makefile.in
new file mode 100644
index 000000000000..804a69ceb4f7
--- /dev/null
+++ b/devel/gnomevfs-extras/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Fri Feb 7 22:14:28 2003
++++ Makefile.in Fri Feb 7 22:16:50 2003
+@@ -149,7 +150,7 @@
+ modulesconfdir = $(sysconfdir)/gnome-vfs-2.0/modules
+ modulesconf_DATA = extra-modules.conf
+
+-desktopdir = $(datadir)/network
++desktopdir = $(datadir)/apps/Applications
+ desktop_in_files = smb.desktop.in
+ desktop_DATA = $(desktop_in_files:.desktop.in=.desktop)
+
diff --git a/devel/gnomevfs-extras/files/patch-configure b/devel/gnomevfs-extras/files/patch-configure
new file mode 100644
index 000000000000..9bc0fc672411
--- /dev/null
+++ b/devel/gnomevfs-extras/files/patch-configure
@@ -0,0 +1,28 @@
+--- configure.orig Thu Feb 6 11:37:10 2003
++++ configure Sun Feb 9 21:03:39 2003
+@@ -7129,6 +7129,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
+@@ -7751,7 +7752,7 @@
+ echo "${ECHO_T}$with_rio500" >&6
+
+ LDFLAGS="-L$with_rio500/lib -L/usr/local/lib $LDFLAGS"
+-CPPFLAGS="-I$with_rio500/include/rio500 -I/usr/local/include/rio500 $CFLAGS"
++CPPFLAGS="-I$with_rio500/include/rio500 -I/usr/local/include/rio500 $CPPFLAGS $CFLAGS"
+
+ else
+
+@@ -7759,7 +7760,7 @@
+ echo "${ECHO_T}none" >&6
+
+ LDFLAGS="-L/usr/local/lib $LDFLAGS"
+-CPPFLAGS="-I/usr/include/rio500 -I/usr/local/include/rio500 $CFLAGS"
++CPPFLAGS="-I/usr/include/rio500 -I/usr/local/include/rio500 $CPPFLAGS $CFLAGS"
+
+ fi;
+
diff --git a/devel/gnomevfs-extras/files/patch-smb.desktop.in b/devel/gnomevfs-extras/files/patch-smb.desktop.in
new file mode 100644
index 000000000000..0b5706ead745
--- /dev/null
+++ b/devel/gnomevfs-extras/files/patch-smb.desktop.in
@@ -0,0 +1,9 @@
+--- smb.desktop.in.orig Wed Dec 11 12:09:03 2002
++++ smb.desktop.in Wed Feb 5 19:23:23 2003
+@@ -3,5 +3,5 @@
+ Type=Link
+ Name=Network neighborhood
+ Comment=Window Shares in you local network
+-URL=smb:
++URL=smb:///
+ Icon=gnome-fs-smb
diff --git a/devel/gnomevfs-extras/pkg-comment b/devel/gnomevfs-extras/pkg-comment
new file mode 100644
index 000000000000..0d37636a1794
--- /dev/null
+++ b/devel/gnomevfs-extras/pkg-comment
@@ -0,0 +1 @@
+A plugin for gnomevfs2 to browse smb shares with nautilus2
diff --git a/devel/gnomevfs-extras/pkg-descr b/devel/gnomevfs-extras/pkg-descr
new file mode 100644
index 000000000000..d9265092acb8
--- /dev/null
+++ b/devel/gnomevfs-extras/pkg-descr
@@ -0,0 +1,14 @@
+[sniped from readme]
+
+ This lets you browse the "network neighbourhood" like in windows
+ by entering the location smb:// in Nautilus. This lists the
+ workgroups on your local network, and you can browse around servers
+ and shares.
+
+ You can also go directly to smb servers by entering the location
+ smb://server/, where server is the NMB (windows) name, the dns name
+ or the ip address. By using ip you can reach machines outside your
+ local subnet.
+
+ If the password popup doesn't appear you can use:
+ smb://user:password@server/share/ notation.
diff --git a/devel/gnomevfs-extras/pkg-plist b/devel/gnomevfs-extras/pkg-plist
new file mode 100644
index 000000000000..20bc2c1715c4
--- /dev/null
+++ b/devel/gnomevfs-extras/pkg-plist
@@ -0,0 +1,24 @@
+etc/gnome-vfs-2.0/modules/extra-modules.conf
+lib/gnome-vfs-2.0/modules/libsmb.so
+share/gnome/apps/Applications/smb.desktop
+share/locale/am/LC_MESSAGES/gnome-vfs-extras.mo
+share/locale/bg/LC_MESSAGES/gnome-vfs-extras.mo
+share/locale/cs/LC_MESSAGES/gnome-vfs-extras.mo
+share/locale/da/LC_MESSAGES/gnome-vfs-extras.mo
+share/locale/de/LC_MESSAGES/gnome-vfs-extras.mo
+share/locale/el/LC_MESSAGES/gnome-vfs-extras.mo
+share/locale/en_GB/LC_MESSAGES/gnome-vfs-extras.mo
+share/locale/es/LC_MESSAGES/gnome-vfs-extras.mo
+share/locale/fr/LC_MESSAGES/gnome-vfs-extras.mo
+share/locale/hi/LC_MESSAGES/gnome-vfs-extras.mo
+share/locale/hu/LC_MESSAGES/gnome-vfs-extras.mo
+share/locale/ko/LC_MESSAGES/gnome-vfs-extras.mo
+share/locale/lv/LC_MESSAGES/gnome-vfs-extras.mo
+share/locale/ms/LC_MESSAGES/gnome-vfs-extras.mo
+share/locale/no/LC_MESSAGES/gnome-vfs-extras.mo
+share/locale/pt_BR/LC_MESSAGES/gnome-vfs-extras.mo
+share/locale/sk/LC_MESSAGES/gnome-vfs-extras.mo
+share/locale/sv/LC_MESSAGES/gnome-vfs-extras.mo
+share/locale/vi/LC_MESSAGES/gnome-vfs-extras.mo
+share/locale/wa/LC_MESSAGES/gnome-vfs-extras.mo
+share/locale/zh_TW/LC_MESSAGES/gnome-vfs-extras.mo