aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-06-10 17:28:43 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-06-10 17:28:43 +0000
commitf42d0fd6cd48f17e11d6c2d52fe479e8d12eeee4 (patch)
tree71f86c1e84dc58f53d7f111b4c9394d3287326da /devel
parentb444684131e4889e57be98bd53988ec2bd7e6d6c (diff)
downloadports-f42d0fd6cd48f17e11d6c2d52fe479e8d12eeee4.tar.gz
ports-f42d0fd6cd48f17e11d6c2d52fe479e8d12eeee4.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/lasi/Makefile25
-rw-r--r--devel/lasi/distinfo3
-rw-r--r--devel/lasi/files/patch-Makefile.in11
-rw-r--r--devel/lasi/pkg-descr14
-rw-r--r--devel/lasi/pkg-plist6
6 files changed, 60 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index ffea3f936b4c..415bb36c612f 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -443,6 +443,7 @@
SUBDIR += kscope
SUBDIR += kxl
SUBDIR += kyra
+ SUBDIR += lasi
SUBDIR += lbpp
SUBDIR += leaktracer
SUBDIR += lemon
diff --git a/devel/lasi/Makefile b/devel/lasi/Makefile
new file mode 100644
index 000000000000..0ae1a02e9db8
--- /dev/null
+++ b/devel/lasi/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: lasi
+# Date created: June 2006
+# Whom: giffunip
+#
+# $FreeBSD$
+#
+
+PORTNAME= lasi
+PORTVERSION= 1.0.4
+CATEGORIES= devel
+MASTER_SITES= http://eyegene.ophthy.med.umich.edu/lasi/download/
+
+MAINTAINER= giffunip@asme.org
+COMMENT= C++ stream output interface for creating Postscript documents
+
+USE_GCC= 3.2+
+USE_GNOME= pango pkgconfig
+USE_AUTOTOOLS= libltdl:15
+GNU_CONFIGURE= yes
+PKG_CONFIG_PATH= ${PREFIX}/libdata/pkgconfig
+CONFIGURE_ENV+= PKG_CONFIG_PATH=${PKG_CONFIG_PATH}
+
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.mk>
diff --git a/devel/lasi/distinfo b/devel/lasi/distinfo
new file mode 100644
index 000000000000..899573163a2e
--- /dev/null
+++ b/devel/lasi/distinfo
@@ -0,0 +1,3 @@
+MD5 (lasi-1.0.4.tar.gz) = ed6016995aaa5649fde2bbf7b1224be8
+SHA256 (lasi-1.0.4.tar.gz) = 7cffcdf9d639b3637614c6d24780a4ab2dcc9e8a6573f67d768a6521c3f4dd35
+SIZE (lasi-1.0.4.tar.gz) = 481554
diff --git a/devel/lasi/files/patch-Makefile.in b/devel/lasi/files/patch-Makefile.in
new file mode 100644
index 000000000000..0e761ab02c8b
--- /dev/null
+++ b/devel/lasi/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Thu Jun 8 00:04:11 2006
++++ Makefile.in Thu Jun 8 00:05:26 2006
+@@ -140,7 +140,7 @@
+ SUBDIRS = src
+ include_HEADERS = include/LASi.h
+
+-pkgconfigdir = $(libdir)/pkgconfig
++pkgconfigdir = ${exec_prefix}/libdata/pkgconfig
+ pkgconfig_DATA = lasi.pc
+ subdir = .
+ ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
diff --git a/devel/lasi/pkg-descr b/devel/lasi/pkg-descr
new file mode 100644
index 000000000000..96257bd6b0e9
--- /dev/null
+++ b/devel/lasi/pkg-descr
@@ -0,0 +1,14 @@
+LASi
+________
+libLASi is a library written by Larry Siden that provides a C++ stream
+output interface ( with operator << ) for creating Postscript documents
+that can contain characters from any of the scripts and symbol blocks
+supported in Unicode and by Owen Taylor's Pango layout engine. The
+library accomodates right-to-left scripts such as Arabic and Hebrew as
+easily as left-to-right scripts. Indic and Indic-derived Complex Text
+Layout (CTL) scripts, such as Devanagari, Thai, Lao, and Tibetan are
+supported to the extent provided by Pango and by the OpenType fonts
+installed on your system. All of this is provided without need for any
+special configuration or layout calculation on the programmer's part.
+
+WWW: http://eyegene.ophthy.med.umich.edu/lasi/
diff --git a/devel/lasi/pkg-plist b/devel/lasi/pkg-plist
new file mode 100644
index 000000000000..e1b8445238fb
--- /dev/null
+++ b/devel/lasi/pkg-plist
@@ -0,0 +1,6 @@
+include/LASi.h
+lib/libLASi.a
+lib/libLASi.la
+lib/libLASi.so
+lib/libLASi.so.0
+libdata/pkgconfig/lasi.pc