aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2006-11-05 03:45:05 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2006-11-05 03:45:05 +0000
commit1a88278734c45ada8e18fca7c815b43d05826c3a (patch)
tree2375ba65fd99b806539d4ee9e1b29f8f3fd29c34 /devel
parentddda5ed61be63fae22938ebe686c49beb6fa76a5 (diff)
downloadports-1a88278734c45ada8e18fca7c815b43d05826c3a.tar.gz
ports-1a88278734c45ada8e18fca7c815b43d05826c3a.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/ORBit/Makefile2
-rw-r--r--devel/ORBit2/Makefile2
-rw-r--r--devel/bonobo-conf/Makefile2
-rw-r--r--devel/g-wrap/Makefile2
-rw-r--r--devel/gamin/Makefile2
-rw-r--r--devel/glib12/Makefile2
-rw-r--r--devel/gnome-build/Makefile2
-rw-r--r--devel/gnome-vfs1/Makefile2
-rw-r--r--devel/goffice/Makefile2
-rw-r--r--devel/goffice04/Makefile2
-rw-r--r--devel/goffice1/Makefile2
-rw-r--r--devel/gtkmozedit/Makefile2
-rw-r--r--devel/libIDL/Makefile3
-rw-r--r--devel/libassetml/Makefile2
-rw-r--r--devel/libgconf-java/Makefile2
-rw-r--r--devel/libglade-java/Makefile2
-rw-r--r--devel/libglade/Makefile2
-rw-r--r--devel/libole2/Makefile2
-rw-r--r--devel/libsigc++/Makefile2
-rw-r--r--devel/libsigc++12/Makefile2
-rw-r--r--devel/libsigc++20/Makefile2
-rw-r--r--devel/libsoup/Makefile2
-rw-r--r--devel/libsoup22/Makefile2
-rw-r--r--devel/orbitcpp/Makefile2
-rw-r--r--devel/present/Makefile2
-rw-r--r--devel/soup/Makefile2
26 files changed, 27 insertions, 26 deletions
diff --git a/devel/ORBit/Makefile b/devel/ORBit/Makefile
index bb24353cc0ac..1efd7d5b15bc 100644
--- a/devel/ORBit/Makefile
+++ b/devel/ORBit/Makefile
@@ -20,7 +20,7 @@ USE_BZIP2= yes
USE_GETTEXT= yes
USE_GMAKE= yes
USE_GNOME= glib12 gnometarget
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-indent
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
diff --git a/devel/ORBit2/Makefile b/devel/ORBit2/Makefile
index 0a5241844582..58421e45cf82 100644
--- a/devel/ORBit2/Makefile
+++ b/devel/ORBit2/Makefile
@@ -22,7 +22,7 @@ USE_BZIP2= yes
.if !defined(REFERENCE_PORT)
USE_GMAKE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
USE_AUTOTOOLS= libtool:15
USE_GNOME= gnomehack libidl ltverhack referencehack
CONFIGURE_ARGS= --disable-indent \
diff --git a/devel/bonobo-conf/Makefile b/devel/bonobo-conf/Makefile
index c883ddf68439..384b9355ee8d 100644
--- a/devel/bonobo-conf/Makefile
+++ b/devel/bonobo-conf/Makefile
@@ -21,7 +21,7 @@ USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack bonobo gconf
USE_GETTEXT= yes
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
diff --git a/devel/g-wrap/Makefile b/devel/g-wrap/Makefile
index 51065197e73f..aadadd32780d 100644
--- a/devel/g-wrap/Makefile
+++ b/devel/g-wrap/Makefile
@@ -27,7 +27,7 @@ INFO= g-wrap
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_GNOME= gtk12
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
CONFIGURE_ENV+= GW_GLIB_CONFIG="${GLIB_CONFIG}"
MAKE_ENV+= GUILE_LOAD_PATH=${WRKSRC}
diff --git a/devel/gamin/Makefile b/devel/gamin/Makefile
index 834a092fb676..55f528e2c663 100644
--- a/devel/gamin/Makefile
+++ b/devel/gamin/Makefile
@@ -16,7 +16,7 @@ COMMENT?= A file and directory monitoring system
USE_GMAKE= yes
USE_GNOME?= gnomehack glib20
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
CONFIGURE_ARGS?=--with-html-dir=${PREFIX}/share/doc \
--without-python
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
diff --git a/devel/glib12/Makefile b/devel/glib12/Makefile
index 2dcb661ed9c9..0239396c7baf 100644
--- a/devel/glib12/Makefile
+++ b/devel/glib12/Makefile
@@ -17,7 +17,7 @@ COMMENT= Some useful routines of C programming (previous stable version)
USE_GNOME= pkgconfig
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
CONFIGURE_ARGS= --includedir=${PREFIX}/include/glib12
CONFIGURE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
diff --git a/devel/gnome-build/Makefile b/devel/gnome-build/Makefile
index 4fe238851b54..3be569aa4118 100644
--- a/devel/gnome-build/Makefile
+++ b/devel/gnome-build/Makefile
@@ -22,7 +22,7 @@ USE_X_PREFIX= yes
USE_GNOME= gnomeprefix intlhack gnomehack libgnomeui gnomevfs2
USE_GETTEXT= yes
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
USE_PERL5_RUN= yes
CONFIGURE_ARGS= --enable-compile-warnings=no
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
diff --git a/devel/gnome-vfs1/Makefile b/devel/gnome-vfs1/Makefile
index 41d4220550be..f775cdde5a0b 100644
--- a/devel/gnome-vfs1/Makefile
+++ b/devel/gnome-vfs1/Makefile
@@ -25,7 +25,7 @@ USE_GNOME= gnomehack gnomeprefix glib12 libxml gtk12 orbit gconf \
gnomemimedata gnomelibs
USE_GETTEXT= yes
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS} -I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib" \
BSD_PTHREAD_LIBS=${PTHREAD_LIBS}
diff --git a/devel/goffice/Makefile b/devel/goffice/Makefile
index eb4557ebb679..5ef8e6e870c1 100644
--- a/devel/goffice/Makefile
+++ b/devel/goffice/Makefile
@@ -22,7 +22,7 @@ USE_GNOME= gnomeprefix gnomehack intlhack libgnomeprint libglade2 \
libgsf_gnome ltverhack
USE_GETTEXT= yes
USE_AUTOTOOLS= libtool:15
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/devel/goffice04/Makefile b/devel/goffice04/Makefile
index eb4557ebb679..5ef8e6e870c1 100644
--- a/devel/goffice04/Makefile
+++ b/devel/goffice04/Makefile
@@ -22,7 +22,7 @@ USE_GNOME= gnomeprefix gnomehack intlhack libgnomeprint libglade2 \
libgsf_gnome ltverhack
USE_GETTEXT= yes
USE_AUTOTOOLS= libtool:15
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/devel/goffice1/Makefile b/devel/goffice1/Makefile
index eb4557ebb679..5ef8e6e870c1 100644
--- a/devel/goffice1/Makefile
+++ b/devel/goffice1/Makefile
@@ -22,7 +22,7 @@ USE_GNOME= gnomeprefix gnomehack intlhack libgnomeprint libglade2 \
libgsf_gnome ltverhack
USE_GETTEXT= yes
USE_AUTOTOOLS= libtool:15
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/devel/gtkmozedit/Makefile b/devel/gtkmozedit/Makefile
index 6c8adaa4f12f..091da42ff4d5 100644
--- a/devel/gtkmozedit/Makefile
+++ b/devel/gtkmozedit/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= Text editor widget based on Mozilla's editing functionality
USE_BZIP2= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
GNU_CONFIGURE= yes
USE_GNOME= gnomehack
USE_GECKO= mozilla
diff --git a/devel/libIDL/Makefile b/devel/libIDL/Makefile
index 8f193dda1cf9..53e76366a0ae 100644
--- a/devel/libIDL/Makefile
+++ b/devel/libIDL/Makefile
@@ -4,6 +4,7 @@
#
# $FreeBSD$
# $MCom: ports/devel/libIDL/Makefile,v 1.5 2006/07/24 14:11:11 ahze Exp $
+#
PORTNAME= libIDL
PORTVERSION= 0.8.7
@@ -19,7 +20,7 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_BISON= yes
USE_GNOME= gnomehack glib20
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
diff --git a/devel/libassetml/Makefile b/devel/libassetml/Makefile
index 8eb4aaef5121..17d47e265176 100644
--- a/devel/libassetml/Makefile
+++ b/devel/libassetml/Makefile
@@ -23,7 +23,7 @@ USE_GMAKE= yes
USE_GNOME= gnomehack lthack gnomeprefix gnometarget glib20 libxml2 pkgconfig
USE_GETTEXT= yes
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
CONFIGURE_ENV= CFLAGS=-I${LOCALBASE}/include \
LDFLAGS=-L${LOCALBASE}/lib
diff --git a/devel/libgconf-java/Makefile b/devel/libgconf-java/Makefile
index df87e56561d7..1a9880120a37 100644
--- a/devel/libgconf-java/Makefile
+++ b/devel/libgconf-java/Makefile
@@ -22,7 +22,7 @@ RUN_DEPENDS= ${JAVALIBDIR}/gtk${GTK_API_VERSION}.jar:${PORTSDIR}/x11-toolkits/li
USE_BZIP2= yes
USE_XLIB= yes
USE_GMAKE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
GNU_CONFIGURE= yes
USE_JAVA= yes
JAVA_VERSION= 1.2+
diff --git a/devel/libglade-java/Makefile b/devel/libglade-java/Makefile
index d8f3b5f9479a..d0f2b664d67c 100644
--- a/devel/libglade-java/Makefile
+++ b/devel/libglade-java/Makefile
@@ -24,7 +24,7 @@ RUN_DEPENDS= ${JAVALIBDIR}/gtk${GTK_API_VERSION}.jar:${PORTSDIR}/x11-toolkits/li
USE_BZIP2= yes
USE_XLIB= yes
USE_GMAKE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
GNU_CONFIGURE= yes
USE_JAVA= yes
USE_GCC= 3.4+
diff --git a/devel/libglade/Makefile b/devel/libglade/Makefile
index b2e6d00b3e58..8677c68060ab 100644
--- a/devel/libglade/Makefile
+++ b/devel/libglade/Makefile
@@ -20,7 +20,7 @@ USE_PERL5= yes
USE_GMAKE= yes
USE_GNOME= gnomehack gnomeprefix gnomehier gnomedb
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
CONFIGURE_ARGS= --enable-bonobo --enable-gnomedb
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
diff --git a/devel/libole2/Makefile b/devel/libole2/Makefile
index 54cb7ddabd68..e3d4570ad502 100644
--- a/devel/libole2/Makefile
+++ b/devel/libole2/Makefile
@@ -18,7 +18,7 @@ COMMENT= Support library for OLE functions (MS-Excel) for gnumeric
USE_GMAKE= yes
USE_GNOME= glib12
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
.include <bsd.port.mk>
diff --git a/devel/libsigc++/Makefile b/devel/libsigc++/Makefile
index 63dd6833cc15..11c4511ede45 100644
--- a/devel/libsigc++/Makefile
+++ b/devel/libsigc++/Makefile
@@ -19,7 +19,7 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= Callback Framework for C++
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
USE_GNOME= gnomehack
pre-configure:
diff --git a/devel/libsigc++12/Makefile b/devel/libsigc++12/Makefile
index fb98e9f775d7..891ecb474d50 100644
--- a/devel/libsigc++12/Makefile
+++ b/devel/libsigc++12/Makefile
@@ -23,7 +23,7 @@ BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
USE_GMAKE= yes
LATEST_LINK= libsigc++12
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
USE_GNOME= gnomehack gnometarget pkgconfig
GNU_CONFIGURE= yes
diff --git a/devel/libsigc++20/Makefile b/devel/libsigc++20/Makefile
index f0ae85747e04..430ad9174dff 100644
--- a/devel/libsigc++20/Makefile
+++ b/devel/libsigc++20/Makefile
@@ -21,7 +21,7 @@ USE_BZIP2= yes
USE_GCC= 3.4
USE_GMAKE= yes
LATEST_LINK= libsigc++20
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
USE_GNOME= gnomehack gnometarget pkgconfig
GNU_CONFIGURE= yes
diff --git a/devel/libsoup/Makefile b/devel/libsoup/Makefile
index 79fd92173bd4..68385ac08e15 100644
--- a/devel/libsoup/Makefile
+++ b/devel/libsoup/Makefile
@@ -24,7 +24,7 @@ USE_BZIP2= yes
LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
USE_GNOME= gnomehack glib20 libxml2 ltverhack referencehack
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
USE_AUTOTOOLS= libtool:15
USE_GMAKE= yes
CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc \
diff --git a/devel/libsoup22/Makefile b/devel/libsoup22/Makefile
index 79fd92173bd4..68385ac08e15 100644
--- a/devel/libsoup22/Makefile
+++ b/devel/libsoup22/Makefile
@@ -24,7 +24,7 @@ USE_BZIP2= yes
LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
USE_GNOME= gnomehack glib20 libxml2 ltverhack referencehack
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
USE_AUTOTOOLS= libtool:15
USE_GMAKE= yes
CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc \
diff --git a/devel/orbitcpp/Makefile b/devel/orbitcpp/Makefile
index 707cdf9466ba..aa100cabae3b 100644
--- a/devel/orbitcpp/Makefile
+++ b/devel/orbitcpp/Makefile
@@ -18,7 +18,7 @@ COMMENT= C++ bindings for ORBit, a CORBA 2.2-compliant ORB
USE_BZIP2= yes
USE_GNOME= gnomehack lthack orbit2
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
post-patch:
@${REINPLACE_CMD} -e 's|^\(SUBDIRS =.*\)test\(.*\)|\1\2|' ${WRKSRC}/Makefile.in
diff --git a/devel/present/Makefile b/devel/present/Makefile
index 9b967791d81f..62aceead62ee 100644
--- a/devel/present/Makefile
+++ b/devel/present/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= goffice-1.2:${PORTSDIR}/devel/goffice
USE_BZIP2= yes
USE_AUTOTOOLS= libtool:15
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
USE_GNOME= gnomehack intlhack gnometarget ltverhack
diff --git a/devel/soup/Makefile b/devel/soup/Makefile
index f74418ddbd4b..46fc066c8124 100644
--- a/devel/soup/Makefile
+++ b/devel/soup/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
USE_BZIP2= yes
USE_GNOME= gnomehack glib12 libxml
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc --disable-gtk-doc
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \