aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2002-10-30 00:36:47 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2002-10-30 00:36:47 +0000
commit35ee867cbffcc1180a66a187c3103d873dc57258 (patch)
tree8763f5cb8e85f34c956a8541e547dbb16a3aa3de /devel
parenta9dd0a728ba75a785a028aa1760880bc5e0a03d8 (diff)
downloadports-35ee867cbffcc1180a66a187c3103d873dc57258.tar.gz
ports-35ee867cbffcc1180a66a187c3103d873dc57258.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/bonobo-activation/Makefile2
-rw-r--r--devel/bonobo-activation/distinfo2
-rw-r--r--devel/bonobo-activation/files/patch-bonobo-activation::bonobo-activation-fork-server.c12
-rw-r--r--devel/bonobo-activation/files/patch-server::Makefile.in22
-rw-r--r--devel/bonobo-activation/pkg-plist2
5 files changed, 21 insertions, 19 deletions
diff --git a/devel/bonobo-activation/Makefile b/devel/bonobo-activation/Makefile
index 6268f00cdf66..c53cccb0f8e6 100644
--- a/devel/bonobo-activation/Makefile
+++ b/devel/bonobo-activation/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= bonobo-activation
-PORTVERSION= 1.0.3
+PORTVERSION= 1.0.4
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/1.0
diff --git a/devel/bonobo-activation/distinfo b/devel/bonobo-activation/distinfo
index 6e72ac85a55e..12555f159da1 100644
--- a/devel/bonobo-activation/distinfo
+++ b/devel/bonobo-activation/distinfo
@@ -1 +1 @@
-MD5 (gnome2/bonobo-activation-1.0.3.tar.bz2) = 79b65c0e35fa22eb2b73346b7490f25f
+MD5 (gnome2/bonobo-activation-1.0.4.tar.bz2) = 2b68d7a94d195cbcca15fcb63e55fb6a
diff --git a/devel/bonobo-activation/files/patch-bonobo-activation::bonobo-activation-fork-server.c b/devel/bonobo-activation/files/patch-bonobo-activation::bonobo-activation-fork-server.c
index 103422530c6f..68b67d2f749a 100644
--- a/devel/bonobo-activation/files/patch-bonobo-activation::bonobo-activation-fork-server.c
+++ b/devel/bonobo-activation/files/patch-bonobo-activation::bonobo-activation-fork-server.c
@@ -1,11 +1,11 @@
---- bonobo-activation/bonobo-activation-fork-server.c.orig Wed Jul 24 16:46:27 2002
-+++ bonobo-activation/bonobo-activation-fork-server.c Wed Jul 24 16:47:00 2002
-@@ -349,6 +349,8 @@
+--- bonobo-activation/bonobo-activation-fork-server.c.orig Tue Oct 29 05:51:18 2002
++++ bonobo-activation/bonobo-activation-fork-server.c Tue Oct 29 19:24:23 2002
+@@ -396,6 +396,8 @@
} else if ((childpid = fork ())) {
_exit (0); /* de-zombifier process, just exit */
} else {
+ sigprocmask (SIG_SETMASK, &omask, NULL);
+
- if (display != NULL) {
- bonobo_activation_setenv ("DISPLAY", display);
- }
+ if (display)
+ bonobo_activation_setenv ("DISPLAY", display);
+ if (session_manager)
diff --git a/devel/bonobo-activation/files/patch-server::Makefile.in b/devel/bonobo-activation/files/patch-server::Makefile.in
index 49683926cdff..5d4a4a652d39 100644
--- a/devel/bonobo-activation/files/patch-server::Makefile.in
+++ b/devel/bonobo-activation/files/patch-server::Makefile.in
@@ -1,11 +1,11 @@
---- server/Makefile.in.orig Wed Jul 24 16:56:33 2002
-+++ server/Makefile.in Wed Jul 24 16:56:52 2002
-@@ -147,7 +147,7 @@
- bin_PROGRAMS = activation-client
- libexec_PROGRAMS = bonobo-activation-server
-
--INCLUDES = -I$(top_srcdir) -I$(top_builddir) -I$(top_builddir)/bonobo-activation -I$(top_srcdir)/bonobo-activation -DSERVERINFODIR=\"$(prefix)/libdata/bonobo/servers\" -DSERVER_LOCALEDIR=\""${prefix}/${DATADIRNAME}/locale"\" $(SERVER_CFLAGS) -DSERVER_CONFDIR=\"$(sysconfdir)\" -DG_DISABLE_DEPRECATED $(NULL)
-+INCLUDES = -I$(top_srcdir) -I$(top_builddir) -I$(top_builddir)/bonobo-activation -I$(top_srcdir)/bonobo-activation -DSERVERINFODIR=\"$(prefix)/libdata/bonobo/servers:${X11BASE}/libdata/bonobo/servers:${LOCALBASE}/libdata/bonobo/servers\" -DSERVER_LOCALEDIR=\""${prefix}/${DATADIRNAME}/locale"\" $(SERVER_CFLAGS) -DSERVER_CONFDIR=\"$(sysconfdir)\" -DG_DISABLE_DEPRECATED $(NULL)
-
-
- bonobo_activation_server_SOURCES = activation-server-corba-extensions.c activation-server-corba-extensions.h activation-context-query.h activation-context-query.c activation-context-query-lexer.c activation-context-query-parser.c activation-context-query-parser.h activation-context-corba.c object-directory-corba.c object-directory-load.c object-directory-activate.c object-directory-config-file.c object-directory-config-file.h activation-server-main.c server.h
+--- server/Makefile.in.orig Tue Oct 29 19:25:02 2002
++++ server/Makefile.in Tue Oct 29 19:27:21 2002
+@@ -154,7 +154,7 @@
+ -I$(top_builddir) \
+ -I$(top_builddir)/bonobo-activation \
+ -I$(top_srcdir)/bonobo-activation \
+- -DSERVERINFODIR=\"$(prefix)/libdata/bonobo/servers\" \
++ -DSERVERINFODIR=\"$(prefix)/libdata/bonobo/servers:${X11BASE}/libdata/bonobo/servers:${LOCALBASE}/libdata/bonobo/servers\" \
+ -DSERVER_LOCALEDIR=\""${prefix}/${DATADIRNAME}/locale"\" \
+ $(SERVER_CFLAGS) \
+ -DSERVER_CONFDIR=\"$(sysconfdir)\" \
diff --git a/devel/bonobo-activation/pkg-plist b/devel/bonobo-activation/pkg-plist
index b27389f39a2b..ba64d17efe36 100644
--- a/devel/bonobo-activation/pkg-plist
+++ b/devel/bonobo-activation/pkg-plist
@@ -67,6 +67,7 @@ share/locale/az/LC_MESSAGES/bonobo-activation.mo
share/locale/ar/LC_MESSAGES/bonobo-activation.mo
share/locale/bg/LC_MESSAGES/bonobo-activation.mo
share/locale/ca/LC_MESSAGES/bonobo-activation.mo
+share/locale/cs/LC_MESSAGES/bonobo-activation.mo
share/locale/da/LC_MESSAGES/bonobo-activation.mo
share/locale/de/LC_MESSAGES/bonobo-activation.mo
share/locale/el/LC_MESSAGES/bonobo-activation.mo
@@ -92,6 +93,7 @@ share/locale/ro/LC_MESSAGES/bonobo-activation.mo
share/locale/ru/LC_MESSAGES/bonobo-activation.mo
share/locale/sk/LC_MESSAGES/bonobo-activation.mo
share/locale/sl/LC_MESSAGES/bonobo-activation.mo
+share/locale/sq/LC_MESSAGES/bonobo-activation.mo
share/locale/sv/LC_MESSAGES/bonobo-activation.mo
share/locale/ta/LC_MESSAGES/bonobo-activation.mo
share/locale/tr/LC_MESSAGES/bonobo-activation.mo