aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-06-12 09:17:03 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-06-12 09:17:03 +0000
commit36aec2ee4d4789c8cc6ad940264e1a101d8a7977 (patch)
treefadc33ad2f29c6931b7a10a46ca3d20a561a3331 /devel
parent59642d1219c0fc9ff42830b664320824c78e3a3f (diff)
downloadports-36aec2ee4d4789c8cc6ad940264e1a101d8a7977.tar.gz
ports-36aec2ee4d4789c8cc6ad940264e1a101d8a7977.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/boehm-gc-redirect/Makefile4
-rw-r--r--devel/boehm-gc-threaded/Makefile8
-rw-r--r--devel/boehm-gc/Makefile4
-rw-r--r--devel/dprog/Makefile12
-rw-r--r--devel/elfio/Makefile12
-rw-r--r--devel/gecode/Makefile5
-rw-r--r--devel/kdesdk3/Makefile9
-rw-r--r--devel/libcfg/Makefile15
-rw-r--r--devel/libelf/Makefile14
-rw-r--r--devel/libstroke/Makefile9
-rw-r--r--devel/libusb/Makefile9
-rw-r--r--devel/linux-js/Makefile17
-rw-r--r--devel/mico/Makefile28
-rw-r--r--devel/ml-doc/Makefile9
-rw-r--r--devel/pdcurses-the/Makefile18
-rw-r--r--devel/pdcurses/Makefile18
16 files changed, 100 insertions, 91 deletions
diff --git a/devel/boehm-gc-redirect/Makefile b/devel/boehm-gc-redirect/Makefile
index 2c71c67841e7..0ea869b0d67b 100644
--- a/devel/boehm-gc-redirect/Makefile
+++ b/devel/boehm-gc-redirect/Makefile
@@ -27,7 +27,7 @@ INSTLIBS= cord gc gccpp
GC_VARIANT= redirect
SOVER= 1
-OPTIONS= FULLDEBUG "Debugging support (see documentation)" off
+OPTIONS_DEFINE= DEBUG
PLIST_FILES= ${INSTLIBS:S,^,lib/lib,g:S,$,-${GC_VARIANT}.so.${SOVER},g} \
${INSTLIBS:S,^,lib/lib,g:S,$,-${GC_VARIANT}.so,g}
@@ -38,7 +38,7 @@ PLIST_FILES= ${INSTLIBS:S,^,lib/lib,g:S,$,-${GC_VARIANT}.so.${SOVER},g} \
BROKEN= Does not compile on ia64
.endif
-.if defined(WITH_FULLDEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
CONFIGURE_ARGS+= --enable-gc-debug
PKGNAMESUFFIX:= ${PKGNAMESUFFIX}+fulldebug
.endif
diff --git a/devel/boehm-gc-threaded/Makefile b/devel/boehm-gc-threaded/Makefile
index 14514f4f7cfe..d215c9c7870c 100644
--- a/devel/boehm-gc-threaded/Makefile
+++ b/devel/boehm-gc-threaded/Makefile
@@ -28,8 +28,8 @@ INSTLIBS= cord gc gccpp
GC_VARIANT= threaded
SOVER= 1
-OPTIONS= PARALLEL_MARK "Parallel-thread marking (faster for SMP)" off \
- FULLDEBUG "Debugging support (see documentation)" off
+OPTIONS_DEFINE= PARALLEL_MARK DEBUG
+PARALLEL_MARK_DESC= Parallel-thread marking (faster for SMP)
PLIST_FILES= ${INSTLIBS:S,^,lib/lib,g:S,$,-${GC_VARIANT}.so.${SOVER},g} \
${INSTLIBS:S,^,lib/lib,g:S,$,-${GC_VARIANT}.so,g} \
@@ -41,11 +41,11 @@ PLIST_FILES= ${INSTLIBS:S,^,lib/lib,g:S,$,-${GC_VARIANT}.so.${SOVER},g} \
BROKEN= Does not compile on ia64
.endif
-.if defined(WITH_PARALLEL_MARK)
+.if ${PORT_OPTIONS:MPARALLEL_MARK}
CONFIGURE_ARGS+= --enable-parallel-mark
.endif
-.if defined(WITH_FULLDEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
CONFIGURE_ARGS+= --enable-gc-debug
PKGNAMESUFFIX:= ${PKGNAMESUFFIX}+fulldebug
.endif
diff --git a/devel/boehm-gc/Makefile b/devel/boehm-gc/Makefile
index 931200dc3d54..8247d8e2ba2e 100644
--- a/devel/boehm-gc/Makefile
+++ b/devel/boehm-gc/Makefile
@@ -20,11 +20,11 @@ USE_GNOME= gnomehack
USE_LDCONFIG= yes
CONFIGURE_ARGS= --enable-cplusplus --disable-static --disable-threads
MAKE_JOBS_UNSAFE= yes
-OPTIONS= FULLDEBUG "Debugging support (see documentation)" off
+OPTIONS_DEFINE= DEBUG
.include <bsd.port.pre.mk>
-.if defined(WITH_FULLDEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
CONFIGURE_ARGS+= --enable-gc-debug
PKGNAMESUFFIX:= ${PKGNAMESUFFIX}+fulldebug
.endif
diff --git a/devel/dprog/Makefile b/devel/dprog/Makefile
index 26c5f311fc3d..10f2f5154454 100644
--- a/devel/dprog/Makefile
+++ b/devel/dprog/Makefile
@@ -21,20 +21,22 @@ GNU_CONFIGURE= yes
CPPFLAGS+= ${CXXFLAGS} -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-OPTIONS= EMACS "Install emacs syntax files" on
+OPTIONS_DEFINE= EMACS
+OPTIONS_DEFAULT= EMACS
+EMACS_DESC= Install emacs syntax files
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_EMACS)
+.if ${PORT_OPTIONS:MEMACS}
PLIST_SUB+= EMACS=""
.else
PLIST_SUB+= EMACS="@comment "
.endif
post-install:
-.if !defined(WITHOUT_EMACS)
+.if ${PORT_OPTIONS:MEMACS}
@${MKDIR} ${DATADIR}
${INSTALL_DATA} ${WRKSRC}/elisp/*.el ${DATADIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/elfio/Makefile b/devel/elfio/Makefile
index d432dd7df891..b368e730a738 100644
--- a/devel/elfio/Makefile
+++ b/devel/elfio/Makefile
@@ -24,13 +24,13 @@ USE_AUTOTOOLS= aclocal automake autoconf libtool
AUTOMAKE_ARGS= -c -a
ACLOCAL_ARGS= --acdir=${ACLOCAL_DIR} -I ${LOCALBASE}/share/aclocal
-OPTIONS= EXAMPLES "Install sample programms" on
+OPTIONE_DEFINE= EXAMPLES DOCS
PORTDOCS= *
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_EXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
PLIST_SUB+= EXAMPLES=""
.else
PLIST_SUB+= EXAMPLES="@comment "
@@ -45,7 +45,7 @@ pre-configure:
${LIBTOOLIZE} --force --copy --automake)
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for file in AUTHORS ChangeLog README
${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
@@ -54,10 +54,10 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/doc/${f} ${DOCSDIR}
.endfor
.endif
-.if !defined(WITHOUT_EXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${EXAMPLESDIR}
@${FIND} ${WRKSRC}/Examples/ -name "*.cpp" -exec ${INSTALL_DATA} {} \
${EXAMPLESDIR}/ \;
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/gecode/Makefile b/devel/gecode/Makefile
index 8ba2cbad8f68..ea866fe2f8c9 100644
--- a/devel/gecode/Makefile
+++ b/devel/gecode/Makefile
@@ -15,7 +15,8 @@ COMMENT= Generic Constraint Development Environment
LICENSE= MIT
-OPTIONS= GIST "Interactive Search Tool (requires Qt)" Off
+OPTIONS_DEFINE= GIST
+GIST_DESC= Interactive Search Tool (requires Qt)
USE_PERL5_BUILD=yes
USE_BISON= build
@@ -38,7 +39,7 @@ MAKE_JOBS_UNSAFE=yes
.include <bsd.port.options.mk>
-.if defined(WITH_GIST)
+.if ${PORT_OPTIONS:MGIST}
USE_QT4= corelib gui moc_build qmake_build
CONFIGURE_ARGS+=--enable-gist --enable-qt
PLIST_SUB+= GIST=""
diff --git a/devel/kdesdk3/Makefile b/devel/kdesdk3/Makefile
index 4f792a9c787b..33fbc5c87bab 100644
--- a/devel/kdesdk3/Makefile
+++ b/devel/kdesdk3/Makefile
@@ -41,12 +41,13 @@ CONFIGURE_ARGS+=--mandir=${MANPREFIX}/man \
MAN1= cervisia.1 cvsblame.1 cvscheck.1 cvsversion.1 includemocs.1 kde-build.1 kdesvn-build.1 noncvslist.1
-OPTIONS= VALGRIND "Install devel/valgrind" off
+OPTIONS_DEFINE= VALGRIND
+VALGRIND_DESC= Install devel/valgrind
.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_VALGRIND)
+.if ${PORT_OPTIONS:MVALGRIND}
RUN_DEPENDS+= valgrind:${PORTSDIR}/devel/valgrind
.endif
@@ -55,4 +56,4 @@ post-patch:
@${REINPLACE_CMD} -e 's|<\(fnmatch.h\)>|"/usr/include/\1"|' \
${WRKSRC}/cervisia/stringmatcher.cpp
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/libcfg/Makefile b/devel/libcfg/Makefile
index df84df804838..51954d63e2a7 100644
--- a/devel/libcfg/Makefile
+++ b/devel/libcfg/Makefile
@@ -34,12 +34,11 @@ INSTALL_TARGET+= install-man
PORTDOCS= *
-OPTIONS= EXAMPLES "Install examples" off \
- HTMLDOCS "Install html documentation" off
+OPTIONS_DEFINE= EXAMPLES DOCS
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_EXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
PLIST_SUB+= EXAMPLES=""
.else
PLIST_SUB+= EXAMPLES="@comment "
@@ -50,21 +49,19 @@ CFLAGS+= -fPIC
.endif
post-install:
-.if defined(WITH_EXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${EXAMPLESDIR}
@${INSTALL_DATA} ${WRKSRC}/doc/examples/example.* ${EXAMPLESDIR}
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for FILE in AUTHORS README TODO
@${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
.endfor
-.if defined(WITH_HTMLDOCS)
@${MKDIR} ${DOCSDIR}/html
@for FILE in ${WRKSRC}/doc/html/*; do \
${INSTALL_DATA} $${FILE} ${DOCSDIR}/html; \
done
.endif
-.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/libelf/Makefile b/devel/libelf/Makefile
index faa49727670a..5d836ffbd580 100644
--- a/devel/libelf/Makefile
+++ b/devel/libelf/Makefile
@@ -16,9 +16,11 @@ MASTER_SITE_SUBDIR= libs
MAINTAINER= ports@FreeBSD.org
COMMENT= A public ELF file access library similar to libelf(3) in Solaris
-OPTIONS= EXTENDED "ELF format extensions" on \
- NLS "Native Language Support" on \
- SANITY "Avoid loading invalid ELF files" on
+OPTIONS_DEFINE= EXTENDED NLS SANITY
+OPTIONS_DEFAULT= EXTENDED SANITY
+
+EXTENDED_DESC= ELF format extensions
+SANITY_DESC= Avoid loading invalid ELF files
.include <bsd.port.options.mk>
@@ -28,7 +30,7 @@ USE_LDCONFIG= yes
NOMAN= defined
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lintl
CONFIGURE_ARGS+= --enable-nls
@@ -39,13 +41,13 @@ CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= GETTEXT="@comment "
.endif
-.if !defined(WITHOUT_EXTENDED)
+.if ${PORT_OPTIONS:MEXTENDED}
CONFIGURE_ARGS+= --enable-extended-format
.else
CONFIGURE_ARGS+= --disable-extended-format
.endif
-.if !defined(WITHOUT_SANITY)
+.if ${PORT_OPTIONS:MSANITY}
CONFIGURE_ARGS+= --enable-sanity-checks
.else
CONFIGURE_ARGS+= --disable-sanity-checks
diff --git a/devel/libstroke/Makefile b/devel/libstroke/Makefile
index 41e5b50aa0e9..5be06ae99f54 100644
--- a/devel/libstroke/Makefile
+++ b/devel/libstroke/Makefile
@@ -20,11 +20,12 @@ USE_AUTOTOOLS= libtool
WANT_GNOME= yes
USE_LDCONFIG= yes
-OPTIONS= GTK "Build with legacy Gtk+/GNOME stroke support" off
+OPTIONS_DEFINE= GTK1
+GTK1_DESC= Build with legacy Gtk+/GNOME stroke support
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_GTK) || ${HAVE_GNOME:Mgtk12}
+.if ${PORT_OPTIONS:MGTK1} || !empty(HAVE_GNOME:Mgtk12)
USE_GNOME+= gtk12
PLIST_SUB+= GS=""
.else
@@ -36,4 +37,4 @@ post-patch:
's|$${CONFIG_SHELL-/bin/sh} $$ac_aux_dir|$$ac_aux_dir|' \
${WRKSRC}/configure
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/libusb/Makefile b/devel/libusb/Makefile
index fbc2ff5e0a35..cbd53a833baf 100644
--- a/devel/libusb/Makefile
+++ b/devel/libusb/Makefile
@@ -14,7 +14,8 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-0.1%20%28LEGACY%29/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Library giving userland programs access to USB devices
-OPTIONS= SGML "Install developer guide from SGML" off
+OPTIONS_DEFINE= SGML
+SGML_DESC= Install developer guide from SGML
.include <bsd.port.pre.mk>
@@ -22,7 +23,7 @@ OPTIONS= SGML "Install developer guide from SGML" off
IGNORE= has been already included into base system
.endif
-.if defined(WITH_SGML)
+.if ${PORT_OPTIONS:MSGML}
BUILD_DEPENDS+= ${LOCALBASE}/share/sgml/jade/catalog:${PORTSDIR}/textproc/jade \
${LOCALBASE}/share/sgml/docbook/dsssl/modular/catalog:${PORTSDIR}/textproc/dsssl-docbook-modular \
${LOCALBASE}/share/sgml/docbook/4.2/catalog:${PORTSDIR}/textproc/docbook-420
@@ -42,9 +43,9 @@ post-patch:
@${REINPLACE_CMD} -e 's|<stdint.h>|<inttypes.h>|' ${WRKSRC}/descriptors.c
post-install:
-.if defined(WITH_SGML)
+.if ${PORT_OPTIONS:MSGML}
@${MKDIR} ${DOCSDIR}/html
@${INSTALL_DATA} ${WRKSRC}/doc/html/* ${DOCSDIR}/html
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/linux-js/Makefile b/devel/linux-js/Makefile
index 9850c63c45b8..45595e1aa9e0 100644
--- a/devel/linux-js/Makefile
+++ b/devel/linux-js/Makefile
@@ -21,9 +21,12 @@ MAN4= linux_js.4
PORTDOCS= joystick-api.txt
USE_RCORDER= jscal.sh linux_js.sh
-OPTIONS= LINUX "Linux mode support (i386/amd64 only)" on \
- JOY "PC joystick support" on \
- UHID "USB joystick support" on
+OPTIONS_DEFINE= LINUX JOY UHID DOCS
+OPTIONS_DEFAULT= LINUX JOY UHID
+
+LINUX_DESC= Linux mode support (i386/amd64 only)
+JOY_DESC= PC joystick support
+UHID_DESC= USB joystick support
MAKE_ENV= WITHOUT_DEBUG=yes
@@ -37,15 +40,15 @@ BROKEN= does not build
IGNORE= requires kernel source files
.endif
-.if defined(WITHOUT_LINUX)
+.if empty(PORT_OPTIONS:MLINUX)
MAKE_ENV+= WITHOUT_LINUX=yes
.endif
-.if defined(WITHOUT_JOY)
+.if empty(PORT_OPTIONS:MJOY)
MAKE_ENV+= WITHOUT_JOY=yes
.endif
-.if defined(WITHOUT_UHID)
+.if empty(PORT_OPTIONS:MUHID)
MAKE_ENV+= WITHOUT_UHID=yes
.endif
@@ -61,7 +64,7 @@ post-install:
.for s in 1 4
${INSTALL_MAN} ${MAN${s}:S|^|${WRKSRC}/|} ${PREFIX}/man/man${s}
.endfor
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/joystick-api.txt ${DOCSDIR}
.endif
diff --git a/devel/mico/Makefile b/devel/mico/Makefile
index de1c7dd0e578..533b1de9b787 100644
--- a/devel/mico/Makefile
+++ b/devel/mico/Makefile
@@ -25,12 +25,12 @@ USE_GMAKE= yes
USE_AUTOTOOLS= autoconf
CONFIGURE_ENV+= EGREP=`which egrep`
-OPTIONS= NOSERVICES "Without services, plain ORB" off \
- SSL "Build with SSL" on \
- X11 "Build with X11 support" off \
- QT "Build with QT support" off \
- GTK "Build with GTK support" off \
- DEBUG "Build debug version" off
+OPTIONS_DEFINE= SERVICES SSL X11 QT3 GTK1 DEBUG TCL DOCS
+OPTIONS_DEFAULT= SSL SERVICES
+SERVICES_DESC= With services, plain ORB
+QT3_DESC= Build with QT3 support
+GTK1_DESC= Build with GTK1 support
+TCL_DESC= Build with TCL support
.include <bsd.port.options.mk>
@@ -38,10 +38,10 @@ NOT_FOR_ARCHS= sparc64
CONFIGURE_ARGS= --enable-cd --disable-mini-stl --enable-threads
-.if defined(WITH_DEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
CONFIGURE_ARGS+= --enable-debug
.endif
-.if !defined(WITH_NOSERVICES)
+.if ${PORT_OPTIONS:MSERVICES}
CONFIGURE_ARGS+= --enable-ccm
.else
CONFIGURE_ARGS+= --disable-coss
@@ -50,27 +50,27 @@ MICO_SERVICE= "@comment "
CXXFLAGS+= ${CPPFLAGS} -Wno-unused
-.if defined(WITH_X11)
+.if ${PORT_OPTIONS:MX11}
USE_XORG= x11
CONFIGURE_ARGS+= --with-x
.else
CONFIGURE_ARGS+= --without-x
MICO_X11= "@comment "
.endif
-.if defined(WITH_QT)
+.if ${PORT_OPTIONS:MQT3}
USE_QT_VER= 3
CONFIGURE_ARGS+= --with-qt=${LOCALBASE}
QTCPPFLAGS+= ${CPPFLAGS}
.else
MICO_QT= "@comment "
.endif
-.if defined(WITH_GTK)
+.if ${PORT_OPTIONS:MGTK1}
USE_GNOME= gtk12
CONFIGURE_ARGS+= --with-gtk=${LOCALBASE}
.else
MICO_GTK= "@comment "
.endif
-.if defined(WITH_TCL)
+.if ${PORT_OPTIONS:MTCL}
LIB_DEPENDS= tcl83:${PORTSDIR}/lang/tcl83
CONFIGURE_ARGS+= --with-tcl
CPPFLAGS+= -I${LOCALBASE}/include/tcl8.3
@@ -78,7 +78,7 @@ CPPFLAGS+= -I${LOCALBASE}/include/tcl8.3
MICO_TCL= "@comment "
.endif
-.if defined(WITHOUT_SSL) || defined(WITH_NOSERVICES)
+.if empty(PORT_OPTIONS:MSSL) || empty(PORT_OPTIONS:MSERVICES)
MICO_SSL= "@comment "
.else
USE_OPENSSL= yes
@@ -111,7 +111,7 @@ post-install:
for i in `${GREP} ^bin/ ${TMPPLIST}`; do \
(${STRIP_CMD} ${PREFIX}/$$i || ${TRUE}) 2> /dev/null; \
done
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${GMAKE} -C ${WRKSRC} install-doc
.endif
diff --git a/devel/ml-doc/Makefile b/devel/ml-doc/Makefile
index 46b967e6677e..716033d8e120 100644
--- a/devel/ml-doc/Makefile
+++ b/devel/ml-doc/Makefile
@@ -34,11 +34,12 @@ MLINKS= ml-doc.1 extract-sig.1 ml-doc.1 extract-info.1 \
ml-doc.1 latex-gen.1 ml-doc.1 proof-latex.1 \
ml-doc.1 filter-index.1 ml-doc.1 mk-mldoc-makefile.1
-OPTIONS= LATEX "Install LaTeX if necessary (needed for pdf output)" OFF
+OPTIONS_DEFINE= LATEX
+LATEX_DESC= Install LaTeX if necessary (needed for pdf output)
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_LATEX)
+.if ${PORT_OPTIONS:MLATEX}
RUN_DEPENDS+= latex:${PORTSDIR}/print/teTeX
.endif
@@ -49,4 +50,4 @@ post-install:
@${INSTALL_MAN} ${WRKDIR}/ml-doc.1 ${MAN1PREFIX}/man/man1
@${INSTALL_MAN} ${WRKDIR}/mkdoc.1 ${MAN1PREFIX}/man/man1
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/pdcurses-the/Makefile b/devel/pdcurses-the/Makefile
index 96ac595642a7..1a617149c3b0 100644
--- a/devel/pdcurses-the/Makefile
+++ b/devel/pdcurses-the/Makefile
@@ -22,25 +22,25 @@ USE_XORG= x11 xext sm ice xt xaw
GNU_CONFIGURE= yes
MAKE_JOBS_UNSAFE= yes
-OPTIONS= DEBUG "Enable debugging support" off \
- LATIN1 "Enable support for Latin1 keys" off \
- NEXTAW "Link with NeXtaw" off \
- XAW3D "Link with Xaw3d" off
+OPTIONS_DEFINE= DEBUG LATIN1 NEXTAW XAW3D
+LATIN1_DESC= Enable support for Latin1 keys
+NEXTAW_DESC= Link with NeXtaw
+XAW3D_DESC= Link with Xaw3d
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.for opt in DEBUG LATIN1
-. if defined(WITH_${opt})
+. if ${PORT_OPTIONS:M${opt}}
CONFIGURE_ARGS+=--enable-${opt:L}
. endif
.endfor
-.if defined(WITH_NEXTAW)
+.if ${PORT_OPTIONS:MNEXTAW}
LIB_DEPENDS+= neXtaw.${XAWVER}:${PORTSDIR}/x11-toolkits/neXtaw
CONFIGURE_ARGS+=--with-nextaw
.endif
-.if defined(WITH_XAW3D)
+.if ${PORT_OPTIONS:MXAW3D}
LIB_DEPENDS+= Xaw3d.${XAWVER}:${PORTSDIR}/x11-toolkits/Xaw3d
CONFIGURE_ARGS+=--with-xaw3d
.endif
@@ -53,4 +53,4 @@ post-patch:
post-install:
@cd ${PREFIX}/lib && ${LN} -sf libXCurses.so.2 libXCurses.so
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/pdcurses/Makefile b/devel/pdcurses/Makefile
index 2db6f99239ef..7468ef83d594 100644
--- a/devel/pdcurses/Makefile
+++ b/devel/pdcurses/Makefile
@@ -21,25 +21,25 @@ USE_XORG= x11 xext sm ice xt xaw
GNU_CONFIGURE= yes
MAKE_JOBS_UNSAFE=yes
-OPTIONS= DEBUG "Enable debugging support" off \
- LATIN1 "Enable support for Latin1 keys" off \
- NEXTAW "Link with NeXtaw" off \
- XAW3D "Link with Xaw3d" off
+OPTONS_DEFINE= DEBUG LATIN1 NEXTAW XAW3D
+LATIN1_DESC= Enable support for Latin1 keys
+NEXTAW_DESC= Link with NeXtaw
+XAW3D_DESC= Link with Xaw3d
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.for opt in DEBUG LATIN1
-. if defined(WITH_${opt})
+. if ${PORT_OPTIONS:M${opt}}
CONFIGURE_ARGS+=--enable-${opt:L}
. endif
.endfor
-.if defined(WITH_NEXTAW)
+.if ${PORT_OPTIONS:MNEXTAW}
LIB_DEPENDS+= neXtaw.${XAWVER}:${PORTSDIR}/x11-toolkits/neXtaw
CONFIGURE_ARGS+=--with-nextaw
.endif
-.if defined(WITH_XAW3D)
+.if ${PORT_OPTIONS:MXAW3D}
LIB_DEPENDS+= Xaw3d.${XAWVER}:${PORTSDIR}/x11-toolkits/Xaw3d
CONFIGURE_ARGS+=--with-xaw3d
.endif
@@ -52,4 +52,4 @@ post-patch:
post-install:
@cd ${PREFIX}/lib && ${LN} -sf libXCurses.so.2 libXCurses.so
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>