aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2004-03-13 09:53:47 +0000
committerKris Kennaway <kris@FreeBSD.org>2004-03-13 09:53:47 +0000
commit4049bbf31d1bf1fd2d32b84f4bb4dbb796ce276f (patch)
tree49b83925ebf2a02b64ef0bd0726e022cc4758d2d /devel
parentb4781fbeea4a7e8cd564f734af47819f7db08477 (diff)
downloadports-4049bbf31d1bf1fd2d32b84f4bb4dbb796ce276f.tar.gz
ports-4049bbf31d1bf1fd2d32b84f4bb4dbb796ce276f.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/cppadvio/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/devel/cppadvio/Makefile b/devel/cppadvio/Makefile
index 9c452d7a9bd9..04c3feb54ae7 100644
--- a/devel/cppadvio/Makefile
+++ b/devel/cppadvio/Makefile
@@ -21,6 +21,12 @@ ALL_TARGET= lib
USE_GMAKE= yes
USE_GCC= 2.95
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "alpha" && ${OSVERSION} < 500000
+BROKEN= "Does not compile on alpha 4.x"
+.endif
+
post-patch:
@( cd ${WRKSRC}; ${MV} c++ c++.orig; \
${SED} -e 's|^ *gcc|${CXX} ${CXXFLAGS}|' c++.orig > c++; ${CHMOD} +x c++ )
@@ -45,4 +51,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/cppadvio
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>