aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2004-09-02 11:55:22 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2004-09-02 11:55:22 +0000
commit4186a585f99833818b1fe398e772784bc013a4d6 (patch)
treebe87da62f81d7332a676eca447d68556f5df5dce /devel
parent06662bc7be978e5bbff0435ae90990c7d8295a8d (diff)
downloadports-4186a585f99833818b1fe398e772784bc013a4d6.tar.gz
ports-4186a585f99833818b1fe398e772784bc013a4d6.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/pear-HTML_QuickForm_Controller/Makefile26
-rw-r--r--devel/pear-HTML_QuickForm_Controller/distinfo2
-rw-r--r--devel/pear-HTML_QuickForm_Controller/pkg-descr12
4 files changed, 41 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index dc74e78cc7e6..92eff0caccc4 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1041,6 +1041,7 @@
SUBDIR += pear-HTML_BBCodeParser
SUBDIR += pear-HTML_Common
SUBDIR += pear-HTML_QuickForm
+ SUBDIR += pear-HTML_QuickForm_Controller
SUBDIR += pear-HTML_Select
SUBDIR += pear-HTML_Select_Common
SUBDIR += pear-HTML_Table
diff --git a/devel/pear-HTML_QuickForm_Controller/Makefile b/devel/pear-HTML_QuickForm_Controller/Makefile
new file mode 100644
index 000000000000..6dfc9e30658e
--- /dev/null
+++ b/devel/pear-HTML_QuickForm_Controller/Makefile
@@ -0,0 +1,26 @@
+# Ports collection makefile for: pear-HTML_QuickForm_Controller
+# Date created: 2 September 2004
+# Whom: Dmitry Karasik (<dk@catpipe.net>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTML_QuickForm_Controller
+PORTVERSION= 1.0.2
+CATEGORIES= devel www pear
+
+MAINTAINER= dk@catpipe.net
+COMMENT= The add-on to HTML_QuickForm that allows building of multipage forms
+
+BUILD_DEPENDS= ${PEARDIR}/HTML/QuickForm.php:${PORTSDIR}/devel/pear-HTML_QuickForm
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+CATEGORY= HTML/QuickForm
+FILES= Controller.php \
+ Action.php Page.php \
+ Action/Back.php Action/Direct.php Action/Display.php \
+ Action/Jump.php Action/Next.php Action/Submit.php
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include <bsd.port.post.mk>
diff --git a/devel/pear-HTML_QuickForm_Controller/distinfo b/devel/pear-HTML_QuickForm_Controller/distinfo
new file mode 100644
index 000000000000..00de089ba317
--- /dev/null
+++ b/devel/pear-HTML_QuickForm_Controller/distinfo
@@ -0,0 +1,2 @@
+MD5 (PEAR/HTML_QuickForm_Controller-1.0.2.tgz) = 80eb2c4cfc70565a6e6a8f240d767e36
+SIZE (PEAR/HTML_QuickForm_Controller-1.0.2.tgz) = 14363
diff --git a/devel/pear-HTML_QuickForm_Controller/pkg-descr b/devel/pear-HTML_QuickForm_Controller/pkg-descr
new file mode 100644
index 000000000000..ea9511cbb6f8
--- /dev/null
+++ b/devel/pear-HTML_QuickForm_Controller/pkg-descr
@@ -0,0 +1,12 @@
+The package is essentially an implementation of a PageController pattern.
+
+Architecture:
+* Controller class that examines HTTP requests and manages form values
+ persistence across requests.
+* Page class (subclass of QuickForm) representing a single page of the form.
+* Business logic is contained in subclasses of Action class.
+
+Cool features:
+* Includes several default Actions that allow easy building of multipage forms.
+* Includes usage examples for common usage cases (single-page form, wizard,
+ tabbed form).