aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2005-11-28 05:33:49 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2005-11-28 05:33:49 +0000
commit91e2669758d051379ebfd07db18ce7d962a5ea2c (patch)
tree24ca4cc0ac73faa39723eb6bcfceb0a4d50e8cb5 /devel
parent4042a103a7e36c8c6abb96af9a62a967065d6e9b (diff)
downloadports-91e2669758d051379ebfd07db18ce7d962a5ea2c.tar.gz
ports-91e2669758d051379ebfd07db18ce7d962a5ea2c.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-File-Copy-Recursive/Makefile23
-rw-r--r--devel/p5-File-Copy-Recursive/distinfo3
-rw-r--r--devel/p5-File-Copy-Recursive/pkg-descr5
-rw-r--r--devel/p5-File-Copy-Recursive/pkg-plist7
5 files changed, 39 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 46ddafc09e14..bab362793c87 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -902,6 +902,7 @@
SUBDIR += p5-File-BasicFlock
SUBDIR += p5-File-Binary
SUBDIR += p5-File-Cache
+ SUBDIR += p5-File-Copy-Recursive
SUBDIR += p5-File-DirSync
SUBDIR += p5-File-FTS
SUBDIR += p5-File-Find-Rule
diff --git a/devel/p5-File-Copy-Recursive/Makefile b/devel/p5-File-Copy-Recursive/Makefile
new file mode 100644
index 000000000000..b904d8b7a99a
--- /dev/null
+++ b/devel/p5-File-Copy-Recursive/Makefile
@@ -0,0 +1,23 @@
+# ex:ts=8
+# Ports collection makefile for: File::Copy::Recursive
+# Date created: Nov 26, 2005
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= File-Copy-Recursive
+PORTVERSION= 0.16
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= File
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= Perl extension for recursively copying files and directories
+
+PERL_CONFIGURE= yes
+
+MAN3= File::Copy::Recursive.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-File-Copy-Recursive/distinfo b/devel/p5-File-Copy-Recursive/distinfo
new file mode 100644
index 000000000000..76ca9eb27e08
--- /dev/null
+++ b/devel/p5-File-Copy-Recursive/distinfo
@@ -0,0 +1,3 @@
+MD5 (File-Copy-Recursive-0.16.tar.gz) = feb03e5c434651124f0f5a3c04a63eac
+SHA256 (File-Copy-Recursive-0.16.tar.gz) = 4c3063df60103c5340499493f816b81b36d9923c2e0655c9b69b9adac8b50c73
+SIZE (File-Copy-Recursive-0.16.tar.gz) = 7800
diff --git a/devel/p5-File-Copy-Recursive/pkg-descr b/devel/p5-File-Copy-Recursive/pkg-descr
new file mode 100644
index 000000000000..162f11e233ae
--- /dev/null
+++ b/devel/p5-File-Copy-Recursive/pkg-descr
@@ -0,0 +1,5 @@
+This module copies and moves directories recursively (or single files, well...
+singley) to an optional depth and attempts to preserve each file or
+directory's mode.
+
+WWW: http://search.cpan.org/dist/File-Copy-Recursive/
diff --git a/devel/p5-File-Copy-Recursive/pkg-plist b/devel/p5-File-Copy-Recursive/pkg-plist
new file mode 100644
index 000000000000..73ea521cdc4d
--- /dev/null
+++ b/devel/p5-File-Copy-Recursive/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/File/Copy/Recursive.pm
+@unexec rmdir %D/%%SITE_PERL%%/File/Copy 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/File 2>/dev/null || true
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/File/Copy/Recursive/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/File/Copy/Recursive
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/File/Copy 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/File 2>/dev/null || true