aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-04-07 07:57:20 +0000
committerWill Andrews <will@FreeBSD.org>2001-04-07 07:57:20 +0000
commitd3c69b69280c35856309f9d4dedf27b5c318e506 (patch)
tree85dfb15ecd9fb3befc1dde36210ddd9237d0f93c /devel
parent56108469586d2be2faea76cfb047b2c4716ea541 (diff)
downloadports-d3c69b69280c35856309f9d4dedf27b5c318e506.tar.gz
ports-d3c69b69280c35856309f9d4dedf27b5c318e506.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/ocamlweb/Makefile31
-rw-r--r--devel/ocamlweb/distinfo2
-rw-r--r--devel/ocamlweb/pkg-comment1
-rw-r--r--devel/ocamlweb/pkg-descr22
-rw-r--r--devel/ocamlweb/pkg-plist4
6 files changed, 61 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 626f3ada1766..2f836e012df8 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -239,6 +239,7 @@
SUBDIR += newt
SUBDIR += noweb
SUBDIR += oaf
+ SUBDIR += ocamlweb
SUBDIR += omniORB
SUBDIR += p5-Agent
SUBDIR += p5-Algorithm-Diff
diff --git a/devel/ocamlweb/Makefile b/devel/ocamlweb/Makefile
new file mode 100644
index 000000000000..3271593f29f7
--- /dev/null
+++ b/devel/ocamlweb/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: ocamlweb
+# Date created: 4 February 2001
+# Whom: Patrick Doane <patrick@watson.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ocamlweb
+PORTVERSION= 0.9
+CATEGORIES= devel
+MASTER_SITES= http://www.lri.fr/~filliatr/ftp/ocamlweb/
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DOCFILES}
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
+
+MAINTAINER= patrick@watson.org
+
+BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml
+
+GNU_CONFIGURE= yes
+
+.if !defined(NOPORTDOCS)
+DOCFILES= ${PORTNAME}-man.ps.gz
+.endif
+
+post-install:
+.if !defined{NOPORTDOCS}
+ ${MKDIR} ${PREFIX}/share/doc/${PORTNAME}
+ ${INSTALL_MAN} ${DISTDIR}/${PORTNAME}-man.ps.gz ${PREFIX}/share/doc/${PORTNAME}
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/ocamlweb/distinfo b/devel/ocamlweb/distinfo
new file mode 100644
index 000000000000..1e04c972ba7b
--- /dev/null
+++ b/devel/ocamlweb/distinfo
@@ -0,0 +1,2 @@
+MD5 (ocamlweb-0.9.tar.gz) = 1c6c0b307b6cf5e840c7255cdb6bd322
+MD5 (ocamlweb-man.ps.gz) = 41731901a88d410a3d95593602a5677f
diff --git a/devel/ocamlweb/pkg-comment b/devel/ocamlweb/pkg-comment
new file mode 100644
index 000000000000..7543f47ffd74
--- /dev/null
+++ b/devel/ocamlweb/pkg-comment
@@ -0,0 +1 @@
+A literate programming tool for Objective Caml
diff --git a/devel/ocamlweb/pkg-descr b/devel/ocamlweb/pkg-descr
new file mode 100644
index 000000000000..caa9c6cac9de
--- /dev/null
+++ b/devel/ocamlweb/pkg-descr
@@ -0,0 +1,22 @@
+Literate programming has been introduced by D. E. Knuth in 1984. The
+main idea is to put the code and its documentation in the same file
+and to produce from it a document which is readable by a human, and
+not only by a machine. Although ocamlweb borrows a lot of ideas from
+Knuth's original tool (called WEB), there are big differences between
+them. First, WEB allows you to present the pieces of your code in any
+order, and this is quite useful when using poorly structured
+languages, like Pascal or C. But Objective Caml is already highly
+structured, and this is no more useful. Moreover, WEB requires the use
+of a tool to produce the code from the WEB file, which greatly
+complicates the use of your favorite source-based tools (dependencies
+generator, debugger, emacs mode, etc.). When using ocamlweb, the
+documentation is inserted in the code as comments (in the Caml sense),
+and your code is not linked to the existence of ocamlweb in any way.
+
+Currently, the task of ocamlweb may be seen as:
+
+ 1. making a nice document with the code and its documentation;
+ 2. generating a global index of cross-references, where each identifier
+ is associated to the lists of sections where it is defined or used.
+
+WWW: http://www.lri.fr/~filliatr/ocamlweb
diff --git a/devel/ocamlweb/pkg-plist b/devel/ocamlweb/pkg-plist
new file mode 100644
index 000000000000..f60f483345f6
--- /dev/null
+++ b/devel/ocamlweb/pkg-plist
@@ -0,0 +1,4 @@
+bin/ocamlweb
+share/texmf/tex/latex/misc/ocamlweb.sty
+share/doc/ocamlweb/ocamlweb-man.ps.gz
+@dirrm share/doc/ocamlweb