aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2021-01-03 08:46:19 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2021-01-03 08:46:19 +0000
commit372b15d95a6cf5226a2feb8cc5c2ab511b45b0e8 (patch)
treed3a5692362de8c6f79c67ec76f5d667b64c12f3f /devel
parent7c9571be467d197eb21892a78fb9373d4c254f66 (diff)
downloadports-372b15d95a6cf5226a2feb8cc5c2ab511b45b0e8.tar.gz
ports-372b15d95a6cf5226a2feb8cc5c2ab511b45b0e8.zip
Resurrect py-typing to unbreak bulk -a
Notes
Notes: svn path=/head/; revision=559996
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-typing/Makefile23
-rw-r--r--devel/py-typing/distinfo3
-rw-r--r--devel/py-typing/pkg-descr8
4 files changed, 35 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index eb5b9874f9e6..546e932c73d2 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5125,6 +5125,7 @@
SUBDIR += py-txaio
SUBDIR += py-typechecks
SUBDIR += py-typed-ast
+ SUBDIR += py-typing
SUBDIR += py-typing-extensions
SUBDIR += py-typing-inspect
SUBDIR += py-tzlocal
diff --git a/devel/py-typing/Makefile b/devel/py-typing/Makefile
new file mode 100644
index 000000000000..8038990a705d
--- /dev/null
+++ b/devel/py-typing/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= typing
+PORTVERSION= 3.7.4.1
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= rm@FreeBSD.org
+COMMENT= Type Hints for Python
+
+LICENSE= PSFL
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+DEPRECATED= Python 2 only, backport of Python 3
+EXPIRATION_DATE= 2020-12-31
+
+USES= python:2.7
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-typing/distinfo b/devel/py-typing/distinfo
new file mode 100644
index 000000000000..3c152f961ff8
--- /dev/null
+++ b/devel/py-typing/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1582223012
+SHA256 (typing-3.7.4.1.tar.gz) = 91dfe6f3f706ee8cc32d38edbbf304e9b7583fb37108fef38229617f8b3eba23
+SIZE (typing-3.7.4.1.tar.gz) = 77982
diff --git a/devel/py-typing/pkg-descr b/devel/py-typing/pkg-descr
new file mode 100644
index 000000000000..bd205715df0f
--- /dev/null
+++ b/devel/py-typing/pkg-descr
@@ -0,0 +1,8 @@
+This is a backport of the standard library typing module to Python
+versions older than 3.5.
+Typing defines a standard notation for Python function and variable type
+annotations. The notation can be used for documenting code in a concise,
+standard format, and it has been designed to also be used by static and
+runtime type checkers, static analyzers, IDEs and other tools.
+
+WWW: https://pypi.org/project/typing/