aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>1997-06-30 12:13:10 +0000
committerThomas Gellekum <tg@FreeBSD.org>1997-06-30 12:13:10 +0000
commit44a2b1c87f17f1c22a838e5ee6fd57851b121325 (patch)
tree884ae72a72b2d3ea5595892e1e10ca551ced72bf /devel
parent43885f1efee51889b81d698b3147aee1092dd884 (diff)
downloadports-44a2b1c87f17f1c22a838e5ee6fd57851b121325.tar.gz
ports-44a2b1c87f17f1c22a838e5ee6fd57851b121325.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/f77flow/Makefile23
-rw-r--r--devel/f77flow/distinfo1
-rw-r--r--devel/f77flow/pkg-comment1
-rw-r--r--devel/f77flow/pkg-descr19
-rw-r--r--devel/f77flow/pkg-plist2
5 files changed, 46 insertions, 0 deletions
diff --git a/devel/f77flow/Makefile b/devel/f77flow/Makefile
new file mode 100644
index 000000000000..61a458ce373c
--- /dev/null
+++ b/devel/f77flow/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: f77flow
+# Version required: 0.12
+# Date created: 25 June 1997
+# Whom: Andrey Zakhvatov
+#
+# $Id$
+#
+
+DISTNAME= f77flow-0.12
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SUNSITE}
+MASTER_SITE_SUBDIR= devel/lang/fortran
+
+MAINTAINER= andy@icc.surw.chel.su
+
+ALL_TARGET=
+MAN1= flow.1
+
+do-install:
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/flow ${PREFIX}/bin/flow
+ @ ${INSTALL_MAN} ${WRKSRC}/flow.1 ${PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/devel/f77flow/distinfo b/devel/f77flow/distinfo
new file mode 100644
index 000000000000..414d9870b0ca
--- /dev/null
+++ b/devel/f77flow/distinfo
@@ -0,0 +1 @@
+MD5 (f77flow-0.12.tar.gz) = 7b666a539fa6b607f7030b76fd1cfe12
diff --git a/devel/f77flow/pkg-comment b/devel/f77flow/pkg-comment
new file mode 100644
index 000000000000..2adb9fa4185d
--- /dev/null
+++ b/devel/f77flow/pkg-comment
@@ -0,0 +1 @@
+Analyze the structure of a fortran77 program
diff --git a/devel/f77flow/pkg-descr b/devel/f77flow/pkg-descr
new file mode 100644
index 000000000000..01d61c512f92
--- /dev/null
+++ b/devel/f77flow/pkg-descr
@@ -0,0 +1,19 @@
+This little program analyses the structure of FORTRAN source-code. As a
+result you get a little flow diagram in which you can recognize which
+SUBROUTINE is called by the program. Further all subroutines called from this
+one are displayed. The indciation of the displayed names is a degree for the
+level.
+
+A new addition is the change of the starting point for an analyse. Instead to
+check the whole source-code you can start with a special SUBROUTINE and see
+the depence of this one.
+
+The number of files which contain the routines are not restricted by the
+program.
+
+You can report the CALL- and/or SUBROUTINE-statements together with filenames
+and line numbers to special files.
+
+Dirk Geschke
+geschke@physik.uni-kassel.de
+7. March 1997
diff --git a/devel/f77flow/pkg-plist b/devel/f77flow/pkg-plist
new file mode 100644
index 000000000000..f3a45f328646
--- /dev/null
+++ b/devel/f77flow/pkg-plist
@@ -0,0 +1,2 @@
+bin/flow
+man/man1/flow.1.gz