aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2009-05-13 05:36:29 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2009-05-13 05:36:29 +0000
commit8c89f1fcf14deaa43731bb12f671660b5cd0a06d (patch)
tree7a8218ef056cccbbbebeb51b3d087f086337bcd8 /devel
parent455b4be9623fa0f37b5acadee6c588f06962c948 (diff)
downloadports-8c89f1fcf14deaa43731bb12f671660b5cd0a06d.tar.gz
ports-8c89f1fcf14deaa43731bb12f671660b5cd0a06d.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-MooseX-Meta-TypeConstraint-ForceCoercion/Makefile25
-rw-r--r--devel/p5-MooseX-Meta-TypeConstraint-ForceCoercion/distinfo3
-rw-r--r--devel/p5-MooseX-Meta-TypeConstraint-ForceCoercion/pkg-descr5
-rw-r--r--devel/p5-MooseX-Meta-TypeConstraint-ForceCoercion/pkg-plist9
5 files changed, 43 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 16071291ca60..eaf8a2599058 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1606,6 +1606,7 @@
SUBDIR += p5-MooseX-Getopt
SUBDIR += p5-MooseX-IOC
SUBDIR += p5-MooseX-Log-Log4perl
+ SUBDIR += p5-MooseX-Meta-TypeConstraint-ForceCoercion
SUBDIR += p5-MooseX-POE
SUBDIR += p5-MooseX-Policy-SemiAffordanceAccessor
SUBDIR += p5-MooseX-SimpleConfig
diff --git a/devel/p5-MooseX-Meta-TypeConstraint-ForceCoercion/Makefile b/devel/p5-MooseX-Meta-TypeConstraint-ForceCoercion/Makefile
new file mode 100644
index 000000000000..677c9c31e7ee
--- /dev/null
+++ b/devel/p5-MooseX-Meta-TypeConstraint-ForceCoercion/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: MooseX-Meta-TypeConstraint-ForceCoercion
+# Date created: 13 May 2009
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= MooseX-Meta-TypeConstraint-ForceCoercion
+PORTVERSION= 0.01
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Force coercion when validating type constraints
+
+BUILD_DEPENDS= p5-Moose>=0:${PORTSDIR}/devel/p5-Moose \
+ p5-namespace-autoclean>=0:${PORTSDIR}/devel/p5-namespace-autoclean
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= MooseX::Meta::TypeConstraint::ForceCoercion.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-MooseX-Meta-TypeConstraint-ForceCoercion/distinfo b/devel/p5-MooseX-Meta-TypeConstraint-ForceCoercion/distinfo
new file mode 100644
index 000000000000..9091e7908432
--- /dev/null
+++ b/devel/p5-MooseX-Meta-TypeConstraint-ForceCoercion/distinfo
@@ -0,0 +1,3 @@
+MD5 (MooseX-Meta-TypeConstraint-ForceCoercion-0.01.tar.gz) = 6208f4c7be243d911d26e6cbfca6bc6b
+SHA256 (MooseX-Meta-TypeConstraint-ForceCoercion-0.01.tar.gz) = f13a688369c1cb58b0c4479502702a277ae62354566439e4bab72e925847f845
+SIZE (MooseX-Meta-TypeConstraint-ForceCoercion-0.01.tar.gz) = 9079
diff --git a/devel/p5-MooseX-Meta-TypeConstraint-ForceCoercion/pkg-descr b/devel/p5-MooseX-Meta-TypeConstraint-ForceCoercion/pkg-descr
new file mode 100644
index 000000000000..02861ade01dc
--- /dev/null
+++ b/devel/p5-MooseX-Meta-TypeConstraint-ForceCoercion/pkg-descr
@@ -0,0 +1,5 @@
+MooseX::Meta::TypeConstraint::ForceCoercion allows to wrap any
+Moose::Meta::TypeConstraint in a way that will force coercion of the
+value when checking or validating a value against it.
+
+WWW: http://search.cpan.org/dist/MooseX-Meta-TypeConstraint-ForceCoercion/
diff --git a/devel/p5-MooseX-Meta-TypeConstraint-ForceCoercion/pkg-plist b/devel/p5-MooseX-Meta-TypeConstraint-ForceCoercion/pkg-plist
new file mode 100644
index 000000000000..3fb0a381b0a6
--- /dev/null
+++ b/devel/p5-MooseX-Meta-TypeConstraint-ForceCoercion/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/MooseX/Meta/TypeConstraint/ForceCoercion/.packlist
+%%SITE_PERL%%/MooseX/Meta/TypeConstraint/ForceCoercion.pm
+@dirrmtry %%SITE_PERL%%/MooseX/Meta/TypeConstraint
+@dirrmtry %%SITE_PERL%%/MooseX/Meta
+@dirrmtry %%SITE_PERL%%/MooseX
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/MooseX/Meta/TypeConstraint/ForceCoercion
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/MooseX/Meta/TypeConstraint
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/MooseX/Meta
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/MooseX