aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2002-10-06 19:50:45 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2002-10-06 19:50:45 +0000
commitf006f18654d67d8bfa9884d8efe2ee2607073b65 (patch)
tree1784ff99e30a4cf584a984aead37af331985f82d /devel
parenta80cf36ff5804657e2f9977e1e0cd3f1cfe24eac (diff)
downloadports-f006f18654d67d8bfa9884d8efe2ee2607073b65.tar.gz
ports-f006f18654d67d8bfa9884d8efe2ee2607073b65.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/ruby-bsearch/Makefile6
-rw-r--r--devel/ruby-cvs/Makefile10
-rw-r--r--devel/ruby-gemfinder/Makefile7
-rw-r--r--devel/ruby-mmap/Makefile6
-rw-r--r--devel/ruby-sdl/Makefile6
-rw-r--r--devel/ruby-sysvipc/Makefile6
-rw-r--r--devel/ruby-tzfile/Makefile6
-rw-r--r--devel/ruby-unit/Makefile4
8 files changed, 17 insertions, 34 deletions
diff --git a/devel/ruby-bsearch/Makefile b/devel/ruby-bsearch/Makefile
index 44dcbe8536f6..e84e89abaee2 100644
--- a/devel/ruby-bsearch/Makefile
+++ b/devel/ruby-bsearch/Makefile
@@ -16,9 +16,7 @@ DIST_SUBDIR= ruby
MAINTAINER= knu@FreeBSD.org
USE_RUBY= yes
-.if !defined(NOPORTDOCS)
-USE_RUBY_RD= yes
-.endif
+USE_RUBY_RDTOOL= yes
DOCS_EN= ChangeLog bsearch.en.html bsearch.en.rd
DOCS_JA= bsearch.ja.html bsearch.ja.rd
@@ -27,7 +25,7 @@ do-build:
.if !defined(NOPORTDOCS)
.for f in bsearch.en.rd bsearch.ja.rd
@cd ${WRKSRC}; \
- ${RUBY_RD} ${f} > ${f:R}.html
+ ${RUBY_RD2} ${f} > ${f:R}.html
.endfor
.endif
diff --git a/devel/ruby-cvs/Makefile b/devel/ruby-cvs/Makefile
index 467e6c6585f2..115c0e6f6ef2 100644
--- a/devel/ruby-cvs/Makefile
+++ b/devel/ruby-cvs/Makefile
@@ -19,9 +19,7 @@ MAINTAINER= knu@FreeBSD.org
RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/flex.so:${PORTSDIR}/devel/ruby-flex_rb
USE_RUBY= yes
-.if !defined(NOPORTDOCS)
-USE_RUBY_RD= yes
-.endif
+USE_RUBY_RDTOOL= yes
RUBY_SHEBANG_FILES= ${WRKSRC}/viztree ${WRKSRC}/reviz/reviz
@@ -31,9 +29,9 @@ DOCS= README TODO cvs.html diff.html tempdir.html
do-build:
.if !defined(NOPORTDOCS)
- cd ${WRKSRC}; ${RUBY_RD} lib/cvs.rb > cvs.html
- cd ${WRKSRC}; ${RUBY_RD} lib/diff.rb > diff.html
- cd ${WRKSRC}; ${RUBY_RD} lib/tempdir.rb > tempdir.html
+ cd ${WRKSRC}; ${RUBY_RD2} lib/cvs.rb > cvs.html
+ cd ${WRKSRC}; ${RUBY_RD2} lib/diff.rb > diff.html
+ cd ${WRKSRC}; ${RUBY_RD2} lib/tempdir.rb > tempdir.html
.endif
do-install:
diff --git a/devel/ruby-gemfinder/Makefile b/devel/ruby-gemfinder/Makefile
index 9ee995543ca8..08413b078a8e 100644
--- a/devel/ruby-gemfinder/Makefile
+++ b/devel/ruby-gemfinder/Makefile
@@ -18,10 +18,7 @@ MAINTAINER= knu@FreeBSD.org
RUN_DEPENDS= ${RUBY_LIBDIR}/tk.rb:${PORTSDIR}/x11-toolkits/ruby-tk
USE_RUBY= yes
-
-.if !defined(NOPORTDOCS)
-USE_RUBY_RD= yes
-.endif
+USE_RUBY_RDTOOL= yes
RUBY_SHEBANG_FILES= ${WRKSRC}/gemfinder
@@ -29,7 +26,7 @@ DOCS= README gemfinder.html gemfinder.rd
do-build:
.if !defined(NOPORTDOCS)
- ${RUBY_RD} < ${WRKSRC}/gemfinder.rd \
+ ${RUBY_RD2} < ${WRKSRC}/gemfinder.rd \
| ${SED} -e 's/<BODY>/<body bgcolor="#ffffff">/' \
> ${WRKSRC}/gemfinder.html
.endif
diff --git a/devel/ruby-mmap/Makefile b/devel/ruby-mmap/Makefile
index 53f2591cdc03..7dac75fc7e1f 100644
--- a/devel/ruby-mmap/Makefile
+++ b/devel/ruby-mmap/Makefile
@@ -20,9 +20,7 @@ BUILD_DEPENDS= rdoc:${PORTSDIR}/textproc/ruby-rdoc
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
-.if !defined(NOPORTDOCS)
-USE_RUBY_RD= yes
-.endif
+USE_RUBY_RDTOOL= yes
INSTALL_TARGET= site-install
@@ -32,7 +30,7 @@ EXAMPLES= b.rb
post-build:
.if !defined(NOPORTDOCS)
- cd ${WRKSRC}; ${RUBY_RD} mmap.rd > mmap.html
+ cd ${WRKSRC}; ${RUBY_RD2} mmap.rd > mmap.html
cd ${WRKSRC}/docs; ${RUBY} b.rb mmap; rdoc mmap.rb
.endif
diff --git a/devel/ruby-sdl/Makefile b/devel/ruby-sdl/Makefile
index d9a8ba42bc6c..17467a043588 100644
--- a/devel/ruby-sdl/Makefile
+++ b/devel/ruby-sdl/Makefile
@@ -26,9 +26,7 @@ RUBY_OPENGL_WRKSRC_CMD= cd ${RUBY_OPENGL_PORTDIR}; ${MAKE} -V WRKSRC
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
-.if !defined(NOPORTDOCS)
-USE_RUBY_RD= yes
-.endif
+USE_RUBY_RDTOOL= yes
RUBY_WITH_PTHREAD= yes
CONFIGURE_ARGS= --with-sdl-config="sdl11-config" \
@@ -57,7 +55,7 @@ post-patch:
post-build:
.if !defined(NOPORTDOCS)
.for f in ${RD_DOCS_EN} ${RD_DOCS_JA}
- @cd ${WRKSRC}; ${RUBY_RD} ${f} > ${f:S/.rd$/.html/}
+ @cd ${WRKSRC}; ${RUBY_RD2} ${f} > ${f:S/.rd$/.html/}
.endfor
.endif
diff --git a/devel/ruby-sysvipc/Makefile b/devel/ruby-sysvipc/Makefile
index 4265f8a2a2c8..2c637ec8ec0a 100644
--- a/devel/ruby-sysvipc/Makefile
+++ b/devel/ruby-sysvipc/Makefile
@@ -17,9 +17,7 @@ MAINTAINER= knu@FreeBSD.org
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
-.if !defined(NOPORTDOCS)
-USE_RUBY_RD= yes
-.endif
+USE_RUBY_RDTOOL= yes
INSTALL_TARGET= site-install
@@ -27,7 +25,7 @@ DOCS= sysvipc.html sysvipc.rd
post-build:
.if !defined(NOPORTDOCS)
- cd ${WRKSRC}; ${RUBY_RD} sysvipc.rd > sysvipc.html
+ cd ${WRKSRC}; ${RUBY_RD2} sysvipc.rd > sysvipc.html
.endif
post-install:
diff --git a/devel/ruby-tzfile/Makefile b/devel/ruby-tzfile/Makefile
index 41b7cbd4bd6c..3bc4748c992b 100644
--- a/devel/ruby-tzfile/Makefile
+++ b/devel/ruby-tzfile/Makefile
@@ -16,15 +16,13 @@ DIST_SUBDIR= ruby
MAINTAINER= knu@FreeBSD.org
USE_RUBY= yes
-.if !defined(NOPORTDOCS)
-USE_RUBY_RD= yes
-.endif
+USE_RUBY_RDTOOL= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
do-build:
.if !defined(NOPORTDOCS)
- cd ${WRKSRC}; ${RUBY_RD} tzfile.rb > tzfile.html
+ cd ${WRKSRC}; ${RUBY_RD2} tzfile.rb > tzfile.html
.endif
do-install:
diff --git a/devel/ruby-unit/Makefile b/devel/ruby-unit/Makefile
index a12717f5dd5c..d2cbfa805b5c 100644
--- a/devel/ruby-unit/Makefile
+++ b/devel/ruby-unit/Makefile
@@ -16,9 +16,7 @@ DIST_SUBDIR= ruby
MAINTAINER= knu@FreeBSD.org
USE_RUBY= yes
-.if !defined(NOPORTDOCS)
-USE_RUBY_RD= yes
-.endif
+USE_RUBY_RDTOOL= yes
RUBY_SHEBANG_FILES= ${WRKSRC}/bin/c2t.rb \
${WRKSRC}/bin/runtest.rb