aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2013-09-09 16:55:31 +0000
committerAndrej Zverev <az@FreeBSD.org>2013-09-09 16:55:31 +0000
commitc10fb42dc444b49630522378287af32bcb6d9f53 (patch)
tree630a26bdd45922409a040c75fbbedf7e92c8dbc2 /devel
parent33734655a0d0ecda5f10d0e1d0971d54790b782d (diff)
downloadports-c10fb42dc444b49630522378287af32bcb6d9f53.tar.gz
ports-c10fb42dc444b49630522378287af32bcb6d9f53.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/colormake/Makefile3
-rw-r--r--devel/p5-Algorithm-Accounting/Makefile9
-rw-r--r--devel/p5-AnyEvent-Filesys-Notify/Makefile3
-rw-r--r--devel/p5-BSD-devstat/Makefile8
-rw-r--r--devel/p5-Class-Container/Makefile9
-rw-r--r--devel/p5-Config-MySQL/Makefile8
-rw-r--r--devel/p5-Data-MessagePack/Makefile3
-rw-r--r--devel/p5-Devel-Declare-Parser/Makefile8
-rw-r--r--devel/p5-Devel-LexAlias/Makefile3
-rw-r--r--devel/p5-Devel-StackTrace-WithLexicals/Makefile8
-rw-r--r--devel/p5-Fennec-Lite/Makefile8
-rw-r--r--devel/p5-Module-Versions/Makefile8
-rw-r--r--devel/p5-MooX-Options/Makefile3
-rw-r--r--devel/p5-Shell-Source/Makefile3
-rw-r--r--devel/p5-String-Similarity/Makefile9
-rw-r--r--devel/p5-Term-ReadPassword/Makefile8
-rw-r--r--devel/p5-Thread-Apartment/Makefile9
-rw-r--r--devel/p5-Thread-Queue-Duplex/Makefile9
-rw-r--r--devel/p5-Tie-ShareLite/Makefile9
19 files changed, 44 insertions, 84 deletions
diff --git a/devel/colormake/Makefile b/devel/colormake/Makefile
index 5c7d3a2c5a69..d6498156d6d5 100644
--- a/devel/colormake/Makefile
+++ b/devel/colormake/Makefile
@@ -12,7 +12,8 @@ RUN_DEPENDS= gmake:${PORTSDIR}/devel/gmake \
bash:${PORTSDIR}/shells/bash
NO_BUILD= yes
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
PLIST_FILES= bin/colormake bin/colormake.pl bin/colormake-short bin/clmake \
bin/clmake-short
diff --git a/devel/p5-Algorithm-Accounting/Makefile b/devel/p5-Algorithm-Accounting/Makefile
index efe360a62bd6..bbe1ed13f877 100644
--- a/devel/p5-Algorithm-Accounting/Makefile
+++ b/devel/p5-Algorithm-Accounting/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: devel/p5-Algorithm-Accounting
-# Date created: 25 Oct 2004
-# Whom: Yuan-Chung Hsiao <ychsiao@ychsiao.idv.tw>
-#
+# Created by: Yuan-Chung Hsiao <ychsiao@ychsiao.idv.tw>
# $FreeBSD$
-#
PORTNAME= Algorithm-Accounting
PORTVERSION= 0.08
@@ -26,7 +22,8 @@ BUILD_DEPENDS= p5-Spiffy>=0:${PORTSDIR}/devel/p5-Spiffy \
p5-YAML>=0:${PORTSDIR}/textproc/p5-YAML
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Algorithm::Accounting.3 \
Algorithm::Accounting::Report.3 \
diff --git a/devel/p5-AnyEvent-Filesys-Notify/Makefile b/devel/p5-AnyEvent-Filesys-Notify/Makefile
index 1903ba567185..b0157fc12c28 100644
--- a/devel/p5-AnyEvent-Filesys-Notify/Makefile
+++ b/devel/p5-AnyEvent-Filesys-Notify/Makefile
@@ -21,7 +21,8 @@ TEST_DEPENDS= p5-Data-Dump>=0:${PORTSDIR}/devel/p5-Data-Dump \
p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception \
p5-Test-Without-Module>=0:${PORTSDIR}/devel/p5-Test-Without-Module
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= AnyEvent::Filesys::Notify.3 \
AnyEvent::Filesys::Notify::Event.3 \
diff --git a/devel/p5-BSD-devstat/Makefile b/devel/p5-BSD-devstat/Makefile
index 272e83d18328..df47281ada77 100644
--- a/devel/p5-BSD-devstat/Makefile
+++ b/devel/p5-BSD-devstat/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: BSD::devstat
-# Date created: 25 Mar 2010
-# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= BSD-devstat
PORTVERSION= 0.02
@@ -15,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Perl extension of devstat(3) API
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= BSD::devstat.3
diff --git a/devel/p5-Class-Container/Makefile b/devel/p5-Class-Container/Makefile
index 649b617d6622..aa4267278511 100644
--- a/devel/p5-Class-Container/Makefile
+++ b/devel/p5-Class-Container/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Class::Container
-# Date created: 5 July 2002
-# Whom: Denis Shaposhnikov <dsh@vlink.ru>
-#
+# Created by: Denis Shaposhnikov <dsh@vlink.ru>
# $FreeBSD$
-#
PORTNAME= Class-Container
PORTVERSION= 0.12
@@ -17,7 +13,8 @@ COMMENT= Glues object frameworks together transparently
BUILD_DEPENDS= p5-Params-Validate>=0:${PORTSDIR}/devel/p5-Params-Validate
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Class::Container.3
diff --git a/devel/p5-Config-MySQL/Makefile b/devel/p5-Config-MySQL/Makefile
index f79881a5badb..f0b511b86932 100644
--- a/devel/p5-Config-MySQL/Makefile
+++ b/devel/p5-Config-MySQL/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: Config::MySQL
-# Date created: 19 Mar 2012
-# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= Config-MySQL
PORTVERSION= 0.02
@@ -18,7 +13,8 @@ RUN_DEPENDS= \
p5-Config-INI>0:${PORTSDIR}/devel/p5-Config-INI
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Config::MySQL.3 \
Config::MySQL::Reader.3 \
diff --git a/devel/p5-Data-MessagePack/Makefile b/devel/p5-Data-MessagePack/Makefile
index cfbd67a395ef..ce22161ceef3 100644
--- a/devel/p5-Data-MessagePack/Makefile
+++ b/devel/p5-Data-MessagePack/Makefile
@@ -13,7 +13,8 @@ COMMENT= Perl extension for MessagePack
TEST_DEPENDS= p5-Test-Requires>=0:${PORTSDIR}/devel/p5-Test-Requires \
p5-Test-LeakTrace>0:${PORTSDIR}/devel/p5-Test-LeakTrace
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
CONFIGURE_ARGS= --xs
MAKE_JOBS_UNSAFE= yes
diff --git a/devel/p5-Devel-Declare-Parser/Makefile b/devel/p5-Devel-Declare-Parser/Makefile
index dc1a44c9644c..6fdfa7e56c64 100644
--- a/devel/p5-Devel-Declare-Parser/Makefile
+++ b/devel/p5-Devel-Declare-Parser/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: Devel::Declare::Parser
-# Date created: 21 Nov 2010
-# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= Devel-Declare-Parser
PORTVERSION= 0.017
@@ -22,7 +17,8 @@ RUN_DEPENDS= \
BUILD_DEPENDS:= ${RUN_DEPENDS}
TEST_DEPENDS= p5-Test-Exception-LessClever>=0:${PORTSDIR}/devel/p5-Test-Exception-LessClever
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= Devel::Declare::Interface.3 \
Devel::Declare::Parser.3 \
diff --git a/devel/p5-Devel-LexAlias/Makefile b/devel/p5-Devel-LexAlias/Makefile
index a311900a8e42..991fda1d76ab 100644
--- a/devel/p5-Devel-LexAlias/Makefile
+++ b/devel/p5-Devel-LexAlias/Makefile
@@ -16,7 +16,8 @@ LICENSE_COMB= dual
BUILD_DEPENDS= p5-Devel-Caller>=0.03:${PORTSDIR}/devel/p5-Devel-Caller
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Devel::LexAlias.3
diff --git a/devel/p5-Devel-StackTrace-WithLexicals/Makefile b/devel/p5-Devel-StackTrace-WithLexicals/Makefile
index c54c977c450a..449ab07b57dd 100644
--- a/devel/p5-Devel-StackTrace-WithLexicals/Makefile
+++ b/devel/p5-Devel-StackTrace-WithLexicals/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: Devel::StackTrace::WithLexicals
-# Date created: 13 Oct 2009
-# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= Devel-StackTrace-WithLexicals
PORTVERSION= 0.10
@@ -19,7 +14,8 @@ RUN_DEPENDS= \
p5-PadWalker>=1.92:${PORTSDIR}/devel/p5-PadWalker
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Devel::StackTrace::WithLexicals.3
diff --git a/devel/p5-Fennec-Lite/Makefile b/devel/p5-Fennec-Lite/Makefile
index 79eec2d30e2e..3a5fa020a83e 100644
--- a/devel/p5-Fennec-Lite/Makefile
+++ b/devel/p5-Fennec-Lite/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: Fennec::Lite
-# Date created: 23 Nov 2010
-# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= Fennec-Lite
PORTVERSION= 0.004
@@ -14,7 +9,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Perl extension for minimalist Fennec, the commonly used bits
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= Fennec::Lite.3
diff --git a/devel/p5-Module-Versions/Makefile b/devel/p5-Module-Versions/Makefile
index f7eae95972da..55a1ebafc5c0 100644
--- a/devel/p5-Module-Versions/Makefile
+++ b/devel/p5-Module-Versions/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: Module::Versions
-# Date created: 03 Apr 2010
-# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= Module-Versions
PORTVERSION= 0.02
@@ -15,7 +10,8 @@ MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Perl extension to handle versions of loaded modules
USE_ZIP= yes
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Module::Versions.3
diff --git a/devel/p5-MooX-Options/Makefile b/devel/p5-MooX-Options/Makefile
index 923163de4ec8..ffbe91567735 100644
--- a/devel/p5-MooX-Options/Makefile
+++ b/devel/p5-MooX-Options/Makefile
@@ -29,7 +29,8 @@ RUN_DEPENDS= p5-Module-Runtime>=0.012:${PORTSDIR}/devel/p5-Module-Runtime \
p5-Getopt-Long-Descriptive>=0.093:${PORTSDIR}/devel/p5-Getopt-Long-Descriptive \
p5-Regexp-Common>=0:${PORTSDIR}/textproc/p5-Regexp-Common
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= MooX::Options.3 \
MooX::Options::Role.3
diff --git a/devel/p5-Shell-Source/Makefile b/devel/p5-Shell-Source/Makefile
index c079485d1561..b77cd3519adf 100644
--- a/devel/p5-Shell-Source/Makefile
+++ b/devel/p5-Shell-Source/Makefile
@@ -10,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= 5u623l20@gmail.com
COMMENT= Run programs and inherit environment changes
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Shell::Source.3
diff --git a/devel/p5-String-Similarity/Makefile b/devel/p5-String-Similarity/Makefile
index 77a1f3568219..f715b58b6f20 100644
--- a/devel/p5-String-Similarity/Makefile
+++ b/devel/p5-String-Similarity/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-String-Similarity
-# Date created: 22 June 2001
-# Whom: Kevin Lo <kevlo@FreeBSD.org>
-#
+# Created by: Kevin Lo <kevlo@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= String-Similarity
PORTVERSION= 1.04
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= kevlo@FreeBSD.org
COMMENT= Perl module that calculates the similarity of two strings
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= String::Similarity.3
diff --git a/devel/p5-Term-ReadPassword/Makefile b/devel/p5-Term-ReadPassword/Makefile
index c005ed433a7c..6dfd4e664e95 100644
--- a/devel/p5-Term-ReadPassword/Makefile
+++ b/devel/p5-Term-ReadPassword/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: p5-Term-ReadPassword
-# Date created: Aug 29 2005
-# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= Term-ReadPassword
PORTVERSION= 0.11
@@ -14,7 +9,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Perl module for asking the user for a password
-PERL_CONFIGURE= YES
+USES= perl5
+USE_PERL5= configure
MAN3= Term::ReadPassword.3
.include <bsd.port.mk>
diff --git a/devel/p5-Thread-Apartment/Makefile b/devel/p5-Thread-Apartment/Makefile
index 85f99655e42b..ca01fe3603de 100644
--- a/devel/p5-Thread-Apartment/Makefile
+++ b/devel/p5-Thread-Apartment/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Thread-Apartment
-# Date created: 2006-08-29
-# Whom: Jin-Shan Tseng <tjs@cdpa.nsysu.edu.tw>
-#
+# Created by: Jin-Shan Tseng <tjs@cdpa.nsysu.edu.tw>
# $FreeBSD$
-#
PORTNAME= Thread-Apartment
PORTVERSION= 0.51
@@ -19,7 +15,8 @@ RUN_DEPENDS= p5-Thread-Queue-Duplex>=0.92:${PORTSDIR}/devel/p5-Thread-Queue-Dupl
p5-Class-Inspector>=1.08:${PORTSDIR}/devel/p5-Class-Inspector
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Thread::Apartment.3
diff --git a/devel/p5-Thread-Queue-Duplex/Makefile b/devel/p5-Thread-Queue-Duplex/Makefile
index 6e01ed3b1b0b..9af788c34eec 100644
--- a/devel/p5-Thread-Queue-Duplex/Makefile
+++ b/devel/p5-Thread-Queue-Duplex/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Thread-Queue-Duplex
-# Date created: 2006-08-29
-# Whom: Jin-Shan Tseng <tjs@cdpa.nsysu.edu.tw>
-#
+# Created by: Jin-Shan Tseng <tjs@cdpa.nsysu.edu.tw>
# $FreeBSD$
-#
PORTNAME= Thread-Queue-Duplex
PORTVERSION= 0.92
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= tjs@cdpa.nsysu.edu.tw
COMMENT= Thread-safe request/response queue with identifiable elements
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Thread::Queue::Duplex.3 Thread::Queue::Queueable.3
diff --git a/devel/p5-Tie-ShareLite/Makefile b/devel/p5-Tie-ShareLite/Makefile
index 95b57b78a133..da8f0587539b 100644
--- a/devel/p5-Tie-ShareLite/Makefile
+++ b/devel/p5-Tie-ShareLite/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Tie-ShareLite
-# Date created: 21 Dec 2005
-# Whom: jnlin@csie.nctu.edu.tw
-#
+# Created by: jnlin@csie.nctu.edu.tw
# $FreeBSD$
-#
PORTNAME= Tie-ShareLite
PORTVERSION= 0.03
@@ -17,7 +13,8 @@ COMMENT= Tied hash interface to IPC::ShareLite
RUN_DEPENDS= p5-IPC-ShareLite>=0:${PORTSDIR}/devel/p5-IPC-ShareLite
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Tie::ShareLite.3