aboutsummaryrefslogtreecommitdiff
path: root/dns/bind8/Makefile
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2002-06-22 21:45:27 +0000
committerDoug Barton <dougb@FreeBSD.org>2002-06-22 21:45:27 +0000
commit614bb0e759405cbc1b7a5f660118ee3a2b6cd01b (patch)
tree1e1f6c5a18ef5fe46b8a301d8b6fbc3d0d0c6138 /dns/bind8/Makefile
parente98a7286401319ad99e1be7e5d830c3e043f3eeb (diff)
downloadports-614bb0e759405cbc1b7a5f660118ee3a2b6cd01b.tar.gz
ports-614bb0e759405cbc1b7a5f660118ee3a2b6cd01b.zip
Notes
Diffstat (limited to 'dns/bind8/Makefile')
-rw-r--r--dns/bind8/Makefile16
1 files changed, 15 insertions, 1 deletions
diff --git a/dns/bind8/Makefile b/dns/bind8/Makefile
index 6ab10759a6f6..9d0ecb193109 100644
--- a/dns/bind8/Makefile
+++ b/dns/bind8/Makefile
@@ -11,7 +11,7 @@
# you can generally build it cleanly from the source. - Doug
PORTNAME= bind
-PORTVERSION= 8.3.1
+PORTVERSION= 8.3.2
CATEGORIES?= net
MASTER_SITES= ftp://ftp.isc.org/isc/bind/src/${PORTVERSION}/ \
ftp://ftp.epix.net/pub/isc/bind/src/${PORTVERSION}/ \
@@ -23,7 +23,12 @@ DIST_SUBDIR= bind-${PORTVERSION}
MAINTAINER= DougB@FreeBSD.org
+.if defined(REPLACE_SYSTEM_BIND)
+PREFIX= /usr
+.endif
+
WRKSRC= ${WRKDIR}/src
+MAKE_ENV+= MANPREFIX=${MANPREFIX}
MAN1= dig.1 dnskeygen.1 dnsquery.1 host.1
MAN3= getaddrinfo.3 gethostbyname.3 getipnodebyname.3 getnetent.3 \
@@ -36,6 +41,15 @@ MAN8= named-bootconf.8 named-xfer.8 named.8 ndc.8 nslookup.8 \
PATCH_ARGS= -s -d ${WRKDIR}
PATCH_DIST_ARGS= -s -d ${WRKDIR}
+post-patch:
+.if defined(REPLACE_SYSTEM_BIND)
+ @${SED} -e "s#\'DESTETC=.*#'DESTETC=/etc/namedb'#" \
+ ${WRKSRC}/port/freebsd/Makefile.set > \
+ ${WRKSRC}/port/freebsd/Makefile.set.sed
+ @${MV} ${WRKSRC}/port/freebsd/Makefile.set.sed \
+ ${WRKSRC}/port/freebsd/Makefile.set
+.endif
+
post-install:
.if !defined(NOPORTDOCS)
@(cd ${WRKDIR}/doc/man && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} \