aboutsummaryrefslogtreecommitdiff
path: root/dns/bind9-devel/files
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2019-08-12 14:20:30 +0000
committerMathieu Arnold <mat@FreeBSD.org>2019-08-12 14:20:30 +0000
commitf3ecc71460beb1618238378d2c96318c02fc34c1 (patch)
tree58c6b4ba03bbe57ee10ac7e0c568606d364b152c /dns/bind9-devel/files
parent51b93a56aaf39443312e9baad49c8883a4163416 (diff)
downloadports-f3ecc71460beb1618238378d2c96318c02fc34c1.tar.gz
ports-f3ecc71460beb1618238378d2c96318c02fc34c1.zip
Notes
Diffstat (limited to 'dns/bind9-devel/files')
-rw-r--r--dns/bind9-devel/files/extrapatch-bind-min-override-ttl16
-rw-r--r--dns/bind9-devel/files/patch-bin_tests_system_dlzexternal_Makefile.in2
-rw-r--r--dns/bind9-devel/files/patch-configure10
3 files changed, 17 insertions, 11 deletions
diff --git a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
index a45c82abd171..70c5bce86955 100644
--- a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
+++ b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
@@ -1,4 +1,6 @@
---- bin/named/config.c.orig 2019-07-29 20:10:44 UTC
+Add the override-cache-ttl feature.
+
+--- bin/named/config.c.orig 2019-08-12 08:39:30 UTC
+++ bin/named/config.c
@@ -177,6 +177,7 @@ options {\n\
notify-source *;\n\
@@ -8,9 +10,9 @@
provide-ixfr true;\n\
qname-minimization relaxed;\n\
query-source address *;\n\
---- bin/named/server.c.orig 2019-07-29 20:10:44 UTC
+--- bin/named/server.c.orig 2019-08-12 08:39:30 UTC
+++ bin/named/server.c
-@@ -4218,6 +4218,11 @@ configure_view(dns_view_t *view, dns_viewlist_t *viewl
+@@ -4217,6 +4217,11 @@ configure_view(dns_view_t *view, dns_viewlist_t *viewl
}
obj = NULL;
@@ -22,7 +24,7 @@
result = named_config_get(maps, "max-cache-ttl", &obj);
INSIST(result == ISC_R_SUCCESS);
view->maxcachettl = cfg_obj_asuint32(obj);
---- lib/dns/include/dns/view.h.orig 2019-07-29 20:10:44 UTC
+--- lib/dns/include/dns/view.h.orig 2019-08-12 08:39:30 UTC
+++ lib/dns/include/dns/view.h
@@ -152,6 +152,7 @@ struct dns_view {
bool requestnsid;
@@ -32,9 +34,9 @@
dns_ttl_t maxncachettl;
dns_ttl_t mincachettl;
dns_ttl_t minncachettl;
---- lib/dns/resolver.c.orig 2019-07-29 20:10:44 UTC
+--- lib/dns/resolver.c.orig 2019-08-12 08:39:30 UTC
+++ lib/dns/resolver.c
-@@ -6022,6 +6022,12 @@ cache_name(fetchctx_t *fctx, dns_name_t *name, dns_adb
+@@ -6011,6 +6011,12 @@ cache_name(fetchctx_t *fctx, dns_name_t *name, dns_adb
}
/*
@@ -47,7 +49,7 @@
* Enforce the configure maximum cache TTL.
*/
if (rdataset->ttl > res->view->maxcachettl) {
---- lib/isccfg/namedconf.c.orig 2019-07-29 20:10:44 UTC
+--- lib/isccfg/namedconf.c.orig 2019-08-12 08:39:30 UTC
+++ lib/isccfg/namedconf.c
@@ -1907,6 +1907,7 @@ view_clauses[] = {
#endif
diff --git a/dns/bind9-devel/files/patch-bin_tests_system_dlzexternal_Makefile.in b/dns/bind9-devel/files/patch-bin_tests_system_dlzexternal_Makefile.in
index ab39836bb768..5fbeafc70626 100644
--- a/dns/bind9-devel/files/patch-bin_tests_system_dlzexternal_Makefile.in
+++ b/dns/bind9-devel/files/patch-bin_tests_system_dlzexternal_Makefile.in
@@ -1,3 +1,5 @@
+BIND9 seems to be abusing LDFLAGS here, and it breaks our linker.
+
--- bin/tests/system/dlzexternal/Makefile.in.orig 2019-06-28 12:33:29 UTC
+++ bin/tests/system/dlzexternal/Makefile.in
@@ -35,7 +35,7 @@ OBJS =
diff --git a/dns/bind9-devel/files/patch-configure b/dns/bind9-devel/files/patch-configure
index 5388015c9f46..228618f74756 100644
--- a/dns/bind9-devel/files/patch-configure
+++ b/dns/bind9-devel/files/patch-configure
@@ -1,6 +1,8 @@
---- configure.orig 2019-08-06 04:55:46 UTC
+Fixup gssapi and db detection.
+
+--- configure.orig 2019-08-12 08:39:30 UTC
+++ configure
-@@ -17183,27 +17183,9 @@ done
+@@ -17216,27 +17216,9 @@ done
# problems start to show up.
saved_libs="$LIBS"
for TRY_LIBS in \
@@ -30,7 +32,7 @@
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking linking as $TRY_LIBS" >&5
$as_echo_n "checking linking as $TRY_LIBS... " >&6; }
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
-@@ -17246,47 +17228,7 @@ $as_echo "no" >&6; } ;;
+@@ -17279,47 +17261,7 @@ $as_echo "no" >&6; } ;;
no) as_fn_error $? "could not determine proper GSSAPI linkage" "$LINENO" 5 ;;
esac
@@ -79,7 +81,7 @@
DNS_GSSAPI_LIBS="$LIBS"
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: using GSSAPI from $use_gssapi/lib and $use_gssapi/include" >&5
-@@ -22676,7 +22618,7 @@ $as_echo "" >&6; }
+@@ -22709,7 +22651,7 @@ $as_echo "" >&6; }
# Check other locations for includes.
# Order is important (sigh).