aboutsummaryrefslogtreecommitdiff
path: root/dns/bind9-devel
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-02-19 14:12:23 +0000
committerMathieu Arnold <mat@FreeBSD.org>2018-02-19 14:12:23 +0000
commit6d2c3c18170cf63bc803d5419adddc90738b7af6 (patch)
treea15f60831ee25e21e8e15d5a5d0755a531354301 /dns/bind9-devel
parent2b1bd7149d396f44e5ba3d77ae9b39a988e0e76c (diff)
downloadports-6d2c3c18170cf63bc803d5419adddc90738b7af6.tar.gz
ports-6d2c3c18170cf63bc803d5419adddc90738b7af6.zip
Notes
Diffstat (limited to 'dns/bind9-devel')
-rw-r--r--dns/bind9-devel/Makefile12
-rw-r--r--dns/bind9-devel/distinfo6
-rw-r--r--dns/bind9-devel/files/extrapatch-bind-min-override-ttl14
-rw-r--r--dns/bind9-devel/files/patch-configure8
-rw-r--r--dns/bind9-devel/pkg-plist1
5 files changed, 20 insertions, 21 deletions
diff --git a/dns/bind9-devel/Makefile b/dns/bind9-devel/Makefile
index f4a924c6e312..9d2c53bad5d9 100644
--- a/dns/bind9-devel/Makefile
+++ b/dns/bind9-devel/Makefile
@@ -11,14 +11,14 @@ PORTREVISION= 0
PORTREVISION= 0
.endif
CATEGORIES= dns net ipv6
-MASTER_SITES= LOCAL/mat/bind
-#MASTER_SITES= https://source.isc.org/cgi-bin/gitweb.cgi?p=bind9.git;a=snapshot;h=${HASH};sf=tgz;/
+MASTER_SITES= LOCAL/mat/bind \
+ https://gitlab.isc.org/isc-projects/bind9/repository/${HASH}/archive.tar.bz2?d/
.if defined(BIND_TOOLS_SLAVE)
PKGNAMESUFFIX= -tools
.else
PKGNAMESUFFIX= 9-devel
.endif
-DISTNAME= ${PORTNAME}9-${HASH}
+DISTNAME= ${PORTNAME}9-${HASH}-${HASH}
MAINTAINER= mat@FreeBSD.org
.if defined(BIND_TOOLS_SLAVE)
@@ -31,10 +31,10 @@ LICENSE= MPL20
LICENSE_FILE= ${WRKSRC}/COPYRIGHT
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.13.0a0.2018.02.10
-HASH= 313e733
+ISCVERSION= 9.13.0a0.2018.02.19
+HASH= 2a50992ab3f9762912e2d4c3f76ab50f213225ed
-USES= cpe libedit
+USES= cpe libedit tar:bz2
CPE_VENDOR= isc
CPE_VERSION= ${ISCVERSION:C/-.*//}
diff --git a/dns/bind9-devel/distinfo b/dns/bind9-devel/distinfo
index 503864a97f4d..d063752ddc4b 100644
--- a/dns/bind9-devel/distinfo
+++ b/dns/bind9-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1518435709
-SHA256 (bind9-313e733.tar.gz) = f768ea970976b1e20907a82fdf01ec4d0f9f599377366fccd7637fb49cfd736e
-SIZE (bind9-313e733.tar.gz) = 11391568
+TIMESTAMP = 1519049419
+SHA256 (bind9-2a50992ab3f9762912e2d4c3f76ab50f213225ed-2a50992ab3f9762912e2d4c3f76ab50f213225ed.tar.bz2) = 8b8524af457132febd65c7bad7704f143c194fe9bb019e72a21ae6013744ee30
+SIZE (bind9-2a50992ab3f9762912e2d4c3f76ab50f213225ed-2a50992ab3f9762912e2d4c3f76ab50f213225ed.tar.bz2) = 9265793
diff --git a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
index 8c2054cb4463..445dc5c47e32 100644
--- a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
+++ b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
@@ -1,4 +1,4 @@
---- bin/named/config.c.orig 2018-01-29 05:35:56 UTC
+--- bin/named/config.c.orig 2018-02-19 09:25:15 UTC
+++ bin/named/config.c
@@ -176,12 +176,14 @@ options {\n\
max-recursion-queries 75;\n\
@@ -15,9 +15,9 @@
provide-ixfr true;\n\
query-source address *;\n\
query-source-v6 address *;\n\
---- bin/named/server.c.orig 2018-01-29 05:35:56 UTC
+--- bin/named/server.c.orig 2018-02-19 09:25:15 UTC
+++ bin/named/server.c
-@@ -4073,6 +4073,16 @@ configure_view(dns_view_t *view, dns_vie
+@@ -4074,6 +4074,16 @@ configure_view(dns_view_t *view, dns_vie
}
obj = NULL;
@@ -34,7 +34,7 @@
result = named_config_get(maps, "max-cache-ttl", &obj);
INSIST(result == ISC_R_SUCCESS);
view->maxcachettl = cfg_obj_asuint32(obj);
---- lib/dns/include/dns/view.h.orig 2018-01-29 05:35:56 UTC
+--- lib/dns/include/dns/view.h.orig 2018-02-19 09:25:15 UTC
+++ lib/dns/include/dns/view.h
@@ -145,6 +145,8 @@ struct dns_view {
isc_boolean_t requestnsid;
@@ -45,9 +45,9 @@
dns_ttl_t maxncachettl;
isc_uint32_t nta_lifetime;
isc_uint32_t nta_recheck;
---- lib/dns/resolver.c.orig 2018-01-29 05:35:56 UTC
+--- lib/dns/resolver.c.orig 2018-02-19 09:25:15 UTC
+++ lib/dns/resolver.c
-@@ -5748,6 +5748,18 @@ cache_name(fetchctx_t *fctx, dns_name_t
+@@ -5745,6 +5745,18 @@ cache_name(fetchctx_t *fctx, dns_name_t
}
/*
@@ -66,7 +66,7 @@
* Enforce the configure maximum cache TTL.
*/
if (rdataset->ttl > res->view->maxcachettl) {
---- lib/isccfg/namedconf.c.orig 2018-01-29 05:35:56 UTC
+--- lib/isccfg/namedconf.c.orig 2018-02-19 09:25:15 UTC
+++ lib/isccfg/namedconf.c
@@ -1913,6 +1913,8 @@ view_clauses[] = {
{ "max-acache-size", &cfg_type_sizenodefault,
diff --git a/dns/bind9-devel/files/patch-configure b/dns/bind9-devel/files/patch-configure
index a6a115793c70..3c35750143e7 100644
--- a/dns/bind9-devel/files/patch-configure
+++ b/dns/bind9-devel/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2018-01-22 08:56:04 UTC
+--- configure.orig 2018-02-19 09:25:15 UTC
+++ configure
-@@ -14444,27 +14444,9 @@ done
+@@ -14939,27 +14939,9 @@ done
# problems start to show up.
saved_libs="$LIBS"
for TRY_LIBS in \
@@ -30,7 +30,7 @@
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking linking as $TRY_LIBS" >&5
$as_echo_n "checking linking as $TRY_LIBS... " >&6; }
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
-@@ -14507,47 +14489,7 @@ $as_echo "no" >&6; } ;;
+@@ -15002,47 +14984,7 @@ $as_echo "no" >&6; } ;;
no) as_fn_error $? "could not determine proper GSSAPI linkage" "$LINENO" 5 ;;
esac
@@ -79,7 +79,7 @@
DNS_GSSAPI_LIBS="$LIBS"
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: using GSSAPI from $use_gssapi/lib and $use_gssapi/include" >&5
-@@ -23204,7 +23146,7 @@ $as_echo "" >&6; }
+@@ -23681,7 +23623,7 @@ $as_echo "" >&6; }
# Check other locations for includes.
# Order is important (sigh).
diff --git a/dns/bind9-devel/pkg-plist b/dns/bind9-devel/pkg-plist
index cdd3e74b1d14..b986cedcfa73 100644
--- a/dns/bind9-devel/pkg-plist
+++ b/dns/bind9-devel/pkg-plist
@@ -191,7 +191,6 @@ include/isc/netdb.h
include/isc/netscope.h
include/isc/offset.h
include/isc/once.h
-include/isc/ondestroy.h
include/isc/os.h
include/isc/parseint.h
include/isc/platform.h