aboutsummaryrefslogtreecommitdiff
path: root/dns/bind9-devel
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2020-09-07 15:13:31 +0000
committerMathieu Arnold <mat@FreeBSD.org>2020-09-07 15:13:31 +0000
commitf32e42fb8caba49655c76fc594bfb0ed42566b9f (patch)
treeb95dd18b0d5a4edb2d71b7b01bebb0a9f220554b /dns/bind9-devel
parente519ec0dbb7d7a273130755b12dff33e47e65223 (diff)
downloadports-f32e42fb8caba49655c76fc594bfb0ed42566b9f.tar.gz
ports-f32e42fb8caba49655c76fc594bfb0ed42566b9f.zip
Notes
Diffstat (limited to 'dns/bind9-devel')
-rw-r--r--dns/bind9-devel/Makefile6
-rw-r--r--dns/bind9-devel/distinfo6
-rw-r--r--dns/bind9-devel/files/extrapatch-bind-min-override-ttl14
3 files changed, 13 insertions, 13 deletions
diff --git a/dns/bind9-devel/Makefile b/dns/bind9-devel/Makefile
index fe8ccbffbc37..81b8bd4e8011 100644
--- a/dns/bind9-devel/Makefile
+++ b/dns/bind9-devel/Makefile
@@ -9,7 +9,7 @@ PORTREVISION= 0
.else
# XXX: correct version
# dns/bind9xx here
-PORTREVISION= 2
+PORTREVISION= 0
.endif
CATEGORIES= dns net
# XXX: put the ISC master_site
@@ -48,13 +48,13 @@ RUN_DEPENDS= bind-tools>0:dns/bind-tools
# XXX: remove tar:bz2
USES= autoreconf compiler:c11 cpe libedit libtool pkgconfig ssl tar:bz2
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.17.4a0.2020.08.31
+ISCVERSION= 9.17.4a0.2020.09.04
# XXX: Remove gitlab
USE_GITLAB= yes
GL_SITE= https://gitlab.isc.org
GL_ACCOUNT= isc-projects
GL_PROJECT= bind9
-GL_COMMIT= 96c4010fe5cc08b9a4cf208962df64fd85bfb781
+GL_COMMIT= 4ed3238eace80c3701c6bbf6457e09201d5a9262
CPE_VENDOR= isc
CPE_VERSION= ${ISCVERSION:C/-.*//}
diff --git a/dns/bind9-devel/distinfo b/dns/bind9-devel/distinfo
index eace031c5b4a..0b710f6cac4a 100644
--- a/dns/bind9-devel/distinfo
+++ b/dns/bind9-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1598874594
-SHA256 (isc-projects-bind9-96c4010fe5cc08b9a4cf208962df64fd85bfb781_GL0.tar.gz) = 1586b5d8f0b322ff95f927e933f84fe3085873adc985f2f063f8a68deddcacd9
-SIZE (isc-projects-bind9-96c4010fe5cc08b9a4cf208962df64fd85bfb781_GL0.tar.gz) = 4339850
+TIMESTAMP = 1599490624
+SHA256 (isc-projects-bind9-4ed3238eace80c3701c6bbf6457e09201d5a9262_GL0.tar.gz) = 6640ace40e2386cbe3a86e183cc2d092c8ac52f096baa56a4dfd2c6e9a2f03dc
+SIZE (isc-projects-bind9-4ed3238eace80c3701c6bbf6457e09201d5a9262_GL0.tar.gz) = 4342623
diff --git a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
index 9a60114028c0..ecfab0464c5f 100644
--- a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
+++ b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
@@ -1,6 +1,6 @@
Add the override-cache-ttl feature.
---- bin/named/config.c.orig 2020-08-24 11:39:18 UTC
+--- bin/named/config.c.orig 2020-09-04 21:22:20 UTC
+++ bin/named/config.c
@@ -180,6 +180,7 @@ options {\n\
notify-source *;\n\
@@ -10,9 +10,9 @@ Add the override-cache-ttl feature.
provide-ixfr true;\n\
qname-minimization relaxed;\n\
query-source address *;\n\
---- bin/named/server.c.orig 2020-08-24 11:39:18 UTC
+--- bin/named/server.c.orig 2020-09-04 21:22:20 UTC
+++ bin/named/server.c
-@@ -4334,6 +4334,11 @@ configure_view(dns_view_t *view, dns_viewlist_t *viewl
+@@ -4343,6 +4343,11 @@ configure_view(dns_view_t *view, dns_viewlist_t *viewl
}
obj = NULL;
@@ -24,7 +24,7 @@ Add the override-cache-ttl feature.
result = named_config_get(maps, "max-cache-ttl", &obj);
INSIST(result == ISC_R_SUCCESS);
view->maxcachettl = cfg_obj_asduration(obj);
---- lib/dns/include/dns/view.h.orig 2020-08-24 11:39:18 UTC
+--- lib/dns/include/dns/view.h.orig 2020-09-04 21:22:20 UTC
+++ lib/dns/include/dns/view.h
@@ -152,6 +152,7 @@ struct dns_view {
bool requestnsid;
@@ -34,9 +34,9 @@ Add the override-cache-ttl feature.
dns_ttl_t maxncachettl;
dns_ttl_t mincachettl;
dns_ttl_t minncachettl;
---- lib/dns/resolver.c.orig 2020-08-24 11:39:18 UTC
+--- lib/dns/resolver.c.orig 2020-09-04 21:22:20 UTC
+++ lib/dns/resolver.c
-@@ -6256,6 +6256,12 @@ cache_name(fetchctx_t *fctx, dns_name_t *name, dns_adb
+@@ -6263,6 +6263,12 @@ cache_name(fetchctx_t *fctx, dns_name_t *name, dns_adb
}
/*
@@ -49,7 +49,7 @@ Add the override-cache-ttl feature.
* Enforce the configure maximum cache TTL.
*/
if (rdataset->ttl > res->view->maxcachettl) {
---- lib/isccfg/namedconf.c.orig 2020-08-24 11:39:18 UTC
+--- lib/isccfg/namedconf.c.orig 2020-09-04 21:22:20 UTC
+++ lib/isccfg/namedconf.c
@@ -1993,6 +1993,7 @@ static cfg_clausedef_t view_clauses[] = {
#endif /* ifdef HAVE_LMDB */