aboutsummaryrefslogtreecommitdiff
path: root/dns/bind9-devel
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-08-22 12:20:54 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-08-22 12:20:54 +0000
commit171a8f9631cc51b3a671889becfce89a8d62aa67 (patch)
tree81ab51d6f6ff53eb0ee45f8beca0fc1dd5ebee4e /dns/bind9-devel
parent1954b9c27ef0a860bb55057497a38868a859f40c (diff)
downloadports-171a8f9631cc51b3a671889becfce89a8d62aa67.tar.gz
ports-171a8f9631cc51b3a671889becfce89a8d62aa67.zip
Notes
Diffstat (limited to 'dns/bind9-devel')
-rw-r--r--dns/bind9-devel/Makefile8
-rw-r--r--dns/bind9-devel/distinfo6
-rw-r--r--dns/bind9-devel/files/extrapatch-bind-min-override-ttl16
-rw-r--r--dns/bind9-devel/files/patch-configure4
-rw-r--r--dns/bind9-devel/pkg-plist2
5 files changed, 19 insertions, 17 deletions
diff --git a/dns/bind9-devel/Makefile b/dns/bind9-devel/Makefile
index f6239796d560..5d451b556a18 100644
--- a/dns/bind9-devel/Makefile
+++ b/dns/bind9-devel/Makefile
@@ -16,8 +16,8 @@ COMMENT= BIND DNS suite with updated DNSSEC and DNS64
LICENSE= MPL
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.12.0a.2016.08.15
-HASH= 131307a
+ISCVERSION= 9.12.0a.2016.08.19
+HASH= 228a095
MAKE_JOBS_UNSAFE= yes
@@ -45,14 +45,14 @@ CONFLICTS+= bind9*-9.[456789].* bind910-* bind911-* bind9*-sdb-9.[456789].*
SUB_FILES= pkg-message
-OPTIONS_DEFAULT= SSL THREADS SIGCHASE IDN GSSAPI_NONE DLZ_FILESYSTEM
+OPTIONS_DEFAULT= SSL THREADS SIGCHASE IDN GSSAPI_NONE
OPTIONS_DEFINE= IDN LARGE_FILE PYTHON START_LATE \
FIXED_RRSET SIGCHASE IPV6 THREADS FILTER_AAAA
OPTIONS_RADIO= CRYPTO GOSTDEF
OPTIONS_RADIO_CRYPTO= SSL NATIVE_PKCS11
OPTIONS_RADIO_GOSTDEF= GOST GOST_ASN1
-OPTIONS_DEFAULT+= RRL
+OPTIONS_DEFAULT+= RRL DLZ_FILESYSTEM LMDB
OPTIONS_DEFINE+= LINKS RPZ_NSIP RPZ_NSDNAME RRL DOCS NEWSTATS GEOIP \
MINCACHE PORTREVISION FETCHLIMIT QUERYTRACE LMDB
OPTIONS_GROUP= DLZ
diff --git a/dns/bind9-devel/distinfo b/dns/bind9-devel/distinfo
index 9323e35b2fdf..e753e7339421 100644
--- a/dns/bind9-devel/distinfo
+++ b/dns/bind9-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1471268744
-SHA256 (bind9-131307a.tar.gz) = e2db65b1852b1e13c809ae60d07780f2878e3ca5e93a7f6a4bbe42780da89ed2
-SIZE (bind9-131307a.tar.gz) = 11768867
+TIMESTAMP = 1471867300
+SHA256 (bind9-228a095.tar.gz) = 247dd197143b41976c5a55a0d019ac504e966d46bfab7eae507033991cdd33ae
+SIZE (bind9-228a095.tar.gz) = 11779488
diff --git a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
index aebb23264afb..3ef99063536e 100644
--- a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
+++ b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
@@ -1,6 +1,6 @@
---- bin/named/config.c.orig 2016-07-29 21:44:23 UTC
+--- bin/named/config.c.orig 2016-08-19 12:54:07 UTC
+++ bin/named/config.c
-@@ -152,6 +152,8 @@ options {\n\
+@@ -154,6 +154,8 @@ options {\n\
lame-ttl 600;\n\
servfail-ttl 1;\n\
max-ncache-ttl 10800; /* 3 hours */\n\
@@ -9,9 +9,9 @@
max-cache-ttl 604800; /* 1 week */\n\
transfer-format many-answers;\n\
max-cache-size 90%;\n\
---- bin/named/server.c.orig 2016-07-29 21:44:23 UTC
+--- bin/named/server.c.orig 2016-08-19 12:54:07 UTC
+++ bin/named/server.c
-@@ -3567,6 +3567,16 @@ configure_view(dns_view_t *view, dns_vie
+@@ -3636,6 +3636,16 @@ configure_view(dns_view_t *view, dns_vie
}
obj = NULL;
@@ -28,7 +28,7 @@
result = ns_config_get(maps, "max-cache-ttl", &obj);
INSIST(result == ISC_R_SUCCESS);
view->maxcachettl = cfg_obj_asuint32(obj);
---- lib/dns/include/dns/view.h.orig 2016-07-29 21:44:23 UTC
+--- lib/dns/include/dns/view.h.orig 2016-08-19 12:54:07 UTC
+++ lib/dns/include/dns/view.h
@@ -146,6 +146,8 @@ struct dns_view {
isc_boolean_t requestnsid;
@@ -39,7 +39,7 @@
dns_ttl_t maxncachettl;
isc_uint32_t nta_lifetime;
isc_uint32_t nta_recheck;
---- lib/dns/resolver.c.orig 2016-07-29 21:44:23 UTC
+--- lib/dns/resolver.c.orig 2016-08-19 12:54:07 UTC
+++ lib/dns/resolver.c
@@ -5431,6 +5431,18 @@ cache_name(fetchctx_t *fctx, dns_name_t
}
@@ -60,9 +60,9 @@
* Enforce the configure maximum cache TTL.
*/
if (rdataset->ttl > res->view->maxcachettl)
---- lib/isccfg/namedconf.c.orig 2016-07-29 21:44:23 UTC
+--- lib/isccfg/namedconf.c.orig 2016-08-19 12:54:07 UTC
+++ lib/isccfg/namedconf.c
-@@ -1707,6 +1707,8 @@ view_clauses[] = {
+@@ -1735,6 +1735,8 @@ view_clauses[] = {
{ "nosit-udp-size", &cfg_type_uint32, CFG_CLAUSEFLAG_OBSOLETE },
{ "max-acache-size", &cfg_type_sizenodefault, 0 },
{ "max-cache-size", &cfg_type_sizeorpercent, 0 },
diff --git a/dns/bind9-devel/files/patch-configure b/dns/bind9-devel/files/patch-configure
index 35242a932c38..318a883260bc 100644
--- a/dns/bind9-devel/files/patch-configure
+++ b/dns/bind9-devel/files/patch-configure
@@ -1,4 +1,4 @@
---- configure.orig 2016-08-15 08:47:02 UTC
+--- configure.orig 2016-08-19 12:54:07 UTC
+++ configure
@@ -14340,27 +14340,9 @@ done
# problems start to show up.
@@ -79,7 +79,7 @@
DNS_GSSAPI_LIBS="$LIBS"
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: using GSSAPI from $use_gssapi/lib and $use_gssapi/include" >&5
-@@ -22477,7 +22419,7 @@ $as_echo "" >&6; }
+@@ -22522,7 +22464,7 @@ $as_echo "" >&6; }
# Check other locations for includes.
# Order is important (sigh).
diff --git a/dns/bind9-devel/pkg-plist b/dns/bind9-devel/pkg-plist
index 5a0dfcccabb2..03aa890170ea 100644
--- a/dns/bind9-devel/pkg-plist
+++ b/dns/bind9-devel/pkg-plist
@@ -136,6 +136,7 @@ include/isc/counter.h
include/isc/crc64.h
include/isc/dir.h
include/isc/entropy.h
+include/isc/errno.h
include/isc/error.h
include/isc/event.h
include/isc/eventclass.h
@@ -257,6 +258,7 @@ include/pk11/constants.h
include/pk11/internal.h
include/pk11/pk11.h
include/pk11/result.h
+include/pk11/site.h
include/pkcs11/cryptoki.h
include/pkcs11/pkcs11.h
include/pkcs11/pkcs11f.h