aboutsummaryrefslogtreecommitdiff
path: root/dns/bind9-sdb-ldap
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2009-02-16 11:21:51 +0000
committerMartin Matuska <mm@FreeBSD.org>2009-02-16 11:21:51 +0000
commit64bb783474007e94783bc6c6455b8cb23de6d573 (patch)
tree84a93c522f4ce5d9a488915dd70ac3690951206c /dns/bind9-sdb-ldap
parenta1e5c1b510a905bfc9993c20a37bb1f9cc3fd046 (diff)
downloadports-64bb783474007e94783bc6c6455b8cb23de6d573.tar.gz
ports-64bb783474007e94783bc6c6455b8cb23de6d573.zip
Notes
Diffstat (limited to 'dns/bind9-sdb-ldap')
-rw-r--r--dns/bind9-sdb-ldap/Makefile76
-rw-r--r--dns/bind9-sdb-ldap/distinfo12
-rw-r--r--dns/bind9-sdb-ldap/pkg-message20
-rw-r--r--dns/bind9-sdb-ldap/pkg-plist14
4 files changed, 78 insertions, 44 deletions
diff --git a/dns/bind9-sdb-ldap/Makefile b/dns/bind9-sdb-ldap/Makefile
index 13b430cb85ef..ec3478f21bf4 100644
--- a/dns/bind9-sdb-ldap/Makefile
+++ b/dns/bind9-sdb-ldap/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= bind9
-PORTVERSION= 9.4.2.1
-PORTREVISION= 1
+PORTVERSION= 9.4.3.1
CATEGORIES= dns net ipv6
-MASTER_SITES= ${MASTER_SITE_ISC}
+MASTER_SITES= ${MASTER_SITE_ISC} \
+ http://dougbarton.us/Downloads/%SUBDIR%/
MASTER_SITE_SUBDIR= bind9/${ISCVERSION}
PKGNAMESUFFIX= -sdb-ldap
DISTNAME= bind-${ISCVERSION}
@@ -23,22 +23,57 @@ USE_OPENLDAP= yes
CONFLICTS= bind9-9.* bind9-sdb-postgresql-* host-* skalibs-*
-# ISC releases things like 9.3.0rc1, which our versioning doesn't like
-ISCVERSION= 9.4.2-P1
+# ISC releases things like 9.4.0b3, which our versioning doesn't like
+ISCVERSION= 9.4.3-P1
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --localstatedir=/var --disable-linux-caps --with-openssl \
+CONFIGURE_ARGS= --localstatedir=/var --disable-linux-caps \
--with-randomdev=/dev/random
+OPTIONS= SSL "Building without OpenSSL removes DNSSEC" on \
+ REPLACE_BASE "Replace base BIND with this version" off \
+ LARGE_FILE "64-bit file support" off \
+ SIGCHASE "dig/host/nslookup will do DNSSEC validation" off \
+ IPV6 "IPv6 Support (autodetected by default)" off
+
+# Just in case
USE_OPENSSL= yes
-.if !defined(WITHOUT_BIND9_THREADS) || defined(PACKAGE_BUILDING)
+.include <bsd.port.pre.mk>
+
+# We are ok by default from 7.0-RELEASE on
+.if ${OSVERSION} >= 700055
+OPTIONS+= THREADS "Compile with thread support" on
+.else
+OPTIONS+= THREADS "Compile w/threads (Not Recommended <FreeBSD-7)" off
+.endif
+
+.if !defined(WITHOUT_SSL)
+CONFIGURE_ARGS+= --with-openssl=${OPENSSLBASE}
+.else
+CONFIGURE_ARGS+= --disable-openssl-version-check
+CONFIGURE_ARGS+= --without-openssl
+.endif
+
+.if defined(WITH_LARGE_FILE)
+CONFIGURE_ARGS+= --enable-largefile
+.endif
+
+.if defined(WITH_SIGCHASE)
+CONFIGURE_ARGS+= STD_CDEFINES="-DDIG_SIGCHASE=1"
+.endif
+
+.if defined(WITH_IPV6)
+CONFIGURE_ARGS+= --enable-ipv6
+.endif
+
+.if !defined(WITHOUT_THREADS)
CONFIGURE_ARGS+= --enable-threads
.else
CONFIGURE_ARGS+= --disable-threads
.endif
-.if defined(WITH_PORT_REPLACES_BASE_BIND9)
+.if defined(WITH_REPLACE_BASE)
PKGNAMESUFFIX= -sdb-ldap-base
PREFIX= /usr
BIND_DESTETC= /etc/namedb
@@ -50,7 +85,7 @@ BIND_DESTETC= ${PREFIX}/etc
PLIST_SUB= BIND_DESTETC="${BIND_DESTETC}"
-MAN1= dig.1 host.1 nslookup.1
+MAN1= dig.1 host.1 nslookup.1 nsupdate.1
MAN3= lwres.3 lwres_addr_parse.3 lwres_buffer.3 lwres_buffer_add.3 \
lwres_buffer_back.3 lwres_buffer_clear.3 lwres_buffer_first.3 \
lwres_buffer_forward.3 lwres_buffer_getmem.3 lwres_buffer_getuint16.3 \
@@ -86,24 +121,14 @@ MAN3= lwres.3 lwres_addr_parse.3 lwres_buffer.3 lwres_buffer_add.3 \
lwres_sethostent_r.3 lwres_string_parse.3
MAN5= named.conf.5 rndc.conf.5
MAN8= dnssec-keygen.8 dnssec-signzone.8 lwresd.8 named-checkconf.8 \
- named-checkzone.8 named.8 nsupdate.8 rndc-confgen.8 rndc.8
+ named-checkzone.8 named.8 rndc-confgen.8 rndc.8
MLINKS= named-checkzone.8 named-compilezone.8
-pre-fetch:
-.if defined(PORT_REPLACES_BASE_BIND9)
- @${ECHO} ""
- @${ECHO} "***************************************************"
- @${ECHO} "Support for the old PORT_REPLACES_BASE_BIND9 option"
- @${ECHO} "will be removed in future versions of the port."
- @${ECHO} "Use WITH_PORT_REPLACES_BASE_BIND9 instead."
- @${ECHO} "***************************************************"
- @${ECHO} ""
- @/bin/sleep 5
-WITH_PORT_REPLACES_BASE_BIND9= true
-.endif
+verify: checksum
+ gpg --verify ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}.asc
post-patch:
-.for FILE in check/named-checkconf.8 named/named.8 nsupdate/nsupdate.8 \
+.for FILE in check/named-checkconf.8 named/named.8 nsupdate/nsupdate.1 \
rndc/rndc.8
@${MV} ${WRKSRC}/bin/${FILE} ${WRKSRC}/bin/${FILE}.Dist
@${SED} -e 's#/etc/named.conf#${BIND_DESTETC}/named.conf#g' \
@@ -116,7 +141,8 @@ post-install:
${BIND_DESTETC}/rndc.conf.sample
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}/arm ${DOCSDIR}/misc
- ${INSTALL_DATA} ${WRKSRC}/doc/arm/Bv9ARM*html ${DOCSDIR}/arm
+ ${INSTALL_DATA} ${WRKSRC}/doc/arm/*.html ${DOCSDIR}/arm
+ ${INSTALL_DATA} ${WRKSRC}/doc/arm/Bv9ARM.pdf ${DOCSDIR}/
${INSTALL_DATA} ${WRKSRC}/doc/misc/[a-z]* ${DOCSDIR}/misc
${CP} ${WRKSRC}/CHANGES ${WRKSRC}/COPYRIGHT ${WRKSRC}/FAQ \
${WRKSRC}/README ${DOCSDIR}/
@@ -124,4 +150,4 @@ post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/dns/bind9-sdb-ldap/distinfo b/dns/bind9-sdb-ldap/distinfo
index 2084eef61776..ba127ded9e78 100644
--- a/dns/bind9-sdb-ldap/distinfo
+++ b/dns/bind9-sdb-ldap/distinfo
@@ -1,6 +1,6 @@
-MD5 (bind-9.4.2-P1.tar.gz) = 87b80edd9872cb017053866c81ca9be8
-SHA256 (bind-9.4.2-P1.tar.gz) = eeeb8f89fe6d88b250ad85ee21cfde6f8ac6f425c70c6705352b3fa8c4c4ee84
-SIZE (bind-9.4.2-P1.tar.gz) = 6451654
-MD5 (bind-9.4.2-P1.tar.gz.asc) = 72310b7045d9806b913835c55ba5388b
-SHA256 (bind-9.4.2-P1.tar.gz.asc) = c84b6446416ff1096ec5bfb1c731d31f984b312b45a3d2064a922a6b50b6162d
-SIZE (bind-9.4.2-P1.tar.gz.asc) = 479
+MD5 (bind-9.4.3-P1.tar.gz) = 3cb525ad4f22315e23f08c8ce1e1d3d3
+SHA256 (bind-9.4.3-P1.tar.gz) = 6f4323db5b55105a83a71517f42c0e6f1defdeefa7156b5ebe035480e2755c8a
+SIZE (bind-9.4.3-P1.tar.gz) = 6544583
+MD5 (bind-9.4.3-P1.tar.gz.asc) = b0f6c208697755993966c9dca4c0e069
+SHA256 (bind-9.4.3-P1.tar.gz.asc) = e346a9169b9d30d47a709bb9c654d579c86b698531260bd81e526ff40d74cd5c
+SIZE (bind-9.4.3-P1.tar.gz.asc) = 479
diff --git a/dns/bind9-sdb-ldap/pkg-message b/dns/bind9-sdb-ldap/pkg-message
index 8dd5f7e54f92..bb713abdd1d3 100644
--- a/dns/bind9-sdb-ldap/pkg-message
+++ b/dns/bind9-sdb-ldap/pkg-message
@@ -5,18 +5,14 @@
* / ___ \| | | | | |___| |\ | | | | | |_| | |\ | *
* /_/ \_\_| |_| |_____|_| \_| |_| |___\___/|_| \_| *
* *
-* BIND 9 requires a good source of randomness to operate. *
-* It also requires configuration of rndc, including a *
-* "secret" key. If you are using FreeBSD 4.x, visit *
-* http://people.freebsd.org/~dougb/randomness.html for *
-* information on how to set up entropy gathering. Users *
-* of FreeBSD 5.x or later do not need to do this step. If *
-* you are running BIND 9 in a chroot environment, make *
-* sure that there is a /dev/random device in the chroot. *
+* If you are running BIND 9 in a chroot environment, make *
+* sure that there is a /dev/random device in the chroot. *
* *
-* The easiest, and most secure way to configure rndc is *
-* to run 'rndc-confgen -a' which will generate the proper *
-* conf file, with a new random key, and appropriate file *
-* permissions. *
+* BIND 9 also requires configuration of rndc, including a *
+* "secret" key. The easiest, and most secure way to configure *
+* rndc is to run 'rndc-confgen -a' to generate the proper conf *
+* file, with a new random key, and appropriate file permissions. *
+* *
+* The /etc/rc.d/named script in the base will do both for you. *
* *
*************************************************************************
diff --git a/dns/bind9-sdb-ldap/pkg-plist b/dns/bind9-sdb-ldap/pkg-plist
index f23884e448d4..9ef535bc8b9b 100644
--- a/dns/bind9-sdb-ldap/pkg-plist
+++ b/dns/bind9-sdb-ldap/pkg-plist
@@ -74,8 +74,8 @@ include/dst/dst.h
include/dst/lib.h
include/dst/result.h
include/isc/app.h
-include/isc/atomic.h
include/isc/assertions.h
+include/isc/atomic.h
include/isc/base64.h
include/isc/bitstring.h
include/isc/boolean.h
@@ -195,6 +195,7 @@ sbin/named-checkzone
sbin/named-compilezone
sbin/rndc
sbin/rndc-confgen
+%%PORTDOCS%%%%DOCSDIR%%/Bv9ARM.pdf
%%PORTDOCS%%%%DOCSDIR%%/CHANGES
%%PORTDOCS%%%%DOCSDIR%%/COPYRIGHT
%%PORTDOCS%%%%DOCSDIR%%/FAQ
@@ -210,6 +211,16 @@ sbin/rndc-confgen
%%PORTDOCS%%%%DOCSDIR%%/arm/Bv9ARM.ch09.html
%%PORTDOCS%%%%DOCSDIR%%/arm/Bv9ARM.ch10.html
%%PORTDOCS%%%%DOCSDIR%%/arm/Bv9ARM.html
+%%PORTDOCS%%%%DOCSDIR%%/arm/man.dig.html
+%%PORTDOCS%%%%DOCSDIR%%/arm/man.dnssec-keygen.html
+%%PORTDOCS%%%%DOCSDIR%%/arm/man.dnssec-signzone.html
+%%PORTDOCS%%%%DOCSDIR%%/arm/man.host.html
+%%PORTDOCS%%%%DOCSDIR%%/arm/man.named-checkconf.html
+%%PORTDOCS%%%%DOCSDIR%%/arm/man.named-checkzone.html
+%%PORTDOCS%%%%DOCSDIR%%/arm/man.named.html
+%%PORTDOCS%%%%DOCSDIR%%/arm/man.rndc-confgen.html
+%%PORTDOCS%%%%DOCSDIR%%/arm/man.rndc.conf.html
+%%PORTDOCS%%%%DOCSDIR%%/arm/man.rndc.html
%%PORTDOCS%%%%DOCSDIR%%/misc/dnssec
%%PORTDOCS%%%%DOCSDIR%%/misc/format-options.pl
%%PORTDOCS%%%%DOCSDIR%%/misc/ipv6
@@ -219,6 +230,7 @@ sbin/rndc-confgen
%%PORTDOCS%%%%DOCSDIR%%/misc/rfc-compliance
%%PORTDOCS%%%%DOCSDIR%%/misc/roadmap
%%PORTDOCS%%%%DOCSDIR%%/misc/sdb
+%%PORTDOCS%%%%DOCSDIR%%/misc/sort-options.pl
%%PORTDOCS%%@dirrm %%DOCSDIR%%/arm
%%PORTDOCS%%@dirrm %%DOCSDIR%%/misc
%%PORTDOCS%%@dirrm %%DOCSDIR%%