aboutsummaryrefslogtreecommitdiff
path: root/dns/bind910
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2015-09-18 22:11:21 +0000
committerMathieu Arnold <mat@FreeBSD.org>2015-09-18 22:11:21 +0000
commit752504ffb605146d3fdc1e6635f6e79c417f6cf9 (patch)
tree862cb59fdbc82ff5509f477c629ebc59791bfc89 /dns/bind910
parentab90db428d2f800c46cfbf58f196d6b0800307e8 (diff)
Fixup gssapi from base.
Submitted by: hrs Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=397301
Diffstat (limited to 'dns/bind910')
-rw-r--r--dns/bind910/Makefile6
-rw-r--r--dns/bind910/files/patch-configure91
2 files changed, 84 insertions, 13 deletions
diff --git a/dns/bind910/Makefile b/dns/bind910/Makefile
index 12963fae332a..c4a276473691 100644
--- a/dns/bind910/Makefile
+++ b/dns/bind910/Makefile
@@ -172,13 +172,13 @@ START_LATE_SUB_LIST_OFF=NAMED_REQUIRE="NETWORKING ldconfig syslogd" \
GSSAPI_BASE_USES= gssapi
GSSAPI_BASE_CONFIGURE_ON= \
- --with-gssapi=${GSSAPIBASEDIR} ${GSSAPI_CONFIGURE_ARGS}
+ --with-gssapi=${GSSAPIBASEDIR} KRB5CONFIG="${KRB5CONFIG}"
GSSAPI_HEIMDAL_USES= gssapi:heimdal
GSSAPI_HEIMDAL_CONFIGURE_ON= \
- --with-gssapi=${GSSAPIBASEDIR} ${GSSAPI_CONFIGURE_ARGS}
+ --with-gssapi=${GSSAPIBASEDIR} KRB5CONFIG="${KRB5CONFIG}"
GSSAPI_MIT_USES= gssapi:mit
GSSAPI_MIT_CONFIGURE_ON= \
- --with-gssapi=${GSSAPIBASEDIR} ${GSSAPI_CONFIGURE_ARGS}
+ --with-gssapi=${GSSAPIBASEDIR} KRB5CONFIG="${KRB5CONFIG}"
GSSAPI_NONE_CONFIGURE_ON= --without-gssapi
.include <bsd.port.options.mk>
diff --git a/dns/bind910/files/patch-configure b/dns/bind910/files/patch-configure
index 01e870150ec6..22c76881d022 100644
--- a/dns/bind910/files/patch-configure
+++ b/dns/bind910/files/patch-configure
@@ -1,10 +1,81 @@
---- configure.orig 2015-09-09 02:23:40 UTC
-+++ configure
-@@ -14105,6 +14105,7 @@ done
- "-lgssapi_krb5 -lkrb5 -lk5crypto -lcom_err -lresolv" \
- "-lgssapi" \
- "-lgssapi -lkrb5 -ldes -lcrypt -lasn1 -lroken -lcom_err" \
-+ "-lkrb5 -lgssapi_krb5 -lkrb5support -lk5crypto -lcom_err" \
- "-lgssapi -lkrb5 -lcrypto -lcrypt -lasn1 -lroken -lcom_err" \
- "-lgssapi -lkrb5 -lgssapi_krb5 -lcrypto -lcrypt -lasn1 -lroken -lcom_err" \
- "-lgssapi -lkrb5 -lhx509 -lcrypto -lcrypt -lasn1 -lroken -lcom_err" \
+--- configure.orig 2015-09-09 11:23:40.000000000 +0900
++++ configure 2015-09-19 03:52:05.021434000 +0900
+@@ -14100,27 +14100,9 @@
+ # problems start to show up.
+ saved_libs="$LIBS"
+ for TRY_LIBS in \
+- "-lgssapi_krb5" \
+- "-lgssapi_krb5 -lkrb5 -lk5crypto -lcom_err" \
+- "-lgssapi_krb5 -lkrb5 -lk5crypto -lcom_err -lresolv" \
+- "-lgssapi" \
+- "-lgssapi -lkrb5 -ldes -lcrypt -lasn1 -lroken -lcom_err" \
+- "-lgssapi -lkrb5 -lcrypto -lcrypt -lasn1 -lroken -lcom_err" \
+- "-lgssapi -lkrb5 -lgssapi_krb5 -lcrypto -lcrypt -lasn1 -lroken -lcom_err" \
+- "-lgssapi -lkrb5 -lhx509 -lcrypto -lcrypt -lasn1 -lroken -lcom_err" \
+- "-lgss -lkrb5"
++ "$($KRB5CONFIG gssapi --libs)"; \
+ do
+- # Note that this does not include $saved_libs, because
+- # on FreeBSD machines this configure script has added
+- # -L/usr/local/lib to LIBS, which can make the
+- # -lgssapi_krb5 test succeed with shared libraries even
+- # when you are trying to build with KTH in /usr/lib.
+- if test "$use_gssapi" = "/usr"
+- then
+- LIBS="$TRY_LIBS"
+- else
+- LIBS="-L$use_gssapi/lib $TRY_LIBS"
+- fi
++ LIBS="$TRY_LIBS"
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking linking as $TRY_LIBS" >&5
+ $as_echo_n "checking linking as $TRY_LIBS... " >&6; }
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+@@ -14163,47 +14145,7 @@
+ no) as_fn_error $? "could not determine proper GSSAPI linkage" "$LINENO" 5 ;;
+ esac
+
+- #
+- # XXXDCL Major kludge. Tries to cope with KTH in /usr/lib
+- # but MIT in /usr/local/lib and trying to build with KTH.
+- # /usr/local/lib can end up earlier on the link lines.
+- # Like most kludges, this one is not only inelegant it
+- # is also likely to be the wrong thing to do at least as
+- # many times as it is the right thing. Something better
+- # needs to be done.
+- #
+- if test "$use_gssapi" = "/usr" -a \
+- -f /usr/local/lib/libkrb5.a; then
+- FIX_KTH_VS_MIT=yes
+- fi
+-
+- case "$FIX_KTH_VS_MIT" in
+- yes)
+- case "$enable_static_linking" in
+- yes) gssapi_lib_suffix=".a" ;;
+- *) gssapi_lib_suffix=".so" ;;
+- esac
+-
+- for lib in $LIBS; do
+- case $lib in
+- -L*)
+- ;;
+- -l*)
+- new_lib=`echo $lib |
+- sed -e s%^-l%$use_gssapi/lib/lib% \
+- -e s%$%$gssapi_lib_suffix%`
+- NEW_LIBS="$NEW_LIBS $new_lib"
+- ;;
+- *)
+- as_fn_error $? "KTH vs MIT Kerberos confusion!" "$LINENO" 5
+- ;;
+- esac
+- done
+- LIBS="$NEW_LIBS"
+- ;;
+- esac
+-
+- DST_GSSAPI_INC="-I$use_gssapi/include"
++ DST_GSSAPI_INC="$($KRB5CONFIG gssapi --cflags)"
+ DNS_GSSAPI_LIBS="$LIBS"
+
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: using GSSAPI from $use_gssapi/lib and $use_gssapi/include" >&5