aboutsummaryrefslogtreecommitdiff
path: root/dns/bind911
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-03-19 11:21:38 +0000
committerMathieu Arnold <mat@FreeBSD.org>2018-03-19 11:21:38 +0000
commitb0dcf1a5601c1a63446ce716d73590ad5fa735a0 (patch)
treeffb55f59207644db99a95a0011f79ddccad4f7bc /dns/bind911
parent9d96fdf5d7f0bafc91ffefb780a9148e18f9074b (diff)
downloadports-b0dcf1a5601c1a63446ce716d73590ad5fa735a0.tar.gz
ports-b0dcf1a5601c1a63446ce716d73590ad5fa735a0.zip
Notes
Diffstat (limited to 'dns/bind911')
-rw-r--r--dns/bind911/Makefile4
-rw-r--r--dns/bind911/distinfo6
-rw-r--r--dns/bind911/files/extrapatch-bind-min-override-ttl36
-rw-r--r--dns/bind911/files/patch-configure8
-rw-r--r--dns/bind911/pkg-plist3
5 files changed, 30 insertions, 27 deletions
diff --git a/dns/bind911/Makefile b/dns/bind911/Makefile
index 8d423ce45adf..ac5bbf5175f0 100644
--- a/dns/bind911/Makefile
+++ b/dns/bind911/Makefile
@@ -3,7 +3,7 @@
PORTNAME= bind
PORTVERSION= ${ISCVERSION:S/-P/P/:S/b/.b/:S/a/.a/:S/rc/.rc/}
-PORTREVISION= 3
+PORTREVISION= 0
CATEGORIES= dns net ipv6
MASTER_SITES= ISC/bind9/${ISCVERSION}
PKGNAMESUFFIX= 911
@@ -16,7 +16,7 @@ LICENSE= MPL20
LICENSE_FILE= ${WRKSRC}/COPYRIGHT
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.11.2-P1
+ISCVERSION= 9.11.3
USES= cpe libedit
diff --git a/dns/bind911/distinfo b/dns/bind911/distinfo
index 4c6cf9846069..036488a510f5 100644
--- a/dns/bind911/distinfo
+++ b/dns/bind911/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1516059868
-SHA256 (bind-9.11.2-P1.tar.gz) = cec31548832fca3f85d95178d4019b7d702039e8595d4c93914feba337df1212
-SIZE (bind-9.11.2-P1.tar.gz) = 9783329
+TIMESTAMP = 1521455716
+SHA256 (bind-9.11.3.tar.gz) = 0d9dde14b2ec7f9cdc3b69f19540c7a2e4eee7b6c727965dfae48810965876f5
+SIZE (bind-9.11.3.tar.gz) = 9523375
diff --git a/dns/bind911/files/extrapatch-bind-min-override-ttl b/dns/bind911/files/extrapatch-bind-min-override-ttl
index f3e60ead8667..d71dfd47f865 100644
--- a/dns/bind911/files/extrapatch-bind-min-override-ttl
+++ b/dns/bind911/files/extrapatch-bind-min-override-ttl
@@ -1,17 +1,17 @@
---- bin/named/config.c.orig 2018-01-04 05:28:11 UTC
+--- bin/named/config.c.orig 2018-01-24 21:23:16 UTC
+++ bin/named/config.c
-@@ -154,6 +154,8 @@ options {\n\
- lame-ttl 600;\n\
- servfail-ttl 1;\n\
- max-ncache-ttl 10800; /* 3 hours */\n\
-+ override-cache-ttl 0; /* do not override */\n\
-+ min-cache-ttl 0; /* no minimal, zero is allowed */\n\
- max-cache-ttl 604800; /* 1 week */\n\
- transfer-format many-answers;\n\
+@@ -171,6 +171,8 @@ options {\n\
+ " max-acache-size 16M;\n\
max-cache-size 90%;\n\
---- bin/named/server.c.orig 2018-01-04 05:28:11 UTC
+ max-cache-ttl 604800; /* 1 week */\n\
++ min-cache-ttl 0; /* no minimal, zero is allowed */\n\
++ override-cache-ttl 0; /* do not override */\n\
+ max-clients-per-query 100;\n\
+ max-ncache-ttl 10800; /* 3 hours */\n\
+ max-recursion-depth 7;\n\
+--- bin/named/server.c.orig 2018-01-24 21:23:16 UTC
+++ bin/named/server.c
-@@ -3713,6 +3713,16 @@ configure_view(dns_view_t *view, dns_vie
+@@ -3699,6 +3699,16 @@ configure_view(dns_view_t *view, dns_vie
}
obj = NULL;
@@ -28,7 +28,7 @@
result = ns_config_get(maps, "max-cache-ttl", &obj);
INSIST(result == ISC_R_SUCCESS);
view->maxcachettl = cfg_obj_asuint32(obj);
---- lib/dns/include/dns/view.h.orig 2018-01-04 05:28:11 UTC
+--- lib/dns/include/dns/view.h.orig 2018-01-24 21:23:16 UTC
+++ lib/dns/include/dns/view.h
@@ -146,6 +146,8 @@ struct dns_view {
isc_boolean_t requestnsid;
@@ -39,9 +39,9 @@
dns_ttl_t maxncachettl;
isc_uint32_t nta_lifetime;
isc_uint32_t nta_recheck;
---- lib/dns/resolver.c.orig 2018-01-04 05:28:11 UTC
+--- lib/dns/resolver.c.orig 2018-01-24 21:23:16 UTC
+++ lib/dns/resolver.c
-@@ -5448,6 +5448,18 @@ cache_name(fetchctx_t *fctx, dns_name_t
+@@ -5477,6 +5477,18 @@ cache_name(fetchctx_t *fctx, dns_name_t
}
/*
@@ -59,11 +59,11 @@
+ /*
* Enforce the configure maximum cache TTL.
*/
- if (rdataset->ttl > res->view->maxcachettl)
---- lib/isccfg/namedconf.c.orig 2018-01-04 05:28:11 UTC
+ if (rdataset->ttl > res->view->maxcachettl) {
+--- lib/isccfg/namedconf.c.orig 2018-01-24 21:23:16 UTC
+++ lib/isccfg/namedconf.c
-@@ -1765,6 +1765,8 @@ view_clauses[] = {
- { "nosit-udp-size", &cfg_type_uint32, CFG_CLAUSEFLAG_OBSOLETE },
+@@ -1766,6 +1766,8 @@ view_clauses[] = {
+ #endif
{ "max-acache-size", &cfg_type_sizenodefault, 0 },
{ "max-cache-size", &cfg_type_sizeorpercent, 0 },
+ { "override-cache-ttl", &cfg_type_uint32, 0 },
diff --git a/dns/bind911/files/patch-configure b/dns/bind911/files/patch-configure
index 2783ccd128f9..bfc0685881cc 100644
--- a/dns/bind911/files/patch-configure
+++ b/dns/bind911/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2017-07-24 05:36:50 UTC
+--- configure.orig 2018-03-08 20:55:28 UTC
+++ configure
-@@ -14402,27 +14402,9 @@ done
+@@ -14465,27 +14465,9 @@ done
# problems start to show up.
saved_libs="$LIBS"
for TRY_LIBS in \
@@ -30,7 +30,7 @@
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking linking as $TRY_LIBS" >&5
$as_echo_n "checking linking as $TRY_LIBS... " >&6; }
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
-@@ -14465,47 +14447,7 @@ $as_echo "no" >&6; } ;;
+@@ -14528,47 +14510,7 @@ $as_echo "no" >&6; } ;;
no) as_fn_error $? "could not determine proper GSSAPI linkage" "$LINENO" 5 ;;
esac
@@ -79,7 +79,7 @@
DNS_GSSAPI_LIBS="$LIBS"
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: using GSSAPI from $use_gssapi/lib and $use_gssapi/include" >&5
-@@ -22825,7 +22767,7 @@ $as_echo "" >&6; }
+@@ -23242,7 +23184,7 @@ $as_echo "" >&6; }
# Check other locations for includes.
# Order is important (sigh).
diff --git a/dns/bind911/pkg-plist b/dns/bind911/pkg-plist
index 346480180355..9e34eb5b04ed 100644
--- a/dns/bind911/pkg-plist
+++ b/dns/bind911/pkg-plist
@@ -145,6 +145,7 @@ include/isc/commandline.h
include/isc/condition.h
include/isc/counter.h
include/isc/crc64.h
+include/isc/deprecated.h
include/isc/dir.h
include/isc/entropy.h
include/isc/errno.h
@@ -170,6 +171,7 @@ include/isc/lang.h
include/isc/lex.h
include/isc/lfsr.h
include/isc/lib.h
+include/isc/likely.h
include/isc/list.h
include/isc/log.h
include/isc/magic.h
@@ -271,6 +273,7 @@ include/pk11/pk11.h
include/pk11/result.h
include/pk11/site.h
include/pkcs11/cryptoki.h
+include/pkcs11/eddsa.h
include/pkcs11/pkcs11.h
include/pkcs11/pkcs11f.h
include/pkcs11/pkcs11t.h