aboutsummaryrefslogtreecommitdiff
path: root/dns/c-ares
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2010-12-19 19:10:48 +0000
committerPeter Pentchev <roam@FreeBSD.org>2010-12-19 19:10:48 +0000
commitf97736f66f0b3733216f93daa1ce61e1ff530459 (patch)
treeaf76b6a5deb17881479ceaa01aead7912b64d458 /dns/c-ares
parent4ec01ce4bf048f5530e0c423e82e112abf76ba69 (diff)
downloadports-f97736f66f0b3733216f93daa1ce61e1ff530459.tar.gz
ports-f97736f66f0b3733216f93daa1ce61e1ff530459.zip
Notes
Diffstat (limited to 'dns/c-ares')
-rw-r--r--dns/c-ares/Makefile8
-rw-r--r--dns/c-ares/distinfo5
-rw-r--r--dns/c-ares/files/ares-config-info.patch8
-rw-r--r--dns/c-ares/files/patch-Makefile.in4
-rw-r--r--dns/c-ares/files/patch-configure16
5 files changed, 29 insertions, 12 deletions
diff --git a/dns/c-ares/Makefile b/dns/c-ares/Makefile
index fd95c72e237e..bbaf70f96599 100644
--- a/dns/c-ares/Makefile
+++ b/dns/c-ares/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= c-ares
-PORTVERSION= 1.7.2
+PORTVERSION= 1.7.4
CATEGORIES= dns
MASTER_SITES= http://c-ares.haxx.se/
@@ -53,7 +53,7 @@ MAKE_ENV= SHLIB_VER="${SHLIB_VER}"
PLIST_SUB= SHLIB_VER="${SHLIB_VER}"
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+= --enable-shared
+CONFIGURE_ARGS+= --enable-shared --disable-werror
MAN3= ares_cancel.3 \
ares_destroy.3 ares_dup.3 \
@@ -67,7 +67,9 @@ MAN3= ares_cancel.3 \
ares_init.3 ares_init_options.3 \
ares_library_cleanup.3 ares_library_init.3 \
ares_mkquery.3 \
- ares_parse_a_reply.3 ares_parse_aaaa_reply.3 ares_parse_ptr_reply.3 \
+ ares_parse_a_reply.3 ares_parse_aaaa_reply.3 \
+ ares_parse_mx_reply.3 \
+ ares_parse_ptr_reply.3 \
ares_parse_srv_reply.3 ares_parse_txt_reply.3 \
ares_process.3 \
ares_query.3 \
diff --git a/dns/c-ares/distinfo b/dns/c-ares/distinfo
index be15d387310e..adcea9e624e6 100644
--- a/dns/c-ares/distinfo
+++ b/dns/c-ares/distinfo
@@ -1,3 +1,2 @@
-MD5 (c-ares-1.7.2.tar.gz) = 50ec9287ec2013dc0fe19f778514280e
-SHA256 (c-ares-1.7.2.tar.gz) = 7472f4d3b86c76b88e9bb09d3b4bdf198bf0d71f2f30b1865b3e7eeba6bf4b31
-SIZE (c-ares-1.7.2.tar.gz) = 629512
+SHA256 (c-ares-1.7.4.tar.gz) = 6b8a7c4ecd67240cca50a345bc955ffbe2d6d1f43982defc77a8e76031a6cb06
+SIZE (c-ares-1.7.4.tar.gz) = 639365
diff --git a/dns/c-ares/files/ares-config-info.patch b/dns/c-ares/files/ares-config-info.patch
index 622d8312e374..f1391897854b 100644
--- a/dns/c-ares/files/ares-config-info.patch
+++ b/dns/c-ares/files/ares-config-info.patch
@@ -4,7 +4,7 @@ Description: Add the ares_get_config() routine used by Unreal IRCd.
Origin: the Unreal IRCd distribution
Author: Peter Pentchev <roam@FreeBSD.org>
Forwarded: no
-Last-Update: 2010-06-11
+Last-Update: 2010-12-19
--- ares.h.orig
+++ ares.h
@@ -23,7 +23,7 @@ Last-Update: 2010-06-11
struct hostent;
struct timeval;
struct sockaddr;
-@@ -511,6 +519,8 @@
+@@ -530,6 +538,8 @@
CARES_EXTERN int ares_get_servers(ares_channel channel,
struct ares_addr_node **servers);
@@ -40,9 +40,9 @@ Last-Update: 2010-06-11
#include "inet_net_pton.h"
+#include "inet_ntop.h"
#include "ares_library_init.h"
+ #include "ares_nowarn.h"
#include "ares_private.h"
-
-@@ -1519,6 +1520,36 @@
+@@ -1536,6 +1537,36 @@
}
#endif /* !WIN32 && !WATT32 */
diff --git a/dns/c-ares/files/patch-Makefile.in b/dns/c-ares/files/patch-Makefile.in
index 5978958aeba8..be3b6ae37ce8 100644
--- a/dns/c-ares/files/patch-Makefile.in
+++ b/dns/c-ares/files/patch-Makefile.in
@@ -1,11 +1,11 @@
Description: Place the pkgconfig file in the correct directory on FreeBSD.
Author: Peter Pentchev <roam@FreeBSD.org>
Forwarded: not-needed
-Last-Update: 2009-03-25
+Last-Update: 2010-12-19
--- Makefile.in.orig
+++ Makefile.in
-@@ -317,7 +317,7 @@
+@@ -322,7 +322,7 @@
CLEANFILES = $(PDFPAGES) $(HTMLPAGES)
DISTCLEANFILES = ares_build.h
diff --git a/dns/c-ares/files/patch-configure b/dns/c-ares/files/patch-configure
new file mode 100644
index 000000000000..a152d865e2a9
--- /dev/null
+++ b/dns/c-ares/files/patch-configure
@@ -0,0 +1,16 @@
+Description: Fix a bashism in the -Werror test.
+Forwarded: https://github.com/bagder/c-ares/pull/3
+Author: Peter Pentchev <roam@ringlet.net>
+Last-Update: 2010-12-19
+
+--- configure.orig
++++ configure
+@@ -24718,7 +24718,7 @@
+
+
+ CARES_CFLAG_EXTRAS=""
+-if test X"$want_werror" == Xyes; then
++if test X"$want_werror" = Xyes; then
+ CARES_CFLAG_EXTRAS="-Werror"
+ fi
+