aboutsummaryrefslogtreecommitdiff
path: root/dns/dhid/Makefile
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2000-02-05 22:07:51 +0000
committerKris Kennaway <kris@FreeBSD.org>2000-02-05 22:07:51 +0000
commit28989c4601ed030a5b58826570d752a61ee41dd8 (patch)
tree7ce4eae8439e3246bc9023196668a5426d45bff0 /dns/dhid/Makefile
parenta80761c0d3af2b965dfb6dda95fc89787bbd5558 (diff)
downloadports-28989c4601ed030a5b58826570d752a61ee41dd8.tar.gz
ports-28989c4601ed030a5b58826570d752a61ee41dd8.zip
Notes
Diffstat (limited to 'dns/dhid/Makefile')
-rw-r--r--dns/dhid/Makefile12
1 files changed, 4 insertions, 8 deletions
diff --git a/dns/dhid/Makefile b/dns/dhid/Makefile
index 8eea3762a59b..78a4c87bc0d9 100644
--- a/dns/dhid/Makefile
+++ b/dns/dhid/Makefile
@@ -1,31 +1,27 @@
# New ports collection makefile for: dhid
-# Version required: 3.0
+# Version required: 3.1
# Date created: Sat Aug 21 06:13:59 EDT 1999
# Whom: Oryx Gazella <oryx@ungulate.net>
#
# $FreeBSD$
#
-DISTNAME= dhid-3.0
+DISTNAME= dhid-3.1
CATEGORIES= net
MASTER_SITES= ftp://ftp.dhis.org/pub/dhis/
MAINTAINER= oryx@ungulate.net
-MAN1= dtool.1
MAN8= dhid.8
post-patch:
- @${ECHO} "===> Patching dtool script and dhid.h"
- ${PERL} -i -p -e "s^__PREFIX__^${PREFIX}^g" ${WRKSRC}/dtool
+ @${ECHO} "===> Patching dhid.h"
${PERL} -i -p -e "s^__PREFIX__^${PREFIX}^g" ${WRKSRC}/dhid.h
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/dhid ${PREFIX}/sbin
- ${INSTALL_SCRIPT} ${WRKSRC}/dtool ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/dhid.8 ${PREFIX}/man/man8
- ${INSTALL_MAN} ${WRKSRC}/dtool.1 ${PREFIX}/man/man1
- ${INSTALL} ${COPY} -o root -g wheel -m 600 ${WRKSRC}/dhid.conf ${PREFIX}/etc
+ ${INSTALL} ${COPY} -o root -g wheel -m 600 ${WRKSRC}/dhid.conf ${PREFIX}/etc/dhid.conf.sample
post-install:
@if [ ! -f ${PREFIX}/etc/rc.d/dhid.sh ]; then \